"Unauthorized" project build fails but Duration timer continues running

A colleague pushed changes to Github, but he was not registered on CircleCI. The commit triggered a build pipeline but it failed with error “Unauthorized”.
Now in the list of Pipelines, those Pipelines appear to be Cancelled but the Duration timer is still ticking (now is up to 18hrs and counting). This is only an issue in the new UI, the old UI doesn’t show any duration.

I have same issue, although not triggered by anything out of the ordinary. Worked 4 days ago, suddenly Unauthorized – on checkout, I presume, but there are 0 details associated with the error.

Did you figure this out @mfabiani-av?

@Jiropole We solved the “Unauthorized” issue (my colleague had not registered on CircleCI yet, so his push to github was not authorized to be built). Next build worked fine, but this bug report is really about the timer that continues running even if the build has failed.

Thanks @mfabiani-av. My issue was different, only resolved by regenerating the WebHooks key. But yes, the timer running is definitely confusing.