422 Error when trying to follow project

I’m receiving an error remakingly similar to the one described in this post: 422 Error when trying to Follow/Start build project

When clicking in ‘Follow Project’, the project remains unfollowed, and nothing happens, no message at all. However, checking the console, I noticed we have this error showing up:

{message: “Received a 422 from the /api/v1.1/project/github/org-name/project-name/follow api.”}

Any ideas of what might be happening?

Thanks for reaching out!

There’s the possibility here that the repo may have an old/stale webhook set up, which is in turn preventing CircleCI from recreating the webhook.

Could you please try navigating to your repo’s Settings page, and the revoking the CircleCI webhook? When you try to follow again the webhook should be created as normal and hopefully unblock you.

Please let me know how you get on!


Hey Al! Thanks, that worked perfectly! I just think it’s very confusing, since no message is shown at all that could indicate a solution for this problem in the UI

I’m glad that worked! I’m also a strong believer in empowering people with error messages, so I’ll take your comments to the team as feedback - thanks!