Github webhook failing


#1

Hey guys,

I can’t for the life of me, figure out why the github webhook for CircleCI is working for one repo and not the other. Is this because I am on the free plan or maybe because I don’t have the proper organization privileges. Every webhook request returns a 400.

Here are some of the response headers,

Connection: keep-alive
Content-Length: 0
Date: Sat, 18 Jun 2016 15:42:33 GMT
Server: nginx
X-Frame-Options: DENY
X-Route: /hooks/github


#2

Is this a GitHub org you are having the issues on? Have you tried removing and re adding the webhook?


#3

I have extractly same issues. All own projects in CircleCI didn’t build since last Saturday. Many many commit/push or PR didn’t trigger any builds in CircleCI


#4

Yeah, it’s a github org, I’m having the issues on. I’ve tried removing and readding the webhook multiple times. I created the repo, but am not an admin of the org itself. Is there a possibility that’s the issue?


#5

It’s possible. I don’t have an org myself, so I’ll have to defer to staff or another community member on this one.


#6