Following Repo not building anymore


#1

As of today, as far as I know, it appear that CircleCI is no longer following or hooked into my Github repository anymore. I’ve checked the settings in my account and appears to be setup. But when I commit/push to Github, it no longer triggers a build in CircleCI. Can you help?


#2

Try telling CircleCi to stop building and then build again in the project settings here. That should remove and re-add the webhook


#3

Tried that. Still not building when I do a commit. What next?


#4

When you say commit, you mean when you do a push to GitHub, correct?

When you click on the circleci webhook name under https://github.com/<user>/<repo>/settings/hooks, what does it show under recent deliveries?


#5

Yes, I mean when I do a commit/push, it does nothing.
Something strange within github.com///settings/hooks. Yesterday CircleCI was in there under Services. Today it is not there. So I re-added it under Services and tested with a commit/push - still does not work. Do I need to add it under Webhooks? I don’t know why this all the sudden stopped working. We’ve been using CircleCI for over a year now. Very strange.


#6

I see what happened with the missing Service. When you had me “Unfollow” the repo within my Project Settings, it removed the service from github. And when I “Re-Follow” the repo it does not add it back. Am I doing something wrong. Something is apparently broken between my CircleCI and Github. Can you help please?! We’re unable to deploy code now. Thanks.


#7

It seems like you will have to wait for staff to take a look, sorry, you can also try emailing them if you have a support plan.


#8

When can I expect to have staff look at it? What email can I used to contact them directly?


#9

Any progress on this? I’m still unable to use CircleCI.


#10

I cannot believe how far you guys have fallen and how lousy your support is. CircleCI has essentially become unusable for me and you’ve offered no solutions.


How to re-add webhook?
#11

Hi there,

Thanks for the feedback. We’re currently taking on more support staff to cope with growth. Support tickets lodged by customers on paid plans get priority. We want to dedicate more time to the community forums as soon as we can.

The steps we recommend to get the project building again should be carried out in order:

  1. Unfollow the project from the CircleCI ‘Project settings’ page - click the orange ‘Unfollow’ button
  2. Remove the webhook for the affected repo on GitHub (Settings > Webhooks and services)
  3. Re-add the project by following the project again on the CircleCI ‘Project settings’ page

Can you try that one more time?

Any relevant screenshots can also help us diagnose what’s happening.


#12

After following the outlined steps, it appears to be working once again. Thank you so much.


#13

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.