Commits doesn't tiggrer a build


#1

Hello!

I’ve added a repo from GitHub successfully and one first build appeared. Everything was perfect but then I started to commit some code to my master branch, expecting to have new builds, and nothing happens.

I’m using all the default configurations - just trying to make it work. I’ve tryied adding a yaml file and doing a merge instead of a normal commit, however is still not working.

Is a NodeJS project, but I don’t think it makes any difference.

Any ideas?


#2

If the project is public, can you provide a link? Same with your circle.yml file? If it’s private, can you please PM me the links so I can take a look?

A quick test, try unfollowing your project and then following it again on CircleCI to reset all of the GitHub hooks. Sometimes that’s an easy way to retrigger everything.


#3

Thanks for your reply.

Unfollow and follow again doesn’t work. I’ll sent you a PM because this is a private repository.

This is the content of my circle.yml file (I also tried without this file):

general:
   branches:
     only:
        - master
        - dev

#4

Solved!

I removed GitHub’s permission and then returned it. In addition, the webhook configuration had not been established.


#5

Hmm so is everything good now?

If you’re not, I strongly suggest having the circle.yml file in every branch since you are doing whitelisting. This allows CircleCI to run the branches (or not) in a more predictable matter.


#6

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.