Debug with SSH has stopped working in BitBucket

#1

I successfully used the SSH option on a private BitBucket repo two days ago, and now CircleCI does not believe I have any SSH keys registered. When I use this option, I get:

Failed to enable SSH
No SSH key is found. Please make sure you’ve added at least one SSH key in your VCS account.

I am using an organisation BitBucket account and a free tier CircleCI account.

I have tried deleting unused accounts in my SSH keys UI:

https://bitbucket.org/account/user/<user>/ssh-keys/

That did not help. I also deleted a public key (that had previously been successful) and re-added it, also to no avail.

When this was working two days ago, I did not use add_ssh_keys, so I assume that is not required. I will, however, try that. It does not seem to be mentioned in the docs.

I assume that SSH keys should be registered as per these instructions, rather than using the read-only SSH keys that one can register per project.

This seems to replicate this old problem, but that did not have a resolution.

1 Like

#2

Hi Halfer,

Thanks for reaching out.

This might be a bug on our end introduced by a recent internal change that we have made to our BitBucket system (BitBucket are switching off their 1.0 API in April and we had to migrate to version 2 (sounds very familiar :rofl:)).

I’ll roll back that change now.

Marc

1 Like

#3

Lovely, thanks @marc - if you need any logs/timings, I can ping you the name of the private repo via PM.

Let me know when it is rolled back, and I’ll test it. Would a Rebuild with SSH be okay, or would I need to push a commit and then Rebuild that? (I think there are quite a few things in Circle where a rebuild keeps a lot of old context).

0 Likes

#4

I never thought to reply earlier. The rollback will have gone live this morning about 20 minutes after my message. On my phone so I can’t check the precise details!

0 Likes

#5

Hrm, I never actually merged the PR this morning. It’s rollong out now :pleading_face:

0 Likes

#6

I’ve tried this again this morning @marc, and I get the same problem in this organisation build:

Failed to enable SSH
No SSH key is found. Please make sure you've added at least one SSH key in your VCS account.

The new SSH key I uploaded to my personal profile seems to be unused. This was the one I deleted and re-added on Friday:

Did the rollback not go live, or is there another problem? :slightly_smiling_face:

1 Like

#7

Hello @halfer, big fan! Thanks for everything you do. The rollback went live, but it looks like that change was unrelated to this issue since it’s still happening. Could you DM me some job links that show the issue with no keys found? I’ll add them to my report so we can get this sorted.

0 Likes

#8

Sure, I’ll ping you something via PM. I’m probably being as daft as a brush, but as far as I can tell, the config is effectively unchanged since SSH sessions last worked.

Thank you for the kind words! :blush:

0 Likes

#9

I’m running into the same issue. Yesterday I could SSH into the container, now I get the failure message. No SSH key is found. Please make sure you've added at least one SSH key in your VCS account

I’m a bit stuck without the ssh ability (local build only takes me so far).

1 Like

#10

Hi, @claytron5000,

Can you open a ticket so we can take a look at the project and figure out why it’s not seeing your key?

0 Likes

#11

Done and done, thanks.

1 Like

#12

Running into the same issue as well. Will open a ticket as mentioned above.

1 Like

#13

me too. i’m unable to login at all using Bitbucket now too.

0 Likes

#14

If you were getting a 500 error trying to login to CircleCI that was a different error that has since been resolved.

0 Likes

#15

Do we have any window into how long it’s going to take to get a response to our ticket on this issue? It’s blocking current work. Considering moving to a different CI platform over it.

0 Likes

#16

Hello,

It’s being actively investigated now. There was a bit of a delay with the US holiday, but we have our engineering team investigating and I have made the support manager aware of your ticket.

1 Like

#17

Hi guys. What status of this issue? I have same problem. My ssh key from Bitbucket don’t use on ssh debug. I got :
No SSH key is found. Please make sure you've added at least one SSH key in your VCS account

0 Likes

#18

Hello,

I don’t have a solution yet, we are working with BitBucket to see what may have changed since it seems the API call we use related to the SSH keys no longer wants to use the creds we are passing. We are aware of the pain this is causing and are trying for a solution as soon as possible.

0 Likes

Can’t SSH into Build Machine for Bitbucket with CI2
Renamed repo, now getting Failed to enable SSH
#19

any update here?

0 Likes

#20

I’m having the same problem “No SSH key is found.” for all my projects I used to run for years.

0 Likes