Problem getting SSH (remote login) working on a new CI project


I’m pretty new to CircleCI and I’m running into an issue getting the “rerun job with SSH” working for a new CI project.

When I rerun a job with SSH I get the following error.

“Failed to enable SSH
No SSH key is found. Please make sure you’ve added at least one SSH key in your VCS account.”

Simple enough except I’m not clear what i’m suppose to connect with the private SSH key I add. This project does of the SSH key used to clone the repo, but no other keys.

We have another project where SSH works, it does have a couple SSH keys listed One for and one for but those are used to get code/modules needed from a couple other repos.

I didn’t setup the circleci project where SSH works, so unsure what steps I need to do to get this working.

I know this is a simple/silly question but just confused at this point.

My thought is to just setup another SSH key to bitbucket, but that is just a shot in the dark and unsure why that would actually work.

Thanks much for any help you can give.

New to circleci guy

Hello.I believe you are hitting this bug: Debug with SSH has stopped working in BitBucket

1 Like

Thanks so much!

Being new to CI I assumed it was something I was doing wrong or not understanding.

I went back to our other project and tried to rerun a job with SSH and sure enough it failed with the same error.

Just to clarify though, the only SSH key needed to do this is the SSH key we use to clone the repo, e.g. checkout key for the repo?

Thanks again.


Yep. Normally no extra keys are needed for this, though in the BitBucket case we may have to make changes depending on the outcome of the talks with Atlasssian. Best bet is to watch that thread for updates.