SSH debugging: Failed to enable SSH

ssh
keys
2.0
debugging

#1

Hi all,

I just tried to access my CircleCI 2.0 build using SSH as explained in the docs. After rebuilding with SSH I went to the build’s “Enable SSH” tab and expand it. There it did not display the command needed to connect but the following error message:

Failed to enable SSH
No SSH key is found. Please make sure you’ve added at least one SSH key in your VCS account.

It is not clear to me what I am missing out? I tried creating a BitBucket user key in the “Checkout SSH keys” section but this did not help.

Any ideas? Thanks in advance.


#2

I’m also facing the same issue. I’ve tried multiple different ways to make this work:

Failed to enable SSH
No SSH key is found. Please make sure you've added at least one SSH key in your VCS account.
  1. Adding a new private SSH key into the SSH Permissions tab (and adding the public key to bitbucket project keys.

  2. Adding a fingerprint to the circle.yml config

- add_ssh_keys:
          fingerprints:
            - "0e:..."
  1. Using various different usernames for the key - bitbucket username and email

#3

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.