Could not find a usable config.yml, you may have revoked the CircleCI OAuth app

I’ve just started seeing this error in our builds -

We don’t use the github app, we use a deploy key and a webhook from the github repo.

Do we need to change anything or is this a temporary problem? I notice that this has happened before - Release build fails because "deleted the CircleCI OAuth app" - #3 by yFujiwara


Can you please raise a support ticket answering the following questions:

Are you are only seeing this issue when a specific user triggers a build?
Is this the only project in which you are seeing this issue?
Can you also confirm that you have tried signing out of CircleCI and logging back in and continuing to see the issue?

Kind Regards
Owen Oliver

Hi there Owen. Thanks for getting back. We since haven’t seen this issue in a while. I wonder if it’s an issue with a PR from a specific fork. Anyway hard to debug and maybe not worth investigation unless it happens a bit more… I’ll let you know if it does.

Maybe same problem occurs here.

Only contributers PR fail.
Detect and set current working directory by js-everts · Pull Request #95 · endaaman/tym · GitHub ttps://

But my PR never fail.

I revoked and re-signed in hundred times but the problem is not solved.

We are seeing this issue for contributors as well in GitHub - adobe/react-spectrum: A collection of libraries and tools that help you build adaptive, accessible, and robust user experiences.
See this PR as an example
Allow custom close delay for tooltips by bill-kerr · Pull Request #4128 · adobe/react-spectrum · GitHub

We started seeing this recently in GitHub - coredns/coredns: CoreDNS is a DNS server that chains plugins … seemingly intermittently in submitted PRs. If I close and re-open a PR that is affected, it usually runs our circleci job successfully. The circleci pipeline error itself however appears to permanently remain in the Task Status, despite subsequent successful runs.