Intermittent Config Processing Error

We have been using CircleCI for our builds for months and beginning today (September 6), we have had multiple builds fail due to Config Processing Error with the error message indicating that no configuration can be found in the project.

The config.yml is in the .circleci directory in the root of the project and has not been modified in our repository in months (last update December 2021). Like the error suggests, rerunning the build through the web UI does not fix the problem - we get the same error. We tried pushing an empty commit to main which re-triggered the build and then ran successfully, so the configuration file does not seem to be the problem. Additionally several of our builds in the same project did run and execute correctly without any intervention necessary. Any advice on resolving the intermittent failure would be helpful.

1 Like

Hi @simonh-mainstay,

Sorry to hear you are running into this issue.

One possible cause for this is CircleCI failing to successfully pull the config.yml file from your repository.

Currently GitHub is showing an incident for degraded services which might be affecting this:

GitHub Status - Incident on 2022-09-06 22:56 UTC

If you would like us to take a deeper look, I would suggest opening a support ticket on the following page:

1 Like

@aaronclark Thank you for the quick reply! We did see that Github was having some issues today - we believe our build failures were outside the time range for their reported outages (our build failures happened around 13:30, 14:20, and 20:10 UTC) but we will keep an eye on things tomorrow. If we are still seeing the same issue we’ll open up a support ticket. Thanks!

1 Like

@aaronclark I’ve been experiencing the same issue as @simonh-mainstay on most of my builds for the past 3-4 days or so. It seems pretty random.

No configuration was found in your project. Please refer to to get started with your configuration.

Has anyone else recently experienced this? From what I can see renaming features branches (instead of rerunning them) is a workaround, although not ideal as you can imagine.

Hi @aaronclark we are seeing the same issue again today (it has been fine since I last posted until today). I’ll open a support ticket as well but it’s the same situation that I originally posted about.

Hi @squallstar @simonh-mainstay ,

Can you verify if your accounts have authorized CircleCI or not? If possible, I would like to have you try accessing and then triggering a new build by pushing a new commit.

@aaronclark new commits for the same branch produce the same issue right away. However, simply renaming the branch does the job (although the reason for failing seems quite random, e.g. the branch names don’t really have special characters or anything that could lead to a general failure).

We are having the same problem, some builds just randomly fail with this issue.