Existing project now fails with "No configuration was found in your project"

A project which has been building successfully for weeks has started failing for no reason with “No configuration was found in your project”. There have been no changes to the config file.

Has anybody come across this and have some hack/workaround to fix it? Have raised a support ticket but we can’t wait with broken builds for their 3-5 day response time.

Have tried:

  • “Stop building”, then setting up project again (as suggested elsewhere). Same result.
  • Creating a new repo with the same content. First build works; subsequent commits (to any file) cause failure with the same result.

I can get it to build if I make a trivial edit to the config file within CCI, but subsequent commits (to any file, not the config file) result in failures.

Just to reiterate - it’s an existing project that has been building fine, and there have been no config file changes. I assume something’s broken in CCI; currently seems like it’s just not a reliable service.

EDIT: Now it’s all our projects. Circle CI is so broken.

1 Like

Same here. Using v2 config. Pipeline was working perfectly but yesterday started failing because config.yml is not found by circle.

Yep, same here. Some bug in circleci causing this?

I have also sent a message to circleci support.

Now it’s affecting all our projects.
Had some contact from CCI support but just routine tasks (reset auth etc) that didn’t help. No reply since then - seems to have landed in their too hard basket.

Hi there,

I am sorry to hear that this was/is affecting your projects.

We have acknowledged this issue and have declared an incident here:

As this incident is now resolved as of Aug 17, 2022 - 17:45 UTC, could you let us know here if new runs on the projects are now working?

If not, could you perhaps reference this reply here in your Support ticket, and we will look into it!
Thank you for your patience in this matter.

We experienced the same problem but one repo is still not able to run. Tried exactly what OP said as well - new commits and everything, and it’s still not triggering because it says “No configuration was found in your project” even though it was building fine for weeks/months before yesterday.

This is still happening, albeit intermittently

Getting the below message in the build, and there’s no way to re-trigger as the “Rerun” buttons are disabled.

#!/bin/sh -eo pipefail
# No configuration was found in your project. Please refer to https://circleci.com/docs/2.0/ to get started with your configuration.
# 
# -------
# Warning: This configuration was auto-generated to show you the message above.
# Don't rerun this job. Rerunning will have no effect.
false

Exited with code exit status 1
CircleCI received exit code 1

Hi Everyone,

For anyone still experiencing this, could you please try performing a re-authentication by logging out of CircleCI, clear the cache and cookies of your browser and log back in? This would allow our system to reissue a token for your user.

If you are still experiencing this, please submit a support ticket here: https://support.circleci.com/hc/en-us/requests/new

Thanks!

This has been happening to our organization for the past month or two and it has become more frequent recently. Performing a full re-authentication seems a little drastic and would be very disruptive to us. Is there any other solution?

This was the advice we got when originally experiencing this problem. It didn’t help in our case, and eventually CCI fixed something on their end and things started working again.

However, this problem arose again for us a couple of weeks ago. Raised a ticket and got a few "try again"s (no luck) and a “show us your config file” (nothing has changed there).

We’ve now given up on Circle CI and moved to another service. Obviously this is a critical function and we can’t have it spontaneously breaking with no apparent solution.

It is happening again with a couple of our projects. It is seriously impairing our work.

Interestingly we can trigger a workflow from the UI using the Trigger Pipeline button, but every time we trigger from a git commit or a tag we see the spurious message “No configuration was found in your project.”.

We are also experiencing this problem with our project. We have been running CircleCI for years and haven’t had any issues with the config file until now. We are running the latest major version (2). I am able to access the config file via the CircleCI web interface, so the file does exist. We have not made changes to the config file recently.

I reached out to CircleCI support via email. The issue is now resolved on our end. A fix had to be pushed, which addressed the issue.