No configuration was found; .circleci/config.yml exists

I just set up CircleCI in this project, but my first build returned the following message:

#!/bin/sh -eo pipefail
# No configuration was found in your project. Please refer to to get started with your configuration.
# -------
# Warning: This configuration was auto-generated to show you the message above.
# Don't rerun this job. Rerunning will have no effect.
Exited with code 1

I’m not sure why I’m getting this error, the .circleci/config.yml file exists and is valid. Also, this is not the same as this because there are no spaces in the filenames.

You deleted the CircleCI config in master/d6cbab874762a591f47cdde56a42d101b587b47d when you introduced the Travis config.

(Aside: IMO, your commit messages are not long or descriptive enough. Fellow developers on your projects will appreciate more substantive descriptions of each commit :slightly_smiling_face:).

True, I did delete the circle config. But you can clearly see it was there.

And thanks for the tip :wink: tbh I was being lazy with the commit messages.

It may have worked while it existed, but it won’t work now - it needs to appear in the branch you’re building.

It didn’t. I tried multiple times, that’s why I switched to Travis.

Right, so you are no longer looking for an answer. Fair enough.

My general advice with CI is to be persistent. The practice of giving up after a day and switching to another provider means that you will soon run out of providers to try. I’ve not used Travis for years (I seem to recall it was very good) but Circle really does work well also.

In the end it turned out that I couldn’t make Netlify wait for the CI to finish, so I stopped using one together. I have had this problem before, though, and every time was totally unable to solve it.

Just to have it out there, I feel like CircleCI is much faster than Travis.

I ran into this problem as well, tried deleting the file and then recommitting it but that didn’t work.
I ended up ‘stop building’ the project in the circleCI dashboard, and then starting building it again, which finally made it recognise that it did have a configuration file again.

I experienced this problem also: added .circleci/config.yml and pushed. Validated in dashboard that its OK, but it simply refuses to run the build asking to add .circleci/config.yml?! Not very good start for this kind of tool if we are to be honest