Release build fails because "deleted the CircleCI OAuth app"

For all of my release builds, I just get an error that says “Could not find a usable config.yml because you deleted the CircleCI OAuth app.” It doesn’t even begin the build.
It just started happening. It doesn’t happen for any other projects at my organization, or for regular builds on the same project.
We do have a config.yml file in the .circleci directory of the project.
As far as I know, no one “deleted our circleIC oauth app”. I’m not sure where to start debugging this.

I’m having the same problem. No changes were done. Did circleci do any changes?

I’m having the same problem.
It was resolved when I logged back into circle ci with github.


Same issue:

  • Nothing was changed with regard to CircleCI or the config.
  • Creating a CircleCI account did not resolve the problem.
  • Creating another PR on the same repo results in the same error.
  • When others push on top of my PR, the error does not occur.

CircleCI has an incident report about it CircleCI Status - Config Fetching is Failing for Some Users

I just kicked off another build and it seems to be working, so the problem may be resolved.

1 Like

hi folks!

yes, indeed, we have declared an incident around this.

thanks @academia-ci for linking it here too!
We have since resolved this incident, and your newer builds should work fine now.
If this is still not the case, please do not hesitate to file a Support ticket with us: (Filing a ticket is free, as in beers.)

Happy to look into it further!
Thank you all for your patience in this issue :bowing_man:

1 Like

How do I fix this issue? I’m seeing it here Fix typo (casing issue) inside Getting Started Guide causing a 404 when clicking on the Components link by sync · Pull Request #2273 · infinitered/ignite · GitHub but there is a config file

I cannot rerun the workflow from CircleCI, both options are grayed out. If I click on edit the config file, it gives me a 404

1 Like

The same problem occurs here.

Myy PR is OK.

Only contributers’ PR fail.

I revoked and re-signed in hundred times but the problem is not solved.