Ubuntu 14.04 Build Image Update 201710-01

build-image

#1

We will update our Ubuntu 14.04 (Trusty) build image between the 30th and 31th of Oct, 2017. This post details the changes - let us know if you have any concerns.

Do you want to control your own build image? Try CircleCI 2.0! 2.0 lets you use Docker images of your choice.


Go

Go will be updated to 1.9.1

Ruby

Ruby 2.3.3 wil be removed

Ruby 2.4.0 wil be removed

Ruby 2.3.5 will be added

Ruby 2.4.2 will be added

NodeJS

Yarn will be updated to 1.1.0

NodeJS v6.11.4 (LTS) will be added

PHP

PHP 7.0.4 will be removed

PHP 7.1.9 will be removed

PHP 7.1.0 will be removed

PHP 7.0.24 will be added

PHP 7.1.9 will be added

Git

Git will be updated to 2.14.2

Curl

Curl and libcurl will be updated to 7.56. This updates are not included in the following “All Changes” because it’s built and installed from source.

All Changes

--- versions.json.before	2017-10-25 04:51:40.671002086 +0000
+++ versions-ubuntu-14_04-XXL.json	2017-10-25 04:51:40.378978367 +0000
@@ -1,12 +1,12 @@
 {
   "summary": {
-    "build-image": "ubuntu-14.04-XXL-1239-04cfc8d",
+    "build-image": "ubuntu-14.04-XXL-1321-3401d20",
     "google-chrome": "54.0.2840.100",
     "chromedriver": "2.27.440175",
     "firefox": "47.0.1",
     "mongod": "3.0.7",
-    "psql": "9.5.7",
-    "mysqld": "5.7.19",
+    "psql": "9.5.9",
+    "mysqld": "5.7.20",
     "ruby": {
       "default": "2.2.6p396",
       "all": [
@@ -14,13 +14,13 @@
         "ruby-2.1.9",
         "ruby-2.2.6",
         "ruby-2.2.7",
-        "ruby-2.3.3",
         "ruby-2.3.4",
-        "ruby-2.4.0",
-        "ruby-2.4.1"
+        "ruby-2.3.5",
+        "ruby-2.4.1",
+        "ruby-2.4.2"
       ],
-      "gem": "2.6.12",
-      "rvm": "1.29.2 (latest)",
+      "gem": "2.6.14",
+      "rvm": "1.29.3 (latest)",
       "bundler": "1.14.6"
     },
     "python": {
@@ -67,12 +67,13 @@
         "v5.6.0",
         "v5.7.0",
         "v6.1.0",
+        "v6.11.4",
         "v8.1.4",
         "v8.2.0"
       ],
       "npm": "2.14.12",
       "nvm": "0.31.0",
-      "yarn": "0.27.5"
+      "yarn": "1.1.0"
     },
     "php": {
       "default": "5.6.17",
@@ -86,11 +87,11 @@
         "7.0.11",
         "7.0.17",
         "7.0.20",
-        "7.0.4",
+        "7.0.24",
         "7.0.7",
-        "7.1.0",
         "7.1.3",
-        "7.1.6"
+        "7.1.6",
+        "7.1.9"
       ]
     },
     "java": {
@@ -113,7 +114,7 @@
       "cabal": "1.24.0.2",
       "alex": "3.1.7",
       "happy": "1.19.5",
-      "stack": "1.4.0"
+      "stack": "1.5.1"
     },
     "scala": {
       "all": [
@@ -132,7 +133,7 @@
     },
     "redis": "2.8.4",
     "memcached": "1.4.14",
-    "git": "2.13.0",
+    "git": "2.14.2",
     "git-lfs": "1.5.4",
     "gcc": "4.8.4",
     "g++": "4.8.4",
@@ -149,13 +150,13 @@
     "riak": "2.1.3",
     "couchdb": "1.6.1",
     "geos": "3.5.0",
-    "go": "1.8.3",
+    "go": "1.9.1",
     "gradle": "1.10",
     "phantomjs": "2.1.1",
     "docker": "1.9.1",
     "docker-compose": "1.5.2",
-    "gcloud": "162.0.1",
-    "aws-cli": "1.11.121",
+    "gcloud": "176.0.0",
+    "aws-cli": "1.11.177",
     "android": {
       "build-tool": "24.4.1",
       "build-tools": [
@@ -201,10 +202,10 @@
     "alex-3.1.7": "3.1.7-3~trusty",
     "ant": "1.9.3-2build1",
     "ant-optional": "1.9.3-2build1",
-    "apache2": "2.4.7-1ubuntu4.16",
-    "apache2-bin": "2.4.7-1ubuntu4.16",
-    "apache2-data": "2.4.7-1ubuntu4.16",
-    "apache2-dev": "2.4.7-1ubuntu4.16",
+    "apache2": "2.4.7-1ubuntu4.18",
+    "apache2-bin": "2.4.7-1ubuntu4.18",
+    "apache2-data": "2.4.7-1ubuntu4.18",
+    "apache2-dev": "2.4.7-1ubuntu4.18",
     "apparmor": "2.8.95~2430-0ubuntu5.3",
     "apport": "2.14.1-0ubuntu3.19",
     "apport-symptoms": "0.20",
@@ -240,7 +241,7 @@
     "busybox-static": "1:1.21.0-1ubuntu1",
     "byobu": "5.77-0ubuntu1.2",
     "bzip2": "1.0.6-5",
-    "ca-certificates": "20160104ubuntu0.14.04.1",
+    "ca-certificates": "20170717~14.04.1",
     "ca-certificates-java": "20130815ubuntu1",
     "cabal-install-1.24": "1.24.0.2+git20161208.0.c5ebf12-3~14.04",
     "cassandra": "3.4",
@@ -261,6 +262,7 @@
     "circleci-nodejs-5.6.0": "1",
     "circleci-nodejs-5.7.0": "1",
     "circleci-nodejs-6.1.0": "1",
+    "circleci-nodejs-6.11.4": "1",
     "circleci-nodejs-8.1.4": "1",
     "circleci-nodejs-8.2.0": "1",
     "circleci-php-5.5.31": "5",
@@ -272,11 +274,11 @@
     "circleci-php-7.0.11": "5",
     "circleci-php-7.0.17": "5",
     "circleci-php-7.0.20": "5",
-    "circleci-php-7.0.4": "5",
+    "circleci-php-7.0.24": "5",
     "circleci-php-7.0.7": "5",
-    "circleci-php-7.1.0": "5",
     "circleci-php-7.1.3": "5",
     "circleci-php-7.1.6": "5",
+    "circleci-php-7.1.9": "5",
     "circleci-python-2.7.10": "2",
     "circleci-python-2.7.11": "2",
     "circleci-python-2.7.12": "2",
@@ -300,10 +302,10 @@
     "circleci-ruby-2.1.9": "1",
     "circleci-ruby-2.2.6": "1",
     "circleci-ruby-2.2.7": "1",
-    "circleci-ruby-2.3.3": "1",
     "circleci-ruby-2.3.4": "1",
-    "circleci-ruby-2.4.0": "1",
+    "circleci-ruby-2.3.5": "1",
     "circleci-ruby-2.4.1": "1",
+    "circleci-ruby-2.4.2": "1",
     "cloud-guest-utils": "0.27-0ubuntu9.1",
     "cloud-image-utils": "0.27-0ubuntu9.2",
     "cloud-init": "0.7.5-0ubuntu1.15",
@@ -324,7 +326,7 @@
     "cron": "3.0pl1-124ubuntu2",
     "cryptsetup": "2:1.6.1-1ubuntu1",
     "cryptsetup-bin": "2:1.6.1-1ubuntu1",
-    "curl": "7.35.0-1ubuntu2.10",
+    "curl": "7.35.0-1ubuntu2.12",
     "daemon": "0.6.4-1",
     "dash": "0.5.7-4ubuntu1",
     "dbus": "1.6.18-0ubuntu4.3",
@@ -337,7 +339,6 @@
     "debianutils": "4.4",
     "debootstrap": "1.0.59ubuntu0.8",
     "default-jre-headless": "2:1.7-51",
-    "desktop-file-utils": "0.22-1ubuntu1.1",
     "dh-apparmor": "2.10.95-0ubuntu2.6~14.04.1",
     "dh-python": "1.20140128-1ubuntu8.2",
     "diffutils": "1:3.3-1",
@@ -345,7 +346,7 @@
     "distro-info-data": "0.18ubuntu0.7",
     "dmidecode": "2.12-2",
     "dmsetup": "2:1.02.77-6ubuntu2",
-    "dnsmasq-base": "2.68-1ubuntu0.1",
+    "dnsmasq-base": "2.68-1ubuntu0.2",
     "dnsutils": "1:9.9.5.dfsg-3ubuntu0.7",
     "docker-engine": "1.10.3-0~trusty",
     "dosfstools": "3.0.26-1",
@@ -359,9 +360,9 @@
     "eject": "2.1.5+deb1+cvs20081104-13.1",
     "elasticsearch": "1.7.2",
     "emacs": "45.0ubuntu1",
-    "emacs24": "24.3+1-2ubuntu1",
-    "emacs24-bin-common": "24.3+1-2ubuntu1",
-    "emacs24-common": "24.3+1-2ubuntu1",
+    "emacs24": "24.3+1-2ubuntu1.1",
+    "emacs24-bin-common": "24.3+1-2ubuntu1.1",
+    "emacs24-common": "24.3+1-2ubuntu1.1",
     "emacs24-common-non-dfsg": "24.3+1-1",
     "emacsen-common": "2.0.7",
     "erlang-asn1": "1:16.b.3-dfsg-1ubuntu2.1",
@@ -415,9 +416,8 @@
     "gcc-4.9-base:amd64": "4.9.3-0ubuntu4",
     "gconf-service": "3.2.6-0ubuntu2",
     "gconf-service-backend": "3.2.6-0ubuntu2",
-    "gconf2": "3.2.6-0ubuntu2",
     "gconf2-common": "3.2.6-0ubuntu2",
-    "gdb": "7.7.1-0ubuntu5~14.04.2",
+    "gdb": "7.7.1-0ubuntu5~14.04.3",
     "gdisk": "0.8.8-1ubuntu0.1",
     "genisoimage": "9:1.1.11-2ubuntu3",
     "geoip-database": "20140313-1",
@@ -426,37 +426,33 @@
     "gfortran": "4:4.8.2-1ubuntu6",
     "gfortran-4.8": "4.8.4-2ubuntu1~14.04.3",
     "ghc-8.0.2": "8.0.2-13.1~14.04",
-    "ghostscript": "9.10~dfsg-0ubuntu10.9",
+    "ghostscript": "9.10~dfsg-0ubuntu10.10",
     "gir1.2-freedesktop": "1.40.0-1ubuntu0.2",
-    "gir1.2-gdkpixbuf-2.0": "2.30.7-0ubuntu1.6",
+    "gir1.2-gdkpixbuf-2.0": "2.30.7-0ubuntu1.7",
     "gir1.2-glib-2.0": "1.40.0-1ubuntu0.2",
     "gir1.2-gst-plugins-base-1.0": "1.2.4-1~ubuntu2.1",
     "gir1.2-gstreamer-1.0": "1.2.4-0ubuntu1.1",
     "gir1.2-rsvg-2.0": "2.40.2-1",
-    "git": "1:2.13.0-0ppa1~ubuntu14.04.1",
+    "git": "1:2.14.2-1~ppa0~ubuntu14.04.1",
     "git-lfs": "1.5.4",
-    "git-man": "1:2.13.0-0ppa1~ubuntu14.04.1",
+    "git-man": "1:2.14.2-1~ppa0~ubuntu14.04.1",
     "gnupg": "1.4.16-1ubuntu2.4",
     "google-chrome-stable": "54.0.2840.100-1",
     "gpgv": "1.4.16-1ubuntu2.3",
     "grep": "2.16-1",
     "groff-base": "1.22.2-5",
     "gsfonts": "1:8.11+urwcyr1.0.7~pre44-4.2ubuntu1",
-    "gvfs:amd64": "1.20.3-0ubuntu1.2",
-    "gvfs-common": "1.20.3-0ubuntu1.2",
-    "gvfs-daemons": "1.20.3-0ubuntu1.2",
-    "gvfs-libs:amd64": "1.20.3-0ubuntu1.2",
     "gzip": "1.6-3ubuntu1",
     "happy-1.19.5": "1.19.5-2~trusty",
     "hdparm": "9.43-1ubuntu3",
-    "heroku": "6.12.9-1",
+    "heroku": "6.14.36-1",
     "hicolor-icon-theme": "0.13-1",
     "hostname": "3.15ubuntu1",
     "htop": "1.0.2-3",
-    "icu-devtools": "52.1-3ubuntu0.6",
+    "icu-devtools": "52.1-3ubuntu0.7",
     "ifupdown": "0.7.47.2ubuntu4.3",
-    "imagemagick": "8:6.7.7.10-6ubuntu3.7",
-    "imagemagick-common": "8:6.7.7.10-6ubuntu3.7",
+    "imagemagick": "8:6.7.7.10-6ubuntu3.9",
+    "imagemagick-common": "8:6.7.7.10-6ubuntu3.9",
     "indicator-application": "12.10.1+14.04.20140407-0ubuntu1",
     "info": "5.2.0.dfsg.1-2",
     "init-system-helpers": "1.14",
@@ -495,7 +491,7 @@
     "libalgorithm-diff-perl": "1.19.02-3",
     "libalgorithm-diff-xs-perl": "0.04-2build4",
     "libalgorithm-merge-perl": "0.08-2",
-    "libapache2-mod-php5": "5.5.9+dfsg-1ubuntu4.21",
+    "libapache2-mod-php5": "5.5.9+dfsg-1ubuntu4.22",
     "libapparmor-perl": "2.8.95~2430-0ubuntu5.3",
     "libapparmor1:amd64": "2.8.95~2430-0ubuntu5.3",
     "libappindicator1": "12.10.1+13.10.20130920-0ubuntu4.1",
@@ -519,7 +515,6 @@
     "libasprintf-dev:amd64": "0.18.3.1-1ubuntu3",
     "libasprintf0c2:amd64": "0.18.3.1-1ubuntu3",
     "libasyncns0:amd64": "0.8-4ubuntu2",
-    "libatasmart4:amd64": "0.19-3",
     "libatk-bridge2.0-0:amd64": "2.10.2-2ubuntu1",
     "libatk-wrapper-java": "0.30.4-4",
     "libatk-wrapper-java-jni:amd64": "0.30.4-4",
@@ -534,7 +529,6 @@
     "libavahi-client3:amd64": "0.6.31-4ubuntu1.1",
     "libavahi-common-data:amd64": "0.6.31-4ubuntu1.1",
     "libavahi-common3:amd64": "0.6.31-4ubuntu1.1",
-    "libavahi-glib1:amd64": "0.6.31-4ubuntu1.1",
     "libavcodec54:amd64": "6:9.20-0ubuntu0.14.04.1",
     "libavdevice53:amd64": "6:9.20-0ubuntu0.14.04.1",
     "libavfilter3:amd64": "6:9.20-0ubuntu0.14.04.1",
@@ -546,8 +540,6 @@
     "libblas-dev": "1.2.20110419-7",
     "libblas3": "1.2.20110419-7",
     "libblkid1:amd64": "2.20.1-5.1ubuntu20.7",
-    "libbonobo2-0:amd64": "2.32.1-0ubuntu5",
-    "libbonobo2-common": "2.32.1-0ubuntu5",
     "libboost-iostreams1.54.0:amd64": "1.54.0-4ubuntu3.1",
     "libboost-system1.54.0:amd64": "1.54.0-4ubuntu3.1",
     "libboost-thread1.54.0:amd64": "1.54.0-4ubuntu3.1",
@@ -565,7 +557,6 @@
     "libcairo-script-interpreter2:amd64": "1.13.0~20140204-0ubuntu1.1",
     "libcairo2:amd64": "1.13.0~20140204-0ubuntu1.1",
     "libcairo2-dev": "1.13.0~20140204-0ubuntu1.1",
-    "libcanberra0:amd64": "0.30-0ubuntu3",
     "libcap-ng0": "0.7.3-1ubuntu2",
     "libcap2:amd64": "1:2.24-0ubuntu2",
     "libcap2-bin": "1:2.24-0ubuntu2",
@@ -586,9 +577,9 @@
     "libcups2:amd64": "1.7.2-0ubuntu1.8",
     "libcupsfilters1:amd64": "1.0.52-0ubuntu1.7",
     "libcupsimage2:amd64": "1.7.2-0ubuntu1.8",
-    "libcurl3:amd64": "7.35.0-1ubuntu2.10",
+    "libcurl3:amd64": "7.35.0-1ubuntu2.12",
     "libcurl3-gnutls:amd64": "7.35.0-1ubuntu2.6",
-    "libcurl4-openssl-dev:amd64": "7.35.0-1ubuntu2.10",
+    "libcurl4-openssl-dev:amd64": "7.35.0-1ubuntu2.12",
     "libcurses-perl": "1.28-1build3",
     "libcurses-ui-perl": "0.9609-1",
     "libcwidget3": "0.5.16-3.5ubuntu1",
@@ -610,12 +601,12 @@
     "libdjvulibre21:amd64": "3.5.25.4-3",
     "libdns100": "1:9.9.5.dfsg-3ubuntu0.7",
     "libdpkg-perl": "1.17.5ubuntu5.7",
-    "libdrm-amdgpu1:amd64": "2.4.67-1ubuntu0.14.04.1",
-    "libdrm-dev:amd64": "2.4.67-1ubuntu0.14.04.1",
-    "libdrm-intel1:amd64": "2.4.67-1ubuntu0.14.04.1",
-    "libdrm-nouveau2:amd64": "2.4.67-1ubuntu0.14.04.1",
-    "libdrm-radeon1:amd64": "2.4.67-1ubuntu0.14.04.1",
-    "libdrm2:amd64": "2.4.67-1ubuntu0.14.04.1",
+    "libdrm-amdgpu1:amd64": "2.4.67-1ubuntu0.14.04.2",
+    "libdrm-dev:amd64": "2.4.67-1ubuntu0.14.04.2",
+    "libdrm-intel1:amd64": "2.4.67-1ubuntu0.14.04.2",
+    "libdrm-nouveau2:amd64": "2.4.67-1ubuntu0.14.04.2",
+    "libdrm-radeon1:amd64": "2.4.67-1ubuntu0.14.04.2",
+    "libdrm2:amd64": "2.4.67-1ubuntu0.14.04.2",
     "libdumbnet1": "1.12-4build1",
     "libedit2:amd64": "3.1-20130712-2",
     "libegl1-mesa:amd64": "10.1.3-0ubuntu0.6",
@@ -633,8 +624,8 @@
     "libexpat1:amd64": "2.1.0-4ubuntu1.4",
     "libexpat1-dev:amd64": "2.1.0-4ubuntu1.4",
     "libfakeroot:amd64": "1.20-3ubuntu2",
-    "libffi-dev:amd64": "3.1~rc1+r3.0.13-12ubuntu0.1",
-    "libffi6:amd64": "3.1~rc1+r3.0.13-12ubuntu0.1",
+    "libffi-dev:amd64": "3.1~rc1+r3.0.13-12ubuntu0.2",
+    "libffi6:amd64": "3.1~rc1+r3.0.13-12ubuntu0.2",
     "libfftw3-double3:amd64": "3.3.3-7ubuntu3",
     "libfile-basedir-perl": "0.03-1fakesync1",
     "libfile-desktopentry-perl": "0.07-1",
@@ -657,18 +648,17 @@
     "libgcc1:amd64": "1:4.9.3-0ubuntu4",
     "libgck-1-0:amd64": "3.10.1-1",
     "libgconf-2-4:amd64": "3.2.6-0ubuntu2",
-    "libgconf2-4:amd64": "3.2.6-0ubuntu2",
     "libgcr-3-common": "3.10.1-1",
     "libgcr-base-3-1:amd64": "3.10.1-1",
     "libgcrypt11:amd64": "1.5.3-2ubuntu4.5",
     "libgcrypt11-dev": "1.5.3-2ubuntu4.5",
-    "libgd3:amd64": "2.1.0-3ubuntu0.6",
+    "libgd3:amd64": "2.1.0-3ubuntu0.8",
     "libgdal1h": "1.10.1+dfsg-5ubuntu1",
     "libgdbm-dev": "1.8.3-12build1",
     "libgdbm3:amd64": "1.8.3-12build1",
-    "libgdk-pixbuf2.0-0:amd64": "2.30.7-0ubuntu1.6",
-    "libgdk-pixbuf2.0-common": "2.30.7-0ubuntu1.6",
-    "libgdk-pixbuf2.0-dev": "2.30.7-0ubuntu1.6",
+    "libgdk-pixbuf2.0-0:amd64": "2.30.7-0ubuntu1.7",
+    "libgdk-pixbuf2.0-common": "2.30.7-0ubuntu1.7",
+    "libgdk-pixbuf2.0-dev": "2.30.7-0ubuntu1.7",
     "libgeoclue0:amd64": "0.12.99-3ubuntu1",
     "libgeoip1:amd64": "1.6.0-1",
     "libgeos-3.4.2": "3.4.2-4ubuntu1",
@@ -695,11 +685,6 @@
     "libgmp10:amd64": "2:5.1.3+dfsg-1ubuntu1",
     "libgmp3-dev": "2:5.1.3+dfsg-1ubuntu1",
     "libgmpxx4ldbl:amd64": "2:5.1.3+dfsg-1ubuntu1",
-    "libgnome2-0:amd64": "2.32.1-4ubuntu1",
-    "libgnome2-bin": "2.32.1-4ubuntu1",
-    "libgnome2-common": "2.32.1-4ubuntu1",
-    "libgnomevfs2-0:amd64": "1:2.24.4-1ubuntu6",
-    "libgnomevfs2-common": "1:2.24.4-1ubuntu6",
     "libgnutls-dev": "2.12.23-12ubuntu2.8",
     "libgnutls-openssl27:amd64": "2.12.23-12ubuntu2.8",
     "libgnutls26:amd64": "2.12.23-12ubuntu2.8",
@@ -711,10 +696,10 @@
     "libgphoto2-l10n": "2.5.3.1-1ubuntu2.2",
     "libgphoto2-port10:amd64": "2.5.3.1-1ubuntu2.2",
     "libgpm2:amd64": "1.20.4-6.1",
-    "libgraphite2-3:amd64": "1.3.6-1ubuntu0.14.04.1",
+    "libgraphite2-3:amd64": "1.3.10-0ubuntu0.14.04.1",
     "libgraphviz-dev": "2.36.0-0ubuntu3.2",
-    "libgs9": "9.10~dfsg-0ubuntu10.9",
-    "libgs9-common": "9.10~dfsg-0ubuntu10.9",
+    "libgs9": "9.10~dfsg-0ubuntu10.10",
+    "libgs9-common": "9.10~dfsg-0ubuntu10.10",
     "libgsm1:amd64": "1.0.13-4",
     "libgssapi-krb5-2:amd64": "1.12+dfsg-2ubuntu5.3",
     "libgssapi3-heimdal:amd64": "1.6~git20131207+dfsg-1ubuntu1.1",
@@ -729,7 +714,7 @@
     "libgtk2.0-0:amd64": "2.24.23-0ubuntu1.4",
     "libgtk2.0-bin": "2.24.23-0ubuntu1.4",
     "libgtk2.0-common": "2.24.23-0ubuntu1.4",
-    "libgudev-1.0-0:amd64": "1:204-5ubuntu20.24",
+    "libgudev-1.0-0:amd64": "1:204-5ubuntu20.25",
     "libgusb2:amd64": "0.1.6-5",
     "libgvc6": "2.36.0-0ubuntu3.2",
     "libgvc6-plugins-gtk": "2.36.0-0ubuntu3.2",
@@ -743,12 +728,10 @@
     "libhx509-5-heimdal:amd64": "1.6~git20131207+dfsg-1ubuntu1.1",
     "libice-dev:amd64": "2:1.0.8-2",
     "libice6:amd64": "2:1.0.8-2",
-    "libicu-dev:amd64": "52.1-3ubuntu0.6",
-    "libicu52:amd64": "52.1-3ubuntu0.6",
-    "libidl-common": "0.8.14-0.2ubuntu4",
-    "libidl0:amd64": "0.8.14-0.2ubuntu4",
-    "libidn11:amd64": "1.28-1ubuntu2.1",
-    "libidn11-dev": "1.28-1ubuntu2.1",
+    "libicu-dev:amd64": "52.1-3ubuntu0.7",
+    "libicu52:amd64": "52.1-3ubuntu0.7",
+    "libidn11:amd64": "1.28-1ubuntu2.2",
+    "libidn11-dev": "1.28-1ubuntu2.2",
     "libieee1284-3:amd64": "0.2.11-12",
     "libijs-0.35": "0.35-8build1",
     "libilmbase-dev": "1.0.1-6ubuntu1",
@@ -804,20 +787,21 @@
     "libltdl-dev:amd64": "2.4.2-1.7ubuntu1",
     "libltdl7:amd64": "2.4.2-1.7ubuntu1",
     "liblwgeom-2.2-5": "2.2.2+dfsg-5.pgdg14.04+1",
-    "liblwgeom-2.3-0": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
+    "liblwgeom-2.3-0": "2.3.3+dfsg-1.pgdg14.04+1",
+    "liblwgeom-2.4-0": "2.4.0+dfsg-1.pgdg14.04+1",
     "liblwres90": "1:9.9.5.dfsg-3ubuntu0.7",
-    "liblxc1": "1.0.10-0ubuntu1",
+    "liblxc1": "1.0.10-0ubuntu1.1",
     "liblzma-dev:amd64": "5.1.1alpha+20120614-2ubuntu2",
     "liblzma5:amd64": "5.1.1alpha+20120614-2ubuntu2",
     "liblzo2-2:amd64": "2.06-1.2ubuntu1.1",
     "libm17n-0": "1.6.4-2ubuntu1",
     "libmagic-dev:amd64": "1:5.14-2ubuntu3.3",
     "libmagic1:amd64": "1:5.14-2ubuntu3.3",
-    "libmagickcore-dev": "8:6.7.7.10-6ubuntu3.8",
-    "libmagickcore5:amd64": "8:6.7.7.10-6ubuntu3.8",
-    "libmagickcore5-extra:amd64": "8:6.7.7.10-6ubuntu3.8",
-    "libmagickwand-dev": "8:6.7.7.10-6ubuntu3.8",
-    "libmagickwand5:amd64": "8:6.7.7.10-6ubuntu3.8",
+    "libmagickcore-dev": "8:6.7.7.10-6ubuntu3.9",
+    "libmagickcore5:amd64": "8:6.7.7.10-6ubuntu3.9",
+    "libmagickcore5-extra:amd64": "8:6.7.7.10-6ubuntu3.9",
+    "libmagickwand-dev": "8:6.7.7.10-6ubuntu3.9",
+    "libmagickwand5:amd64": "8:6.7.7.10-6ubuntu3.9",
     "libmail-sendmail-perl": "0.79.16-1",
     "libmcrypt-dev": "2.5.8-3.1ubuntu1",
     "libmcrypt4": "2.5.8-3.1ubuntu1",
@@ -838,10 +822,10 @@
     "libmpdec2:amd64": "2.4.0-6",
     "libmpfr4:amd64": "3.1.2-1",
     "libmtdev1:amd64": "1.1.4-1ubuntu1",
-    "libmysqlclient-dev": "5.7.19-1ubuntu14.04",
-    "libmysqlclient18:amd64": "5.5.55-0ubuntu0.14.04.1",
-    "libmysqlclient20:amd64": "5.7.19-1ubuntu14.04",
-    "libmysqld-dev": "5.7.19-1ubuntu14.04",
+    "libmysqlclient-dev": "5.7.20-1ubuntu14.04",
+    "libmysqlclient18:amd64": "5.5.58-0ubuntu0.14.04.1",
+    "libmysqlclient20:amd64": "5.7.20-1ubuntu14.04",
+    "libmysqld-dev": "5.7.20-1ubuntu14.04",
     "libncurses5:amd64": "5.9+20140118-1ubuntu1",
     "libncurses5-dev:amd64": "5.9+20140118-1ubuntu1",
     "libncursesw5:amd64": "5.9+20140118-1ubuntu1",
@@ -854,8 +838,8 @@
     "libnih-dbus1:amd64": "1.0.3-4ubuntu25",
     "libnih1:amd64": "1.0.3-4ubuntu25",
     "libnspr4:amd64": "2:4.13.1-0ubuntu0.14.04.1",
-    "libnss3:amd64": "2:3.28.4-0ubuntu0.14.04.2",
-    "libnss3-nssdb": "2:3.28.4-0ubuntu0.14.04.2",
+    "libnss3:amd64": "2:3.28.4-0ubuntu0.14.04.3",
+    "libnss3-nssdb": "2:3.28.4-0ubuntu0.14.04.3",
     "libnuma1:amd64": "2.0.9~rc5-1ubuntu3.14.04.1",
     "libodbc1:amd64": "2.2.14p2-5ubuntu5",
     "libogdi3.2": "3.2.0~beta2-7ubuntu1",
@@ -866,8 +850,6 @@
     "libopenvg1-mesa:amd64": "10.1.3-0ubuntu0.6",
     "libopts25:amd64": "1:5.18-2ubuntu2",
     "libopus0": "1.1-0ubuntu1",
-    "liborbit-2-0:amd64": "1:2.14.19-0.3",
-    "liborbit2:amd64": "1:2.14.19-0.3",
     "liborc-0.4-0:amd64": "1:0.4.18-1ubuntu1",
     "libotf0:amd64": "0.9.13-1ubuntu1",
     "libp11-kit-dev": "0.20.2-2ubuntu2",
@@ -906,10 +888,10 @@
     "libpolkit-agent-1-0:amd64": "0.105-4ubuntu3.14.04.1",
     "libpolkit-backend-1-0:amd64": "0.105-4ubuntu3.14.04.1",
     "libpolkit-gobject-1-0:amd64": "0.105-4ubuntu3.14.04.1",
-    "libpoppler44:amd64": "0.24.5-2ubuntu4.5",
+    "libpoppler44:amd64": "0.24.5-2ubuntu4.7",
     "libpopt0:amd64": "1.16-8ubuntu1",
-    "libpq-dev": "9.6.3-1.pgdg14.04+1",
-    "libpq5:amd64": "9.6.3-1.pgdg14.04+1",
+    "libpq-dev": "10.0-1.pgdg14.04+1",
+    "libpq5:amd64": "10.0-1.pgdg14.04+1",
     "libprocps3:amd64": "1:3.3.9-1ubuntu2.2",
     "libproj0": "4.8.0-2ubuntu2",
     "libprotobuf-dev:amd64": "2.5.0-9ubuntu1",
@@ -954,9 +936,9 @@
     "libqt5widgets5:amd64": "5.2.1+dfsg-1ubuntu14.3",
     "libqt5xml5:amd64": "5.2.1+dfsg-1ubuntu14.3",
     "libquadmath0:amd64": "4.8.4-2ubuntu1~14.04.3",
-    "librados2": "0.80.11-0ubuntu1.14.04.2",
+    "librados2": "0.80.11-0ubuntu1.14.04.3",
     "libraw1394-11:amd64": "2.1.0-1ubuntu1",
-    "librbd1": "0.80.11-0ubuntu1.14.04.2",
+    "librbd1": "0.80.11-0ubuntu1.14.04.3",
     "libreadline-dev:amd64": "6.3-4ubuntu2",
     "libreadline6:amd64": "6.3-4ubuntu2",
     "libreadline6-dev:amd64": "6.3-4ubuntu2",
@@ -966,7 +948,7 @@
     "librsvg2-dev": "2.40.2-1",
     "librtmp-dev": "2.4+20121230.gitdf6c518-1ubuntu0.1",
     "librtmp0:amd64": "2.4+20121230.gitdf6c518-1ubuntu0.1",
-    "libruby1.9.1": "1.9.3.484-2ubuntu1.2",
+    "libruby1.9.1": "1.9.3.484-2ubuntu1.5",
     "libsamplerate0:amd64": "0.1.8-7",
     "libsane:amd64": "1.0.23-3ubuntu3.1",
     "libsane-common": "1.0.23-3ubuntu3.1",
@@ -977,9 +959,7 @@
     "libsctp-dev": "1.0.15+dfsg-1",
     "libsctp1:amd64": "1.0.15+dfsg-1",
     "libsdl1.2debian:amd64": "1.2.15-8ubuntu1.1",
-    "libseccomp2:amd64": "2.1.1-1ubuntu1~trusty3",
-    "libsecret-1-0:amd64": "0.16-0ubuntu1",
-    "libsecret-common": "0.16-0ubuntu1",
+    "libseccomp2:amd64": "2.1.1-1ubuntu1~trusty4",
     "libselinux1:amd64": "2.2.2-1ubuntu0.1",
     "libsemanage-common": "2.2-1",
     "libsemanage1:amd64": "2.2-1",
@@ -1007,12 +987,11 @@
     "libsybdb5:amd64": "0.91-5",
     "libsys-hostname-long-perl": "1.4-3",
     "libsystemd-daemon0:amd64": "204-5ubuntu20.18",
-    "libsystemd-journal0:amd64": "204-5ubuntu20.24",
+    "libsystemd-journal0:amd64": "204-5ubuntu20.25",
     "libsystemd-login0:amd64": "204-5ubuntu20.18",
     "libtasn1-6:amd64": "3.4-3ubuntu0.5",
     "libtasn1-6-dev": "3.4-3ubuntu0.5",
     "libtcl8.6:amd64": "8.6.1-4ubuntu1",
-    "libtdb1:amd64": "1.3.8-0ubuntu0.14.04.1",
     "libterm-readkey-perl": "2.31-1",
     "libterm-ui-perl": "0.42-1",
     "libtext-charwidth-perl": "0.04-7build3",
@@ -1036,7 +1015,6 @@
     "libtsan0:amd64": "4.8.4-2ubuntu1~14.04.3",
     "libtxc-dxtn-s2tc0:amd64": "0~git20131104-1.1",
     "libudev1:amd64": "204-5ubuntu20.18",
-    "libudisks2-0:amd64": "2.1.3-1ubuntu0.1",
     "libunistring0:amd64": "0.9.3-5ubuntu3",
     "liburiparser1": "0.7.5-1ubuntu2",
     "libusb-0.1-4:amd64": "2:0.1.12-23.3ubuntu1",
@@ -1049,7 +1027,6 @@
     "libva1:amd64": "1.3.0-2",
     "libvorbis0a:amd64": "1.3.2-1.3ubuntu1",
     "libvorbisenc2:amd64": "1.3.2-1.3ubuntu1",
-    "libvorbisfile3:amd64": "1.3.2-1.3ubuntu1",
     "libvpx1:amd64": "1.3.0-2",
     "libwayland-client0:amd64": "1.4.0-1ubuntu1",
     "libwayland-cursor0:amd64": "1.4.0-1ubuntu1",
@@ -1121,7 +1098,7 @@
     "libxfconf-0-2": "4.10.0-2ubuntu1",
     "libxfixes-dev:amd64": "1:5.0.1-1ubuntu1.1",
     "libxfixes3:amd64": "1:5.0.1-1ubuntu1.1",
-    "libxfont1:amd64": "1:1.4.7-1ubuntu0.2",
+    "libxfont1:amd64": "1:1.4.7-1ubuntu0.3",
     "libxft2:amd64": "2.3.1-2",
     "libxi6:amd64": "2:1.7.1.901-1ubuntu1.1",
     "libxinerama1:amd64": "2:1.1.3-1",
@@ -1130,8 +1107,8 @@
     "libxkbfile1:amd64": "1:1.0.8-1",
     "libxml-commons-external-java": "1.4.01-2build1",
     "libxml-commons-resolver1.1-java": "1.2-7build1",
-    "libxml2:amd64": "2.9.1+dfsg1-3ubuntu4.9",
-    "libxml2-dev:amd64": "2.9.1+dfsg1-3ubuntu4.9",
+    "libxml2:amd64": "2.9.1+dfsg1-3ubuntu4.10",
+    "libxml2-dev:amd64": "2.9.1+dfsg1-3ubuntu4.10",
     "libxmu6:amd64": "2:1.1.1-1",
     "libxmuu1:amd64": "2:1.1.1-1",
     "libxpm4:amd64": "1:3.5.10-1ubuntu0.1",
@@ -1155,7 +1132,7 @@
     "libxxf86vm1:amd64": "1:1.1.3-1",
     "libyaml-0-2:amd64": "0.1.4-3ubuntu3.1",
     "libyaml-dev:amd64": "0.1.4-3ubuntu3.1",
-    "linux-libc-dev:amd64": "3.13.0-125.174",
+    "linux-libc-dev:amd64": "3.13.0-133.182",
     "lksctp-tools": "1.0.15+dfsg-1",
     "llvm": "1:3.4-0ubuntu1",
     "llvm-3.4": "1:3.4-1ubuntu3",
@@ -1171,8 +1148,8 @@
     "lshw": "02.16-2ubuntu1.3",
     "lsof": "4.86+dfsg-1ubuntu2",
     "ltrace": "0.7.3-4ubuntu5.1",
-    "lxc": "1.0.10-0ubuntu1",
-    "lxc-templates": "1.0.10-0ubuntu1",
+    "lxc": "1.0.10-0ubuntu1.1",
+    "lxc-templates": "1.0.10-0ubuntu1.1",
     "lzop": "1.03-3",
     "m17n-contrib": "1.1.14-1",
     "m17n-db": "1.6.4-1",
@@ -1201,11 +1178,11 @@
     "mtr-tiny": "0.85-2",
     "multiarch-support": "2.19-0ubuntu6.7",
     "mysql-apt-config": "0.6.0-1",
-    "mysql-client": "5.7.19-1ubuntu14.04",
-    "mysql-common": "5.7.19-1ubuntu14.04",
-    "mysql-community-client": "5.7.19-1ubuntu14.04",
-    "mysql-community-server": "5.7.19-1ubuntu14.04",
-    "mysql-server": "5.7.19-1ubuntu14.04",
+    "mysql-client": "5.7.20-1ubuntu14.04",
+    "mysql-common": "5.7.20-1ubuntu14.04",
+    "mysql-community-client": "5.7.20-1ubuntu14.04",
+    "mysql-community-server": "5.7.20-1ubuntu14.04",
+    "mysql-server": "5.7.20-1ubuntu14.04",
     "nano": "2.2.6-1ubuntu1",
     "ncurses-base": "5.9+20140118-1ubuntu1",
     "ncurses-bin": "5.9+20140118-1ubuntu1",
@@ -1216,19 +1193,19 @@
     "netcat-openbsd": "1.105-7ubuntu1",
     "netpbm": "2:10.0-15ubuntu2",
     "ntfs-3g": "1:2013.1.13AR.1-2ubuntu2",
-    "ntp": "1:4.2.6.p5+dfsg-3ubuntu2.14.04.11",
+    "ntp": "1:4.2.6.p5+dfsg-3ubuntu2.14.04.12",
     "ntpdate": "1:4.2.6.p5+dfsg-3ubuntu2.14.04.8",
     "numactl": "2.0.9~rc5-1ubuntu3.14.04.2",
     "odbcinst": "2.2.14p2-5ubuntu5",
     "odbcinst1debian2:amd64": "2.2.14p2-5ubuntu5",
     "open-vm-tools": "2:9.4.0-1280544-5ubuntu6.2",
-    "openjdk-7-jdk:amd64": "7u131-2.6.9-0ubuntu0.14.04.2",
-    "openjdk-7-jre:amd64": "7u131-2.6.9-0ubuntu0.14.04.2",
-    "openjdk-7-jre-headless:amd64": "7u131-2.6.9-0ubuntu0.14.04.2",
-    "openjdk-8-jdk:amd64": "8u111-b14-3~14.04.1",
-    "openjdk-8-jdk-headless:amd64": "8u111-b14-3~14.04.1",
-    "openjdk-8-jre:amd64": "8u111-b14-3~14.04.1",
-    "openjdk-8-jre-headless:amd64": "8u111-b14-3~14.04.1",
+    "openjdk-7-jdk:amd64": "7u151-2.6.11-0ubuntu1.14.04.1",
+    "openjdk-7-jre:amd64": "7u151-2.6.11-0ubuntu1.14.04.1",
+    "openjdk-7-jre-headless:amd64": "7u151-2.6.11-0ubuntu1.14.04.1",
+    "openjdk-8-jdk:amd64": "8u141-b15-3~14.04",
+    "openjdk-8-jdk-headless:amd64": "8u141-b15-3~14.04",
+    "openjdk-8-jre:amd64": "8u141-b15-3~14.04",
+    "openjdk-8-jre-headless:amd64": "8u141-b15-3~14.04",
     "openssh-client": "1:6.6p1-2ubuntu2.6",
     "openssh-server": "1:6.6p1-2ubuntu2.6",
     "openssh-sftp-server": "1:6.6p1-2ubuntu2.6",
@@ -1243,35 +1220,34 @@
     "perl": "5.18.2-2ubuntu1",
     "perl-base": "5.18.2-2ubuntu1",
     "perl-modules": "5.18.2-2ubuntu1",
-    "pgdg-keyring": "2017.1",
-    "php5-cli": "5.5.9+dfsg-1ubuntu4.21",
-    "php5-common": "5.5.9+dfsg-1ubuntu4.21",
+    "pgdg-keyring": "2017.2",
+    "php5-cli": "5.5.9+dfsg-1ubuntu4.22",
+    "php5-common": "5.5.9+dfsg-1ubuntu4.22",
     "php5-json": "1.3.2-2build1",
-    "php5-readline": "5.5.9+dfsg-1ubuntu4.21",
+    "php5-readline": "5.5.9+dfsg-1ubuntu4.22",
     "pkg-config": "0.26-1ubuntu4",
     "plymouth": "0.8.8-0ubuntu17.1",
     "plymouth-theme-ubuntu-text": "0.8.8-0ubuntu17.1",
     "po-debconf": "1.0.16+nmu2ubuntu1",
     "policykit-1": "0.105-4ubuntu3.14.04.1",
-    "policykit-1-gnome": "0.105-1ubuntu4",
     "pollinate": "4.7-0ubuntu1.4",
     "poppler-data": "0.4.6-4",
     "popularity-contest": "1.57ubuntu1",
-    "postgis": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
-    "postgis-doc": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
-    "postgresql-9.5": "9.5.7-1.pgdg14.04+1",
+    "postgis": "2.4.0+dfsg-1.pgdg14.04+1",
+    "postgis-doc": "2.4.0+dfsg-1.pgdg14.04+1",
+    "postgresql-9.5": "9.5.9-1.pgdg14.04+1",
     "postgresql-9.5-postgis-2.2": "2.2.2+dfsg-7~137.gite11228b.pgdg14.04+1",
-    "postgresql-9.5-postgis-2.3": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
-    "postgresql-9.5-postgis-2.3-scripts": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
-    "postgresql-9.6": "9.6.3-1.pgdg14.04+1",
-    "postgresql-9.6-postgis-2.3": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
-    "postgresql-9.6-postgis-2.3-scripts": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
-    "postgresql-client-9.5": "9.5.7-1.pgdg14.04+1",
-    "postgresql-client-9.6": "9.6.3-1.pgdg14.04+1",
-    "postgresql-client-common": "184.pgdg14.04+1",
-    "postgresql-common": "184.pgdg14.04+1",
-    "postgresql-contrib-9.5": "9.5.7-1.pgdg14.04+1",
-    "postgresql-contrib-9.6": "9.6.3-1.pgdg14.04+1",
+    "postgresql-9.5-postgis-2.3": "2.3.3+dfsg-1.pgdg14.04+1",
+    "postgresql-9.5-postgis-2.3-scripts": "2.3.3+dfsg-1.pgdg14.04+1",
+    "postgresql-9.6": "9.6.5-1.pgdg14.04+2",
+    "postgresql-9.6-postgis-2.4": "2.4.0+dfsg-1.pgdg14.04+1",
+    "postgresql-9.6-postgis-2.4-scripts": "2.4.0+dfsg-1.pgdg14.04+1",
+    "postgresql-client-9.5": "9.5.9-1.pgdg14.04+1",
+    "postgresql-client-9.6": "9.6.5-1.pgdg14.04+2",
+    "postgresql-client-common": "186.pgdg14.04+1",
+    "postgresql-common": "186.pgdg14.04+1",
+    "postgresql-contrib-9.5": "9.5.9-1.pgdg14.04+1",
+    "postgresql-contrib-9.6": "9.6.5-1.pgdg14.04+2",
     "powermgmt-base": "1.31build1",
     "ppp": "2.4.5-5.1ubuntu2.2",
     "pppconfig": "2.3.19ubuntu1",
@@ -1338,7 +1314,7 @@
     "python3-distupgrade": "1:0.220.8",
     "python3-gdbm:amd64": "3.4.3-1~14.04.2",
     "python3-gi": "3.12.0-1ubuntu1",
-    "python3-lxc": "1.0.10-0ubuntu1",
+    "python3-lxc": "1.0.10-0ubuntu1.1",
     "python3-minimal": "3.4.0-0ubuntu2",
     "python3-newt": "0.52.15-2ubuntu5",
     "python3-pkg-resources": "3.3-1ubuntu2",
@@ -1348,7 +1324,7 @@
     "python3-update-manager": "1:0.196.14",
     "python3.4": "3.4.3-1ubuntu1~14.04.5",
     "python3.4-minimal": "3.4.3-1ubuntu1~14.04.5",
-    "qemu-utils": "2.0.0+dfsg-2ubuntu1.34",
+    "qemu-utils": "2.0.0+dfsg-2ubuntu1.36",
     "qt5-default:amd64": "5.2.1+dfsg-1ubuntu14.3",
     "qt5-qmake:amd64": "5.2.1+dfsg-1ubuntu14.3",
     "qt55base": "5.5.1-1basyskom2",
@@ -1363,7 +1339,7 @@
     "qtlocation5-dev": "5.2.1-1ubuntu2",
     "qtpositioning5-dev": "5.2.1-1ubuntu2",
     "qtsensors5-dev": "5.2.1+dfsg-2ubuntu2",
-    "rabbitmq-server": "3.2.4-1",
+    "rabbitmq-server": "3.2.4-1ubuntu0.1",
     "re2c": "0.13.5-1build2",
     "readline-common": "6.3-4ubuntu2",
     "redis-server": "2:2.8.4-2",
@@ -1374,8 +1350,8 @@
     "rsyslog": "7.4.4-1ubuntu2.6",
     "ruby": "1:1.9.3.4",
     "ruby-dev": "1:1.9.3.4",
-    "ruby1.9.1": "1.9.3.484-2ubuntu1.2",
-    "ruby1.9.1-dev": "1.9.3.484-2ubuntu1.2",
+    "ruby1.9.1": "1.9.3.484-2ubuntu1.5",
+    "ruby1.9.1-dev": "1.9.3.484-2ubuntu1.5",
     "run-one": "1.17-0ubuntu1",
     "sbt": "0.13.9",
     "screen": "4.1.0~20120320gitdb59704-9",
@@ -1385,7 +1361,6 @@
     "shared-mime-info": "1.2-0ubuntu3",
     "sharutils": "1:4.14-1ubuntu1",
     "software-properties-common": "0.92.37.8",
-    "sound-theme-freedesktop": "0.8-1",
     "ssh-import-id": "3.21-0ubuntu1",
     "ssl-cert": "1.0.33",
     "strace": "4.8-1ubuntu5",
@@ -1419,7 +1394,6 @@
     "ubuntu-standard": "1.325",
     "ucf": "3.0027+nmu1",
     "udev": "204-5ubuntu20.18",
-    "udisks2": "2.1.3-1ubuntu0.1",
     "ufw": "0.34~rc-0ubuntu2",
     "uidmap": "1:4.1.5.1-1ubuntu9.5",
     "unattended-upgrades": "0.82.1ubuntu2.4",
@@ -1470,10 +1444,10 @@
     "xkb-data": "2.10.1-1ubuntu1",
     "xml-core": "0.13+nmu2",
     "xorg-sgml-doctools": "1:1.11-1",
-    "xserver-common": "2:1.15.1-0ubuntu2.7",
+    "xserver-common": "2:1.15.1-0ubuntu2.11",
     "xterm": "297-1ubuntu1",
-    "xtrans-dev": "1.3.5-1~ubuntu14.04.1",
-    "xvfb": "2:1.15.1-0ubuntu2.7",
+    "xtrans-dev": "1.3.5-1~ubuntu14.04.2",
+    "xvfb": "2:1.15.1-0ubuntu2.11",
     "xz-utils": "5.1.1alpha+20120614-2ubuntu2",
     "zerofree": "1.0.2-1ubuntu1",
     "zip": "3.0-8",

Php version error for 7.1.0
#2