Ubuntu 14.04 Build Image Update 201704-01

build-image

#1

We will update our Ubuntu 14.04 (Trusty) build image between the 5th and 6th of April, 2017. This post details the changes - let us know if you have any concerns.

Do you want to control your own build image? CircleCI 2.0 is in Beta now! 2.0 lets you use Docker images of your choice.


Git LFS

Git LFS will no longer pull files managed under LFS automatically.

In the previous image update, we’ve pre-installed Git LFS.

This made git to automatically pull files under LFS in the checkout step and brought some performance issue for some customers who manage many files under LFS.

To disable the automatic pull, we will set GIT_LFS_SKIP_SMUDGE=1 environment variable in this update.

If your builds were relying on the automatic pull behavior, please add the following to your circle.yml.

checkout:
  post:
    - git lfs pull

Ruby

RubyGems 2.6 will be installed for all versions of Ruby

Bundler 1.14 will be installed for all versions of Ruby

Ruby 2.2.5 will be removed

Ruby 2.3.1 will be removed

Ruby 2.2.7 will be pre-installed

Ruby 2.3.4 will be pre-installed

PHP

PHP 7.0.17 will be pre-installed

PHP 7.1.3 will be pre-installed

Go

Go will be updated to 1.8

Python

Python 3.5.3 will be added

Yarn

Yarn will be updated to 0.21.3

Leiningen

Leiningen will be updated to 2.7.1

Stack

Stack 1.4.0 will be pre-installed

All Changes

--- versions.json.before	2017-04-04 03:50:02.786792087 +0000
+++ versions-ubuntu-14_04-XXL.json	2017-04-04 03:50:02.354792511 +0000
@@ -1,26 +1,27 @@
 {
   "summary": {
-    "build-image": "ubuntu-14.04-XXL-927-41cd8fe",
+    "build-image": "ubuntu-14.04-XXL-1151-7fe501c",
     "google-chrome": "54.0.2840.100",
     "chromedriver": "2.27.440175",
     "firefox": "47.0.1",
     "mongod": "3.0.7",
-    "psql": "9.5.5",
+    "psql": "9.5.6",
     "mysqld": "5.7.17",
     "ruby": {
       "default": "2.2.6p396",
       "all": [
         "ruby-2.1.8",
         "ruby-2.1.9",
-        "ruby-2.2.5",
         "ruby-2.2.6",
-        "ruby-2.3.1",
+        "ruby-2.2.7",
         "ruby-2.3.3",
-        "ruby-2.4.0"
+        "ruby-2.3.4",
+        "ruby-2.4.0",
+        "ruby-2.4.1"
       ],
-      "gem": "2.4.5.2",
-      "rvm": "1.28.0 (master)",
-      "bundler": "1.13.7"
+      "gem": "2.6.11",
+      "rvm": "1.29.1 (master)",
+      "bundler": "1.14.6"
     },
     "python": {
       "default": "2.7.11",
@@ -38,7 +39,9 @@
         "3.4.4",
         "3.5.1",
         "3.5.2",
+        "3.5.3",
         "3.6.0",
+        "3.6.1",
         "pypy-1.9",
         "pypy-2.6.1",
         "pypy-4.0.1"
@@ -67,7 +70,7 @@
       ],
       "npm": "2.14.12",
       "nvm": "0.31.0",
-      "yarn": "0.18.1"
+      "yarn": "0.21.3"
     },
     "php": {
       "default": "5.6.17",
@@ -79,9 +82,11 @@
         "5.6.18",
         "5.6.22",
         "7.0.11",
+        "7.0.17",
         "7.0.4",
         "7.0.7",
-        "7.1.0"
+        "7.1.0",
+        "7.1.3"
       ]
     },
     "java": {
@@ -94,16 +99,17 @@
       ]
     },
     "clojure": {
-      "lein": "2.5.3"
+      "lein": "2.7.1"
     },
     "haskell": {
       "all": [
-        "8.0.1",
+        "8.0.2",
         "bin"
       ],
       "cabal": "1.24.0.2",
       "alex": "3.1.7",
-      "happy": "1.19.5"
+      "happy": "1.19.5",
+      "stack": "1.4.0"
     },
     "scala": {
       "all": [
@@ -136,14 +142,14 @@
     "riak": "2.1.3",
     "couchdb": "1.6.1",
     "geos": "3.5.0",
-    "go": "1.7.4",
+    "go": "1.8",
     "gradle": "1.10",
     "phantomjs": "2.1.1",
     "docker": "1.9.1",
     "docker-compose": "1.5.2",
     "heroku-toolbelt": "3.43.16",
-    "gcloud": "139.0.1",
-    "aws-cli": "1.11.36",
+    "gcloud": "149.0.0",
+    "aws-cli": "1.11.70",
     "android": {
       "build-tool": "24.4.1",
       "build-tools": [
@@ -178,7 +184,8 @@
         "google_play_services",
         "m2repository"
       ]
-    }
+    },
+    "yarn": "0.21.3"
   },
   "all": {
     "accountsservice": "0.6.35-0ubuntu7.2",
@@ -220,7 +227,7 @@
     "bison": "2:2.7.1.dfsg-1",
     "bridge-utils": "1.5-6ubuntu2",
     "bsdmainutils": "9.0.5ubuntu1",
-    "bsdtar": "3.1.2-7ubuntu2.3",
+    "bsdtar": "3.1.2-7ubuntu2.4",
     "bsdutils": "1:2.20.1-5.1ubuntu20.7",
     "btrfs-tools": "3.12-1ubuntu0.1",
     "build-essential": "11.6ubuntu6",
@@ -256,9 +263,11 @@
     "circleci-php-5.6.18": "5",
     "circleci-php-5.6.22": "5",
     "circleci-php-7.0.11": "5",
+    "circleci-php-7.0.17": "5",
     "circleci-php-7.0.4": "5",
     "circleci-php-7.0.7": "5",
     "circleci-php-7.1.0": "5",
+    "circleci-php-7.1.3": "5",
     "circleci-python-2.7.10": "2",
     "circleci-python-2.7.11": "2",
     "circleci-python-2.7.12": "2",
@@ -272,17 +281,20 @@
     "circleci-python-3.4.4": "2",
     "circleci-python-3.5.1": "2",
     "circleci-python-3.5.2": "2",
+    "circleci-python-3.5.3": "2",
     "circleci-python-3.6.0": "2",
+    "circleci-python-3.6.1": "2",
     "circleci-python-pypy-1.9": "2",
     "circleci-python-pypy-2.6.1": "2",
     "circleci-python-pypy-4.0.1": "2",
     "circleci-ruby-2.1.8": "1",
     "circleci-ruby-2.1.9": "1",
-    "circleci-ruby-2.2.5": "1",
     "circleci-ruby-2.2.6": "1",
-    "circleci-ruby-2.3.1": "1",
+    "circleci-ruby-2.2.7": "1",
     "circleci-ruby-2.3.3": "1",
+    "circleci-ruby-2.3.4": "1",
     "circleci-ruby-2.4.0": "1",
+    "circleci-ruby-2.4.1": "1",
     "cloud-guest-utils": "0.27-0ubuntu9.1",
     "cloud-image-utils": "0.27-0ubuntu9.2",
     "cloud-init": "0.7.5-0ubuntu1.15",
@@ -307,7 +319,7 @@
     "daemon": "0.6.4-1",
     "dash": "0.5.7-4ubuntu1",
     "dbus": "1.6.18-0ubuntu4.3",
-    "dbus-x11": "1.6.18-0ubuntu4.4",
+    "dbus-x11": "1.6.18-0ubuntu4.5",
     "dconf-gsettings-backend:amd64": "0.20.0-1",
     "dconf-service": "0.20.0-1",
     "debconf": "1.5.51ubuntu2",
@@ -317,7 +329,7 @@
     "debootstrap": "1.0.59ubuntu0.6",
     "default-jre-headless": "2:1.7-51",
     "desktop-file-utils": "0.22-1ubuntu1",
-    "dh-apparmor": "2.8.95~2430-0ubuntu5.3",
+    "dh-apparmor": "2.10.95-0ubuntu2.6~14.04.1",
     "dh-python": "1.20140128-1ubuntu8.2",
     "diffutils": "1:3.3-1",
     "distro-info": "0.12",
@@ -404,18 +416,18 @@
     "gettext-base": "0.18.3.1-1ubuntu3",
     "gfortran": "4:4.8.2-1ubuntu6",
     "gfortran-4.8": "4.8.4-2ubuntu1~14.04.3",
-    "ghc-8.0.1": "8.0.1-13~14.04",
+    "ghc-8.0.2": "8.0.2-13.1~14.04",
     "ghostscript": "9.10~dfsg-0ubuntu10.6",
     "gir1.2-freedesktop": "1.40.0-1ubuntu0.2",
     "gir1.2-gdkpixbuf-2.0": "2.30.7-0ubuntu1.6",
     "gir1.2-glib-2.0": "1.40.0-1ubuntu0.2",
-    "gir1.2-gst-plugins-base-1.0": "1.2.4-1~ubuntu2",
+    "gir1.2-gst-plugins-base-1.0": "1.2.4-1~ubuntu2.1",
     "gir1.2-gstreamer-1.0": "1.2.4-0ubuntu1.1",
     "gir1.2-rsvg-2.0": "2.40.2-1",
     "git": "1:2.11.0-2~ppa0~ubuntu14.04.1",
     "git-lfs": "1.5.4",
     "git-man": "1:2.11.0-2~ppa0~ubuntu14.04.1",
-    "gnupg": "1.4.16-1ubuntu2.3",
+    "gnupg": "1.4.16-1ubuntu2.4",
     "google-chrome-stable": "54.0.2840.100-1",
     "gpgv": "1.4.16-1ubuntu2.3",
     "grep": "2.16-1",
@@ -433,10 +445,10 @@
     "hicolor-icon-theme": "0.13-1",
     "hostname": "3.15ubuntu1",
     "htop": "1.0.2-3",
-    "icu-devtools": "52.1-3ubuntu0.4",
+    "icu-devtools": "52.1-3ubuntu0.5",
     "ifupdown": "0.7.47.2ubuntu4.3",
-    "imagemagick": "8:6.7.7.10-6ubuntu3.3",
-    "imagemagick-common": "8:6.7.7.10-6ubuntu3.3",
+    "imagemagick": "8:6.7.7.10-6ubuntu3.6",
+    "imagemagick-common": "8:6.7.7.10-6ubuntu3.6",
     "indicator-application": "12.10.1+14.04.20140407-0ubuntu1",
     "info": "5.2.0.dfsg.1-2",
     "init-system-helpers": "1.14",
@@ -460,7 +472,7 @@
     "klibc-utils": "2.0.3-0ubuntu1",
     "kmod": "15-0ubuntu6",
     "krb5-locales": "1.12+dfsg-2ubuntu5.2",
-    "krb5-multidev": "1.12+dfsg-2ubuntu5.2",
+    "krb5-multidev": "1.12+dfsg-2ubuntu5.3",
     "landscape-client": "14.12-0ubuntu0.14.04",
     "landscape-common": "14.12-0ubuntu0.14.04",
     "language-selector-common": "0.129.3",
@@ -475,7 +487,7 @@
     "libalgorithm-diff-perl": "1.19.02-3",
     "libalgorithm-diff-xs-perl": "0.04-2build4",
     "libalgorithm-merge-perl": "0.08-2",
-    "libapache2-mod-php5": "5.5.9+dfsg-1ubuntu4.20",
+    "libapache2-mod-php5": "5.5.9+dfsg-1ubuntu4.21",
     "libapparmor-perl": "2.8.95~2430-0ubuntu5.3",
     "libapparmor1:amd64": "2.8.95~2430-0ubuntu5.3",
     "libappindicator1": "12.10.1+13.10.20130920-0ubuntu4.1",
@@ -489,7 +501,7 @@
     "libapt-inst1.5:amd64": "1.0.1ubuntu2.11",
     "libapt-pkg4.12:amd64": "1.0.1ubuntu2.11",
     "libarchive-extract-perl": "0.70-1",
-    "libarchive13:amd64": "3.1.2-7ubuntu2.3",
+    "libarchive13:amd64": "3.1.2-7ubuntu2.4",
     "libarmadillo4": "1:4.200.0+dfsg-1",
     "libarpack2": "3.1.5-2",
     "libasan0:amd64": "4.8.4-2ubuntu1~14.04.3",
@@ -535,11 +547,11 @@
     "libbz2-1.0:amd64": "1.0.6-5",
     "libbz2-dev:amd64": "1.0.6-5",
     "libc-bin": "2.19-0ubuntu6.7",
-    "libc-dev-bin": "2.19-0ubuntu6.9",
-    "libc6:amd64": "2.19-0ubuntu6.9",
-    "libc6-dbg:amd64": "2.19-0ubuntu6.9",
-    "libc6-dev:amd64": "2.19-0ubuntu6.9",
-    "libc6-i386": "2.19-0ubuntu6.9",
+    "libc-dev-bin": "2.19-0ubuntu6.11",
+    "libc6:amd64": "2.19-0ubuntu6.11",
+    "libc6-dbg:amd64": "2.19-0ubuntu6.11",
+    "libc6-dev:amd64": "2.19-0ubuntu6.11",
+    "libc6-i386": "2.19-0ubuntu6.11",
     "libcaca0:amd64": "0.99.beta18-1ubuntu5",
     "libcairo-gobject2:amd64": "1.13.0~20140204-0ubuntu1.1",
     "libcairo-script-interpreter2:amd64": "1.13.0~20140204-0ubuntu1.1",
@@ -563,9 +575,9 @@
     "libcomerr2:amd64": "1.42.9-3ubuntu1.3",
     "libcroco3:amd64": "0.6.8-2ubuntu1",
     "libcryptsetup4": "2:1.6.1-1ubuntu1",
-    "libcups2:amd64": "1.7.2-0ubuntu1.7",
+    "libcups2:amd64": "1.7.2-0ubuntu1.8",
     "libcupsfilters1:amd64": "1.0.52-0ubuntu1.7",
-    "libcupsimage2:amd64": "1.7.2-0ubuntu1.7",
+    "libcupsimage2:amd64": "1.7.2-0ubuntu1.8",
     "libcurl3:amd64": "7.35.0-1ubuntu2.10",
     "libcurl3-gnutls:amd64": "7.35.0-1ubuntu2.6",
     "libcurl4-openssl-dev:amd64": "7.35.0-1ubuntu2.10",
@@ -625,8 +637,8 @@
     "libfontconfig1:amd64": "2.11.0-0ubuntu4.2",
     "libfontconfig1-dev": "2.11.0-0ubuntu4.2",
     "libfontenc1:amd64": "1:1.1.2-1",
-    "libfreetype6:amd64": "2.5.2-1ubuntu2.5",
-    "libfreetype6-dev": "2.5.2-1ubuntu2.5",
+    "libfreetype6:amd64": "2.5.2-1ubuntu2.6",
+    "libfreetype6-dev": "2.5.2-1ubuntu2.6",
     "libfreexl1:amd64": "1.0.0g-1ubuntu0.14.04.2",
     "libfribidi0:amd64": "0.19.6-1",
     "libfs6:amd64": "2:1.0.5-1",
@@ -642,7 +654,7 @@
     "libgcr-base-3-1:amd64": "3.10.1-1",
     "libgcrypt11:amd64": "1.5.3-2ubuntu4.4",
     "libgcrypt11-dev": "1.5.3-2ubuntu4.4",
-    "libgd3:amd64": "2.1.0-3ubuntu0.5",
+    "libgd3:amd64": "2.1.0-3ubuntu0.6",
     "libgdal1h": "1.10.1+dfsg-5ubuntu1",
     "libgdbm-dev": "1.8.3-12build1",
     "libgdbm3:amd64": "1.8.3-12build1",
@@ -680,10 +692,10 @@
     "libgnome2-common": "2.32.1-4ubuntu1",
     "libgnomevfs2-0:amd64": "1:2.24.4-1ubuntu6",
     "libgnomevfs2-common": "1:2.24.4-1ubuntu6",
-    "libgnutls-dev": "2.12.23-12ubuntu2.5",
-    "libgnutls-openssl27:amd64": "2.12.23-12ubuntu2.5",
-    "libgnutls26:amd64": "2.12.23-12ubuntu2.5",
-    "libgnutlsxx27:amd64": "2.12.23-12ubuntu2.5",
+    "libgnutls-dev": "2.12.23-12ubuntu2.7",
+    "libgnutls-openssl27:amd64": "2.12.23-12ubuntu2.7",
+    "libgnutls26:amd64": "2.12.23-12ubuntu2.7",
+    "libgnutlsxx27:amd64": "2.12.23-12ubuntu2.7",
     "libgomp1:amd64": "4.8.4-2ubuntu1~14.04.3",
     "libgpg-error-dev": "1.12-0.2ubuntu1",
     "libgpg-error0:amd64": "1.12-0.2ubuntu1",
@@ -696,11 +708,11 @@
     "libgs9": "9.10~dfsg-0ubuntu10.6",
     "libgs9-common": "9.10~dfsg-0ubuntu10.6",
     "libgsm1:amd64": "1.0.13-4",
-    "libgssapi-krb5-2:amd64": "1.12+dfsg-2ubuntu5.2",
+    "libgssapi-krb5-2:amd64": "1.12+dfsg-2ubuntu5.3",
     "libgssapi3-heimdal:amd64": "1.6~git20131207+dfsg-1ubuntu1.1",
-    "libgssrpc4:amd64": "1.12+dfsg-2ubuntu5.2",
-    "libgstreamer-plugins-base1.0-0:amd64": "1.2.4-1~ubuntu2",
-    "libgstreamer-plugins-base1.0-dev": "1.2.4-1~ubuntu2",
+    "libgssrpc4:amd64": "1.12+dfsg-2ubuntu5.3",
+    "libgstreamer-plugins-base1.0-0:amd64": "1.2.4-1~ubuntu2.1",
+    "libgstreamer-plugins-base1.0-dev": "1.2.4-1~ubuntu2.1",
     "libgstreamer1.0-0:amd64": "1.2.4-0ubuntu1.1",
     "libgstreamer1.0-dev": "1.2.4-0ubuntu1.1",
     "libgtk-3-0:amd64": "3.10.8-0ubuntu1.6",
@@ -709,7 +721,7 @@
     "libgtk2.0-0:amd64": "2.24.23-0ubuntu1.4",
     "libgtk2.0-bin": "2.24.23-0ubuntu1.4",
     "libgtk2.0-common": "2.24.23-0ubuntu1.4",
-    "libgudev-1.0-0:amd64": "1:204-5ubuntu20.20",
+    "libgudev-1.0-0:amd64": "1:204-5ubuntu20.24",
     "libgusb2:amd64": "0.1.6-5",
     "libgvc6": "2.36.0-0ubuntu3.1",
     "libgvpr2": "2.36.0-0ubuntu3.1",
@@ -722,8 +734,8 @@
     "libhx509-5-heimdal:amd64": "1.6~git20131207+dfsg-1ubuntu1.1",
     "libice-dev:amd64": "2:1.0.8-2",
     "libice6:amd64": "2:1.0.8-2",
-    "libicu-dev:amd64": "52.1-3ubuntu0.4",
-    "libicu52:amd64": "52.1-3ubuntu0.4",
+    "libicu-dev:amd64": "52.1-3ubuntu0.5",
+    "libicu52:amd64": "52.1-3ubuntu0.5",
     "libidl-common": "0.8.14-0.2ubuntu4",
     "libidl0:amd64": "0.8.14-0.2ubuntu4",
     "libidn11:amd64": "1.28-1ubuntu2.1",
@@ -755,18 +767,18 @@
     "libjs-jquery": "1.7.2+dfsg-2ubuntu1",
     "libjson-c2:amd64": "0.11-3ubuntu1.2",
     "libjson0:amd64": "0.11-3ubuntu1.2",
-    "libk5crypto3:amd64": "1.12+dfsg-2ubuntu5.2",
-    "libkadm5clnt-mit9:amd64": "1.12+dfsg-2ubuntu5.2",
-    "libkadm5srv-mit9:amd64": "1.12+dfsg-2ubuntu5.2",
-    "libkdb5-7:amd64": "1.12+dfsg-2ubuntu5.2",
+    "libk5crypto3:amd64": "1.12+dfsg-2ubuntu5.3",
+    "libkadm5clnt-mit9:amd64": "1.12+dfsg-2ubuntu5.3",
+    "libkadm5srv-mit9:amd64": "1.12+dfsg-2ubuntu5.3",
+    "libkdb5-7:amd64": "1.12+dfsg-2ubuntu5.3",
     "libkeyutils1:amd64": "1.5.6-1",
     "libklibc": "2.0.3-0ubuntu1",
     "libkml0:amd64": "1.3.0~r864-2",
     "libkmod2:amd64": "15-0ubuntu6",
     "libkrb5-26-heimdal:amd64": "1.6~git20131207+dfsg-1ubuntu1.1",
-    "libkrb5-3:amd64": "1.12+dfsg-2ubuntu5.2",
-    "libkrb5-dev": "1.12+dfsg-2ubuntu5.2",
-    "libkrb5support0:amd64": "1.12+dfsg-2ubuntu5.2",
+    "libkrb5-3:amd64": "1.12+dfsg-2ubuntu5.3",
+    "libkrb5-dev": "1.12+dfsg-2ubuntu5.3",
+    "libkrb5support0:amd64": "1.12+dfsg-2ubuntu5.3",
     "liblapack-dev": "3.5.0-2ubuntu1",
     "liblapack3": "3.5.0-2ubuntu1",
     "liblcms2-2:amd64": "2.5-0ubuntu4.1",
@@ -783,20 +795,20 @@
     "libltdl-dev:amd64": "2.4.2-1.7ubuntu1",
     "libltdl7:amd64": "2.4.2-1.7ubuntu1",
     "liblwgeom-2.2-5": "2.2.2+dfsg-5.pgdg14.04+1",
-    "liblwgeom-2.3-0": "2.3.1+dfsg-1.pgdg14.04+1",
+    "liblwgeom-2.3-0": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
     "liblwres90": "1:9.9.5.dfsg-3ubuntu0.7",
-    "liblxc1": "1.0.8-0ubuntu0.4",
+    "liblxc1": "1.0.9-0ubuntu3",
     "liblzma-dev:amd64": "5.1.1alpha+20120614-2ubuntu2",
     "liblzma5:amd64": "5.1.1alpha+20120614-2ubuntu2",
     "liblzo2-2:amd64": "2.06-1.2ubuntu1.1",
     "libm17n-0": "1.6.4-2ubuntu1",
     "libmagic-dev:amd64": "1:5.14-2ubuntu3.3",
     "libmagic1:amd64": "1:5.14-2ubuntu3.3",
-    "libmagickcore-dev": "8:6.7.7.10-6ubuntu3.3",
-    "libmagickcore5:amd64": "8:6.7.7.10-6ubuntu3.3",
-    "libmagickcore5-extra:amd64": "8:6.7.7.10-6ubuntu3.3",
-    "libmagickwand-dev": "8:6.7.7.10-6ubuntu3.3",
-    "libmagickwand5:amd64": "8:6.7.7.10-6ubuntu3.3",
+    "libmagickcore-dev": "8:6.7.7.10-6ubuntu3.6",
+    "libmagickcore5:amd64": "8:6.7.7.10-6ubuntu3.6",
+    "libmagickcore5-extra:amd64": "8:6.7.7.10-6ubuntu3.6",
+    "libmagickwand-dev": "8:6.7.7.10-6ubuntu3.6",
+    "libmagickwand5:amd64": "8:6.7.7.10-6ubuntu3.6",
     "libmail-sendmail-perl": "0.79.16-1",
     "libmcrypt-dev": "2.5.8-3.1ubuntu1",
     "libmcrypt4": "2.5.8-3.1ubuntu1",
@@ -818,7 +830,7 @@
     "libmpfr4:amd64": "3.1.2-1",
     "libmtdev1:amd64": "1.1.4-1ubuntu1",
     "libmysqlclient-dev": "5.7.17-1ubuntu14.04",
-    "libmysqlclient18:amd64": "5.5.53-0ubuntu0.14.04.1",
+    "libmysqlclient18:amd64": "5.5.54-0ubuntu0.14.04.1",
     "libmysqlclient20:amd64": "5.7.17-1ubuntu14.04",
     "libmysqld-dev": "5.7.17-1ubuntu14.04",
     "libncurses5:amd64": "5.9+20140118-1ubuntu1",
@@ -827,7 +839,7 @@
     "libnetcdfc7": "1:4.1.3-7ubuntu2",
     "libnetfilter-conntrack3:amd64": "1.0.4-1",
     "libnetpbm10": "2:10.0-15ubuntu2",
-    "libnettle4:amd64": "2.7.1-1ubuntu0.1",
+    "libnettle4:amd64": "2.7.1-1ubuntu0.2",
     "libnewt0.52:amd64": "0.52.15-2ubuntu5",
     "libnfnetlink0:amd64": "1.0.1-2",
     "libnih-dbus1:amd64": "1.0.3-4ubuntu25",
@@ -874,7 +886,7 @@
     "libpcre3:amd64": "1:8.31-2ubuntu2.3",
     "libpcre3-dev:amd64": "1:8.31-2ubuntu2.3",
     "libpcrecpp0:amd64": "1:8.31-2ubuntu2.3",
-    "libpcsclite1:amd64": "1.8.10-1ubuntu1",
+    "libpcsclite1:amd64": "1.8.10-1ubuntu1.1",
     "libpipeline1:amd64": "1.3.0-1",
     "libpixman-1-0:amd64": "0.30.2-2ubuntu1.1",
     "libpixman-1-dev": "0.30.2-2ubuntu1.1",
@@ -887,8 +899,8 @@
     "libpolkit-gobject-1-0:amd64": "0.105-4ubuntu3.14.04.1",
     "libpoppler44:amd64": "0.24.5-2ubuntu4.4",
     "libpopt0:amd64": "1.16-8ubuntu1",
-    "libpq-dev": "9.6.1-2.pgdg14.04+1",
-    "libpq5:amd64": "9.6.1-2.pgdg14.04+1",
+    "libpq-dev": "9.6.2-1.pgdg14.04+1",
+    "libpq5:amd64": "9.6.2-1.pgdg14.04+1",
     "libprocps3:amd64": "1:3.3.9-1ubuntu2.2",
     "libproj0": "4.8.0-2ubuntu2",
     "libprotobuf-dev:amd64": "2.5.0-9ubuntu1",
@@ -956,7 +968,7 @@
     "libsctp-dev": "1.0.15+dfsg-1",
     "libsctp1:amd64": "1.0.15+dfsg-1",
     "libsdl1.2debian:amd64": "1.2.15-8ubuntu1.1",
-    "libseccomp2:amd64": "2.1.0+dfsg-1",
+    "libseccomp2:amd64": "2.1.1-1ubuntu1~trusty3",
     "libsecret-1-0:amd64": "0.16-0ubuntu1",
     "libsecret-common": "0.16-0ubuntu1",
     "libselinux1:amd64": "2.2.2-1ubuntu0.1",
@@ -975,9 +987,9 @@
     "libsqlite3-0:amd64": "3.8.2-1ubuntu2.1",
     "libsqlite3-dev:amd64": "3.8.2-1ubuntu2.1",
     "libss2:amd64": "1.42.9-3ubuntu1.3",
-    "libssl-dev:amd64": "1.0.1f-1ubuntu2.21",
-    "libssl-doc": "1.0.1f-1ubuntu2.21",
-    "libssl1.0.0:amd64": "1.0.1f-1ubuntu2.21",
+    "libssl-dev:amd64": "1.0.1f-1ubuntu2.22",
+    "libssl-doc": "1.0.1f-1ubuntu2.22",
+    "libssl1.0.0:amd64": "1.0.1f-1ubuntu2.22",
     "libstartup-notification0:amd64": "0.12-3ubuntu1",
     "libstdc++-4.8-dev:amd64": "4.8.4-2ubuntu1~14.04.3",
     "libstdc++6:amd64": "4.8.4-2ubuntu1~14.04.3",
@@ -986,7 +998,7 @@
     "libsybdb5:amd64": "0.91-5",
     "libsys-hostname-long-perl": "1.4-3",
     "libsystemd-daemon0:amd64": "204-5ubuntu20.18",
-    "libsystemd-journal0:amd64": "204-5ubuntu20.20",
+    "libsystemd-journal0:amd64": "204-5ubuntu20.24",
     "libsystemd-login0:amd64": "204-5ubuntu20.18",
     "libtasn1-6:amd64": "3.4-3ubuntu0.4",
     "libtasn1-6-dev": "3.4-3ubuntu0.4",
@@ -1003,9 +1015,9 @@
     "libtheora0:amd64": "1.1.1+dfsg.1-3.2",
     "libtidy-0.99-0": "20091223cvs-1.2ubuntu1.1",
     "libtidy-dev": "20091223cvs-1.2ubuntu1.1",
-    "libtiff5:amd64": "4.0.3-7ubuntu0.4",
-    "libtiff5-dev:amd64": "4.0.3-7ubuntu0.4",
-    "libtiffxx5:amd64": "4.0.3-7ubuntu0.4",
+    "libtiff5:amd64": "4.0.3-7ubuntu0.6",
+    "libtiff5-dev:amd64": "4.0.3-7ubuntu0.6",
+    "libtiffxx5:amd64": "4.0.3-7ubuntu0.6",
     "libtimedate-perl": "2.3000-1",
     "libtinfo-dev:amd64": "5.9+20140118-1ubuntu1",
     "libtinfo5:amd64": "5.9+20140118-1ubuntu1",
@@ -1109,11 +1121,11 @@
     "libxkbfile1:amd64": "1:1.0.8-1",
     "libxml-commons-external-java": "1.4.01-2build1",
     "libxml-commons-resolver1.1-java": "1.2-7build1",
-    "libxml2:amd64": "2.9.1+dfsg1-3ubuntu4.8",
-    "libxml2-dev:amd64": "2.9.1+dfsg1-3ubuntu4.8",
+    "libxml2:amd64": "2.9.1+dfsg1-3ubuntu4.9",
+    "libxml2-dev:amd64": "2.9.1+dfsg1-3ubuntu4.9",
     "libxmu6:amd64": "2:1.1.1-1",
     "libxmuu1:amd64": "2:1.1.1-1",
-    "libxpm4:amd64": "1:3.5.10-1",
+    "libxpm4:amd64": "1:3.5.10-1ubuntu0.1",
     "libxrandr2:amd64": "2:1.5.0-1~trusty1",
     "libxrender-dev:amd64": "1:0.9.8-1build0.14.04.1",
     "libxrender1:amd64": "1:0.9.8-1build0.14.04.1",
@@ -1134,7 +1146,7 @@
     "libxxf86vm1:amd64": "1:1.1.3-1",
     "libyaml-0-2:amd64": "0.1.4-3ubuntu3.1",
     "libyaml-dev:amd64": "0.1.4-3ubuntu3.1",
-    "linux-libc-dev:amd64": "3.13.0-107.154",
+    "linux-libc-dev:amd64": "3.13.0-115.162",
     "lksctp-tools": "1.0.15+dfsg-1",
     "llvm": "1:3.4-0ubuntu1",
     "llvm-3.4": "1:3.4-1ubuntu3",
@@ -1150,8 +1162,8 @@
     "lshw": "02.16-2ubuntu1.3",
     "lsof": "4.86+dfsg-1ubuntu2",
     "ltrace": "0.7.3-4ubuntu5.1",
-    "lxc": "1.0.8-0ubuntu0.4",
-    "lxc-templates": "1.0.8-0ubuntu0.4",
+    "lxc": "1.0.9-0ubuntu3",
+    "lxc-templates": "1.0.9-0ubuntu3",
     "lzop": "1.03-3",
     "m17n-contrib": "1.1.14-1",
     "m17n-db": "1.6.4-1",
@@ -1201,9 +1213,9 @@
     "odbcinst": "2.2.14p2-5ubuntu5",
     "odbcinst1debian2:amd64": "2.2.14p2-5ubuntu5",
     "open-vm-tools": "2:9.4.0-1280544-5ubuntu6.2",
-    "openjdk-7-jdk:amd64": "7u121-2.6.8-1ubuntu0.14.04.1",
-    "openjdk-7-jre:amd64": "7u121-2.6.8-1ubuntu0.14.04.1",
-    "openjdk-7-jre-headless:amd64": "7u121-2.6.8-1ubuntu0.14.04.1",
+    "openjdk-7-jdk:amd64": "7u121-2.6.8-1ubuntu0.14.04.3",
+    "openjdk-7-jre:amd64": "7u121-2.6.8-1ubuntu0.14.04.3",
+    "openjdk-7-jre-headless:amd64": "7u121-2.6.8-1ubuntu0.14.04.3",
     "openjdk-8-jdk:amd64": "8u111-b14-3~14.04.1",
     "openjdk-8-jdk-headless:amd64": "8u111-b14-3~14.04.1",
     "openjdk-8-jre:amd64": "8u111-b14-3~14.04.1",
@@ -1222,11 +1234,11 @@
     "perl": "5.18.2-2ubuntu1",
     "perl-base": "5.18.2-2ubuntu1",
     "perl-modules": "5.18.2-2ubuntu1",
-    "pgdg-keyring": "2014.1",
-    "php5-cli": "5.5.9+dfsg-1ubuntu4.20",
-    "php5-common": "5.5.9+dfsg-1ubuntu4.20",
+    "pgdg-keyring": "2017.1",
+    "php5-cli": "5.5.9+dfsg-1ubuntu4.21",
+    "php5-common": "5.5.9+dfsg-1ubuntu4.21",
     "php5-json": "1.3.2-2build1",
-    "php5-readline": "5.5.9+dfsg-1ubuntu4.20",
+    "php5-readline": "5.5.9+dfsg-1ubuntu4.21",
     "pkg-config": "0.26-1ubuntu4",
     "plymouth": "0.8.8-0ubuntu17.1",
     "plymouth-theme-ubuntu-text": "0.8.8-0ubuntu17.1",
@@ -1236,21 +1248,21 @@
     "pollinate": "4.7-0ubuntu1.4",
     "poppler-data": "0.4.6-4",
     "popularity-contest": "1.57ubuntu1",
-    "postgis": "2.3.1+dfsg-1.pgdg14.04+1",
-    "postgis-doc": "2.3.1+dfsg-1.pgdg14.04+1",
-    "postgresql-9.5": "9.5.5-1.pgdg14.04+1",
+    "postgis": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
+    "postgis-doc": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
+    "postgresql-9.5": "9.5.6-1.pgdg14.04+1",
     "postgresql-9.5-postgis-2.2": "2.2.2+dfsg-7~137.gite11228b.pgdg14.04+1",
-    "postgresql-9.5-postgis-2.3": "2.3.1+dfsg-1.pgdg14.04+1",
-    "postgresql-9.5-postgis-2.3-scripts": "2.3.1+dfsg-1.pgdg14.04+1",
-    "postgresql-9.6": "9.6.1-2.pgdg14.04+1",
-    "postgresql-9.6-postgis-2.3": "2.3.1+dfsg-1.pgdg14.04+1",
-    "postgresql-9.6-postgis-2.3-scripts": "2.3.1+dfsg-1.pgdg14.04+1",
-    "postgresql-client-9.5": "9.5.5-1.pgdg14.04+1",
-    "postgresql-client-9.6": "9.6.1-2.pgdg14.04+1",
-    "postgresql-client-common": "178.pgdg14.04+1",
-    "postgresql-common": "178.pgdg14.04+1",
-    "postgresql-contrib-9.5": "9.5.5-1.pgdg14.04+1",
-    "postgresql-contrib-9.6": "9.6.1-2.pgdg14.04+1",
+    "postgresql-9.5-postgis-2.3": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
+    "postgresql-9.5-postgis-2.3-scripts": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
+    "postgresql-9.6": "9.6.2-1.pgdg14.04+1",
+    "postgresql-9.6-postgis-2.3": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
+    "postgresql-9.6-postgis-2.3-scripts": "2.3.2+dfsg-1~exp2.pgdg14.04+1",
+    "postgresql-client-9.5": "9.5.6-1.pgdg14.04+1",
+    "postgresql-client-9.6": "9.6.2-1.pgdg14.04+1",
+    "postgresql-client-common": "180.pgdg14.04+1",
+    "postgresql-common": "180.pgdg14.04+1",
+    "postgresql-contrib-9.5": "9.5.6-1.pgdg14.04+1",
+    "postgresql-contrib-9.6": "9.6.2-1.pgdg14.04+1",
     "powermgmt-base": "1.31build1",
     "ppp": "2.4.5-5.1ubuntu2.2",
     "pppconfig": "2.3.19ubuntu1",
@@ -1317,7 +1329,7 @@
     "python3-distupgrade": "1:0.220.8",
     "python3-gdbm:amd64": "3.4.3-1~14.04.2",
     "python3-gi": "3.12.0-1ubuntu1",
-    "python3-lxc": "1.0.8-0ubuntu0.4",
+    "python3-lxc": "1.0.9-0ubuntu3",
     "python3-minimal": "3.4.0-0ubuntu2",
     "python3-newt": "0.52.15-2ubuntu5",
     "python3-pkg-resources": "3.3-1ubuntu2",
@@ -1327,7 +1339,7 @@
     "python3-update-manager": "1:0.196.14",
     "python3.4": "3.4.3-1ubuntu1~14.04.5",
     "python3.4-minimal": "3.4.3-1ubuntu1~14.04.5",
-    "qemu-utils": "2.0.0+dfsg-2ubuntu1.30",
+    "qemu-utils": "2.0.0+dfsg-2ubuntu1.32",
     "qt5-default:amd64": "5.2.1+dfsg-1ubuntu14.3",
     "qt5-qmake:amd64": "5.2.1+dfsg-1ubuntu14.3",
     "qt55base": "5.5.1-1basyskom2",

Automatically detect Stack Applications
Install Stack by default
Ubuntu 14.04 Build Image Update 201704-02
Haskell distributions need updating
Add Ruby 2.4.1/2/3.4 to Trusty image?
Support Haskell GHC 7.10.2 (Current Stable Release)
Issue "An error occurred while installing bcrypt" during bundle install
#2

#3