Ubuntu 14.04 Build Image Update 201605-01

build-image

#1

We will update our Ubuntu 14.04 (Trusty) build image between 18th and 19th May.

This build is now live. To use the 14.04 image you need to select it from ‘Project Settings > Build Environment’

This update is going to be a significant release for the build image. We will pre-install many things that our customers wanted and fix bugs.

Nodejs

Adding Nodejs 6.1.0

Now Nodejs 6.1.0 is pre-installed.

Fixing NVM bug

Using implicit version in NVM (Nodejs Version Manager) was broken on Ubuntu 14.04 build image.

For example, the following command didn’t work.

$ nvm install stable
$ nvm install 5

This bug is fixed and now you should be able to specify implicit version to NVM.

GO

Updating Go

Go will be updated to 1.6.2

PHP

Removing PHP 7.0.2 from the pre-installed versions

Since we are now pre-installing PHP 7.0.3 and 7.0.4, we will not pre-install 7.0.2 anymore.

Historically, we never removed anything from the Precise image, but adding more and more versions made the build image gigantic and brought many maintenance issues. We want to avoid being in the same situation, so we like to keep the Trusty image small.

You can still install the version by putting the following in your circle.yml.

machine:
  pre:
    - sudo apt-get install circleci-php-7.0.2

  php:
    version: 7.0.2

Adding PHP 7.0.4

Now PHP 7.0.4 is pre-installed and supported on Ubuntu 14.04 build image.

Enabling Apache PHP module (libphp5.so and libphp7.so)

The module was missing on the build image and this update will install the module for all php versions.

The modules will be installed under the following paths.

For PHP 5

$CIRCLECI_PKG_DIR/php/<version>/usr/lib/apache2/modules/libphp5.so

For PHP 7

$CIRCLECI_PKG_DIR/php/<version>/usr/lib/apache2/modules/libphp7.so

Please note that the installation path for the module is different from Ubuntu 12.04 build image.
We were installing the modules under <path-to-php>/libexec/apache2 on 12.04 build image but they will be installed under usr/lib/apache2/modules on 14.04 build image.

The modules were installed under libexec/apache2 because we were using the fork of php-build but the use of fork has gave us some maintenance costs and we’ve decided to use the upstream php-build which will install under usr/lib/apache2/modules.

Enabling PECL for PHP

PECL was missing for all pre-installed versions. This update will install pecl for all pre-installed versions.

Enabling --enable-intl compile option

Now we build all versions of php with --enable-intl option.

Changing to php.ini-development from php.ini-production

All version of PHP were built with php.ini-production but now php.ini-development is used.

Ruby

Adding 2.1.9 2.2.5 2.3.1

Ruby 2.1.9 2.2.5 2.3.1 will be pre-installed.

Removing 2.0.0-p647 2.1.7 2.2.3

Since we are pre-installing the latest patch level of 2.1 and 2.2 we will remove 2.1.7 and 2.2.3 from the pre-installed versions.

Historically, we never removed anything from the Precise image, but adding more and more versions made the build image gigantic and brought many maintenance issues. We want to avoid being in the same situation, so we like to keep the Trusty image small.

We’ll also remove 2.0.0-p647 since the version is EOL.

You can still install the versions by putting the following in your circle.yml.

machine:
  pre:
    - sudo apt-get install circleci-ruby-2.0.0-p647

  ruby:
    version: ruby-2.0.0-p647
machine:
  pre:
    - sudo apt-get install circleci-ruby-2.1.7

  ruby:
    version: 2.1.7
machine:
  pre:
    - sudo apt-get install circleci-ruby-2.2.3

  ruby:
    version: 2.2.3

Java

Adding ant

Ant was missing on the build image. Now 1.9.3 will be pre-installed.

Browsers

Updating Firefox

Firefox will be updated to 46.0.

Updating Google Chrome

Google Chrome will be updated to 50.0.2661.102.

Updating ChromeDriver

ChromeDriver will be updated to 2.21.371461.

Android

Updating Android SDKs

We will update and install the following Android SDKs.

  • Updating Android SDK tool to r24.4.1
  • Adding build-tools-23.0.3
  • Adding build-tools-23.0.2
  • Adding build-tools-22.0.1
  • Adding extra-android-m2repository
  • Adding extra-google-m2repository
  • Adding extra-google-google_play_services
  • Adding addon-google_apis-google-23
  • Adding addon-google_apis-google-22

Misc

Adding Heroku Toolbelt

Heroku Toolbelt v3.43.2 will be pre-installed.

Adding Jq

Jq 1.5 will be pre-installed.

Fixing CodeDeploy bug

CodeDeploy integration was broken

The image update should fix the bug.

All changes

--- versions.json.before.json   2016-05-12 11:47:34.000000000 +0900
+++ versions.json.after.json    2016-05-12 11:48:27.000000000 +0900
@@ -1,25 +1,44 @@
 {
   "summary": {
-    "build-image": "",
-    "google-chrome": "49.0.2623.110",
-    "chromedriver": "2.12.301324",
-    "firefox": "45.0",
+    "build-image": "trusty-526-4bfd179",
+    "google-chrome": "50.0.2661.102",
+    "chromedriver": "2.21.371461",
+    "firefox": "46.0",
     "mongod": "3.0.7",
-    "psql": "9.5.1",
-    "mysqld": "5.6.28",
+    "psql": "9.5.2",
+    "mysqld": "5.6.30",
     "ruby:": {
       "default": "2.2.4p230",
       "all": [
-        "ruby-2.0.0-p647", "ruby-2.1.7", "ruby-2.1.8", "ruby-2.2.3", "ruby-2.2.4", "ruby-2.3.0"
+        "ruby-2.0.0-p647",
+        "ruby-2.1.7",
+        "ruby-2.1.8",
+        "ruby-2.2.3",
+        "ruby-2.2.4",
+        "ruby-2.3.0"
       ],
       "gem": "2.4.5.1",
       "rvm": "1.27.0 (master)",
-      "bundler": "1.11.2"
+      "bundler": "1.12.3"
     },
     "python:": {
       "default": "2.7.11",
       "all": [
-        "2.7.10", "2.7.11", "3.1.4", "3.1.5", "3.2.5", "3.2.6", "3.3.5", "3.3.6", "3.4.3", "3.4.4", "3.5.0", "3.5.1", "pypy-1.9", "pypy-2.6.1", "pypy-4.0.1"
+        "2.7.10",
+        "2.7.11",
+        "3.1.4",
+        "3.1.5",
+        "3.2.5",
+        "3.2.6",
+        "3.3.5",
+        "3.3.6",
+        "3.4.3",
+        "3.4.4",
+        "3.5.0",
+        "3.5.1",
+        "pypy-1.9",
+        "pypy-2.6.1",
+        "pypy-4.0.1"
       ],
       "pip": "7.1.2",
       "virtualenv": "14.0.3"
@@ -27,40 +46,66 @@
     "nodejs:": {
       "default": "4.2.6",
       "all": [
-        "v0.12.9", "v4.0.0", "v4.1.2", "v4.2.6", "v4.3.0", "v5.0.0", "v5.1.1", "v5.2.0", "v5.3.0", "v5.4.1", "v5.5.0", "v5.6.0", "v5.7.0"
+        "v0.12.9",
+        "v4.0.0",
+        "v4.1.2",
+        "v4.2.6",
+        "v4.3.0",
+        "v5.0.0",
+        "v5.1.1",
+        "v5.2.0",
+        "v5.3.0",
+        "v5.4.1",
+        "v5.5.0",
+        "v5.6.0",
+        "v5.7.0",
+        "v6.1.0"
       ],
       "npm": "2.14.12",
-      "nvm": "0.30.2"
+      "nvm": "0.31.0"
     },
     "php": {
       "default": "5.6.17",
       "all": [
-        "v0.12.9", "v4.0.0", "v4.1.2", "v4.2.6", "v4.3.0", "v5.0.0", "v5.1.1", "v5.2.0", "v5.3.0", "v5.4.1", "v5.5.0", "v5.6.0", "v5.7.0"
+        "v0.12.9",
+        "v4.0.0",
+        "v4.1.2",
+        "v4.2.6",
+        "v4.3.0",
+        "v5.0.0",
+        "v5.1.1",
+        "v5.2.0",
+        "v5.3.0",
+        "v5.4.1",
+        "v5.5.0",
+        "v5.6.0",
+        "v5.7.0",
+        "v6.1.0"
       ]
     },
     "redis": "2.8.4",
     "memcached": "1.4.14",
-    "git": "2.7.4",
+    "git": "2.8.2",
     "cc": "4.8.4",
     "c++": "4.8.4",
     "make": "3.81",
     "lein": "2.5.3",
     "java": "1.8.0_40",
     "maven": "3.2.5",
-    "ant": "",
+    "ant": "1.9.3",
     "apache2": "2.4.7",
     "beanstalkd": "1.9",
     "cassandra": "3.4",
     "elasticsearch": "1.7.2",
     "geos": "3.5.0",
-    "go": "1.6",
+    "go": "1.6.2",
     "gradle": "1.10",
     "phantomjs": "2.1.1",
     "docker-compose": "1.5.2",
-    "heroku-toolbelt": "",
-    "gcloud": "103.0.0",
-    "aws-cli": "1.10.17"
+    "heroku-toolbelt": "3.43.2",
+    "gcloud": "109.0.0",
+    "aws-cli": "1.10.27"
   },
   "all": {
     "accountsservice": "0.6.35-0ubuntu7.2",
@@ -68,14 +113,17 @@
 "acl": "2.2.52-1",
 "acpid": "1:2.0.21-1ubuntu2",
 "adduser": "3.113+nmu3ubuntu3",
+    "ant": "1.9.3-2build1",
+    "ant-optional": "1.9.3-2build1",
 "apache2": "2.4.7-1ubuntu4.9",
 "apache2-bin": "2.4.7-1ubuntu4.9",
 "apache2-data": "2.4.7-1ubuntu4.9",
+    "apache2-dev": "2.4.7-1ubuntu4.9",
 "apparmor": "2.8.95~2430-0ubuntu5.3",
 "apport": "2.14.1-0ubuntu3.19",
 "apport-symptoms": "0.20",
 "apt": "1.0.1ubuntu2.11",
-"apt-transport-https": "1.0.1ubuntu2.11",
+    "apt-transport-https": "1.0.1ubuntu2.13",
 "apt-utils": "1.0.1ubuntu2.11",
 "apt-xapian-index": "0.45ubuntu4",
 "aptitude": "0.6.8.2-1ubuntu4",
@@ -96,11 +144,9 @@
 "binfmt-support": "2.1.4-1",
 "binutils": "2.24-5ubuntu14",
 "bison": "2:2.7.1.dfsg-1",
-"bridge-utils": "1.5-6ubuntu2",
 "bsdmainutils": "9.0.5ubuntu1",
 "bsdtar": "3.1.2-7ubuntu2.1",
 "bsdutils": "1:2.20.1-5.1ubuntu20.7",
-"btrfs-tools": "3.12-1ubuntu0.1",
 "build-essential": "11.6ubuntu6",
 "busybox-initramfs": "1:1.21.0-1ubuntu1",
 "busybox-static": "1:1.21.0-1ubuntu1",
@@ -109,7 +155,6 @@
 "ca-certificates": "20160104ubuntu0.14.04.1",
 "ca-certificates-java": "20130815ubuntu1",
 "cassandra": "3.4",
-"cgmanager": "0.24-0ubuntu7.5",
 "cgroup-lite": "1.9",
 "circleci-nodejs-0.12.9": "1",
 "circleci-nodejs-4.0.0": "1",
@@ -124,12 +169,13 @@
 "circleci-nodejs-5.5.0": "1",
 "circleci-nodejs-5.6.0": "1",
 "circleci-nodejs-5.7.0": "1",
-"circleci-php-5.5.31": "1",
-"circleci-php-5.5.32": "1",
-"circleci-php-5.6.17": "1",
-"circleci-php-5.6.18": "1",
-"circleci-php-7.0.2": "1",
-"circleci-php-7.0.3": "1",
+    "circleci-nodejs-6.1.0": "1",
+    "circleci-php-5.5.31": "3",
+    "circleci-php-5.5.32": "3",
+    "circleci-php-5.6.17": "3",
+    "circleci-php-5.6.18": "3",
+    "circleci-php-7.0.3": "3",
+    "circleci-php-7.0.4": "3",
 "circleci-python-2.7.10": "1",
 "circleci-python-2.7.11": "1",
 "circleci-python-3.1.4": "1",
@@ -152,7 +198,6 @@
 "circleci-ruby-2.2.4": "1",
 "circleci-ruby-2.3.0": "1",
 "cloud-guest-utils": "0.27-0ubuntu9.1",
-"cloud-image-utils": "0.27-0ubuntu9.2",
 "cloud-init": "0.7.5-0ubuntu1.15",
 "cmake": "2.8.12.2-0ubuntu3",
 "cmake-data": "2.8.12.2-0ubuntu3",
@@ -179,21 +224,18 @@
 "debconf-i18n": "1.5.51ubuntu2",
 "debhelper": "9.20131227ubuntu1",
 "debianutils": "4.4",
-"debootstrap": "1.0.59ubuntu0.4",
+    "default-jre-headless": "2:1.7-51",
 "desktop-file-utils": "0.22-1ubuntu1",
 "dh-apparmor": "2.8.95~2430-0ubuntu5.3",
 "dh-python": "1.20140128-1ubuntu8.2",
 "diffutils": "1:3.3-1",
-"distro-info": "0.12",
-"distro-info-data": "0.18ubuntu0.4",
 "dmidecode": "2.12-2",
 "dmsetup": "2:1.02.77-6ubuntu2",
-"dnsmasq-base": "2.68-1ubuntu0.1",
 "dnsutils": "1:9.9.5.dfsg-3ubuntu0.7",
 "docker-engine": "1.10.3-0~trusty",
 "dosfstools": "3.0.26-1",
 "dpkg": "1.17.5ubuntu5.5",
-"dpkg-dev": "1.17.5ubuntu5.5",
+    "dpkg-dev": "1.17.5ubuntu5.6",
 "e2fslibs:amd64": "1.42.9-3ubuntu1.3",
 "e2fsprogs": "1.42.9-3ubuntu1.3",
 "eatmydata": "26-2",
@@ -233,11 +275,10 @@
 "erlang-webtool": "1:16.b.3-dfsg-1ubuntu2.1",
 "erlang-xmerl": "1:16.b.3-dfsg-1ubuntu2.1",
 "ethtool": "1:3.13-1",
-"euca2ools": "3.0.2-1ubuntu1",
 "fakeroot": "1.20-3ubuntu2",
 "file": "1:5.14-2ubuntu3.3",
 "findutils": "4.4.2-7",
-"firefox": "45.0+build2-0ubuntu0.14.04.1",
+    "firefox": "46.0+build5-0ubuntu0.14.04.2",
 "fontconfig": "2.11.0-0ubuntu4.1",
 "fontconfig-config": "2.11.0-0ubuntu4.1",
 "fonts-dejavu-core": "2.34-1ubuntu1",
@@ -260,7 +301,6 @@
 "gconf2-common": "3.2.6-0ubuntu2",
 "gdb": "7.7.1-0ubuntu5~14.04.2",
 "gdisk": "0.8.8-1ubuntu0.1",
-"genisoimage": "9:1.1.11-2ubuntu3",
 "geoip-database": "20140313-1",
 "gettext": "0.18.3.1-1ubuntu3",
 "gettext-base": "0.18.3.1-1ubuntu3",
@@ -273,10 +313,10 @@
 "gir1.2-gst-plugins-base-1.0": "1.2.4-1~ubuntu2",
 "gir1.2-gstreamer-1.0": "1.2.4-0ubuntu1",
 "gir1.2-rsvg-2.0": "2.40.2-1",
-"git": "1:2.7.4-0ppa1~ubuntu14.04.1",
-"git-man": "1:2.7.4-0ppa1~ubuntu14.04.1",
+    "git": "1:2.8.2-0ppa1~ubuntu14.04.1",
+    "git-man": "1:2.8.2-0ppa1~ubuntu14.04.1",
 "gnupg": "1.4.16-1ubuntu2.3",
-"google-chrome-stable": "49.0.2623.110-1",
+    "google-chrome-stable": "50.0.2661.102-1",
 "gpgv": "1.4.16-1ubuntu2.3",
 "grep": "2.16-1",
 "groff-base": "1.22.2-5",
@@ -287,6 +327,8 @@
 "gvfs-libs:amd64": "1.20.3-0ubuntu1.2",
 "gzip": "1.6-3ubuntu1",
 "hdparm": "9.43-1ubuntu3",
+    "heroku": "3.43.2",
+    "heroku-toolbelt": "3.43.2",
 "hicolor-icon-theme": "0.13-1",
 "hostname": "3.15ubuntu1",
 "htop": "1.0.2-3",
@@ -312,7 +354,6 @@
 "isc-dhcp-common": "4.2.4-7ubuntu12.4",
 "iso-codes": "3.52-1",
 "java-common": "0.51",
-"jq": "1.3-1.1ubuntu1",
 "kbd": "1.15.5-1ubuntu1",
 "keyboard-configuration": "1.70ubuntu8",
 "klibc-utils": "2.0.3-0ubuntu1",
@@ -333,14 +374,16 @@
 "libalgorithm-diff-perl": "1.19.02-3",
 "libalgorithm-diff-xs-perl": "0.04-2build4",
 "libalgorithm-merge-perl": "0.08-2",
-"libapache2-mod-php5": "5.5.9+dfsg-1ubuntu4.14",
+    "libapache2-mod-php5": "5.5.9+dfsg-1ubuntu4.16",
 "libapparmor-perl": "2.8.95~2430-0ubuntu5.3",
 "libapparmor1:amd64": "2.8.95~2430-0ubuntu5.3",
 "libappindicator1": "12.10.1+13.10.20130920-0ubuntu4.1",
 "libappindicator3-1": "12.10.1+13.10.20130920-0ubuntu4.1",
 "libapr1:amd64": "1.5.0-1",
+    "libapr1-dev": "1.5.0-1",
 "libaprutil1:amd64": "1.5.3-1",
 "libaprutil1-dbd-sqlite3:amd64": "1.5.3-1",
+    "libaprutil1-dev": "1.5.3-1",
 "libaprutil1-ldap:amd64": "1.5.3-1",
 "libapt-inst1.5:amd64": "1.0.1ubuntu2.11",
 "libapt-pkg4.12:amd64": "1.0.1ubuntu2.11",
@@ -386,7 +429,6 @@
 "libbonobo2-common": "2.32.1-0ubuntu5",
 "libboost-iostreams1.54.0:amd64": "1.54.0-4ubuntu3.1",
 "libboost-system1.54.0:amd64": "1.54.0-4ubuntu3.1",
-"libboost-thread1.54.0:amd64": "1.54.0-4ubuntu3.1",
 "libbsd0:amd64": "0.6.0-2ubuntu1",
 "libbz2-1.0:amd64": "1.0.6-5",
 "libbz2-dev:amd64": "1.0.6-5",
@@ -447,7 +489,7 @@
 "libdjvulibre-text": "3.5.25.4-3",
 "libdjvulibre21:amd64": "3.5.25.4-3",
 "libdns100": "1:9.9.5.dfsg-3ubuntu0.7",
-"libdpkg-perl": "1.17.5ubuntu5.5",
+    "libdpkg-perl": "1.17.5ubuntu5.6",
 "libdrm-amdgpu1:amd64": "2.4.64-1~ubuntu14.04.1",
 "libdrm-dev:amd64": "2.4.64-1~ubuntu14.04.1",
 "libdrm-intel1:amd64": "2.4.64-1~ubuntu14.04.1",
@@ -564,7 +606,7 @@
 "libgtk2.0-0:amd64": "2.24.23-0ubuntu1.4",
 "libgtk2.0-bin": "2.24.23-0ubuntu1.4",
 "libgtk2.0-common": "2.24.23-0ubuntu1.4",
-"libgudev-1.0-0:amd64": "1:204-5ubuntu20.18",
+    "libgudev-1.0-0:amd64": "1:204-5ubuntu20.19",
 "libgusb2:amd64": "0.1.6-5",
 "libgvc6": "2.36.0-0ubuntu3.1",
 "libgvpr2": "2.36.0-0ubuntu3.1",
@@ -625,8 +667,8 @@
 "libkrb5support0:amd64": "1.12+dfsg-2ubuntu5.2",
 "liblapack-dev": "3.5.0-2ubuntu1",
 "liblapack3": "3.5.0-2ubuntu1",
-"liblcms2-2:amd64": "2.5-0ubuntu4",
-"liblcms2-dev:amd64": "2.5-0ubuntu4",
+    "liblcms2-2:amd64": "2.5-0ubuntu4.1",
+    "liblcms2-dev:amd64": "2.5-0ubuntu4.1",
 "libldap-2.4-2:amd64": "2.4.31-1+nmu2ubuntu8.2",
 "libldap2-dev:amd64": "2.4.31-1+nmu2ubuntu8.2",
 "libllvm3.4:amd64": "1:3.4-1ubuntu3",
@@ -639,9 +681,8 @@
 "libltdl-dev:amd64": "2.4.2-1.7ubuntu1",
 "libltdl7:amd64": "2.4.2-1.7ubuntu1",
 "liblwgeom-2.1.8": "2.1.8+dfsg-5~97.git43a09cc.pgdg14.04+1",
-"liblwgeom-2.2-5": "2.2.1+dfsg-2.pgdg14.04+1",
+    "liblwgeom-2.2-5": "2.2.2+dfsg-1.pgdg14.04+1",
 "liblwres90": "1:9.9.5.dfsg-3ubuntu0.7",
-"liblxc1": "1.0.8-0ubuntu0.3",
 "liblzma-dev:amd64": "5.1.1alpha+20120614-2ubuntu2",
 "liblzma5:amd64": "5.1.1alpha+20120614-2ubuntu2",
 "liblzo2-2:amd64": "2.06-1.2ubuntu1.1",
@@ -663,21 +704,19 @@
 "libmirclientplatform-mesa:amd64": "0.1.8+14.04.20140411-0ubuntu1",
 "libmirprotobuf-dev:amd64": "0.1.8+14.04.20140411-0ubuntu1",
 "libmirprotobuf0:amd64": "0.1.8+14.04.20140411-0ubuntu1",
-"libmnl0:amd64": "1.0.3-3ubuntu1",
 "libmodule-pluggable-perl": "5.1-1",
 "libmount1:amd64": "2.20.1-5.1ubuntu20.7",
 "libmp3lame0:amd64": "3.99.5+repack1-3ubuntu1",
 "libmpc3:amd64": "1.0.1-1ubuntu1",
 "libmpdec2:amd64": "2.4.0-6",
 "libmpfr4:amd64": "3.1.2-1",
-"libmysqlclient-dev": "5.5.47-0ubuntu0.14.04.1",
-"libmysqlclient18:amd64": "5.5.47-0ubuntu0.14.04.1",
-"libmysqld-dev": "5.5.47-0ubuntu0.14.04.1",
+    "libmysqlclient-dev": "5.5.49-0ubuntu0.14.04.1",
+    "libmysqlclient18:amd64": "5.5.49-0ubuntu0.14.04.1",
+    "libmysqld-dev": "5.5.49-0ubuntu0.14.04.1",
 "libncurses5:amd64": "5.9+20140118-1ubuntu1",
 "libncurses5-dev:amd64": "5.9+20140118-1ubuntu1",
 "libncursesw5:amd64": "5.9+20140118-1ubuntu1",
 "libnetcdfc7": "1:4.1.3-7ubuntu2",
-"libnetfilter-conntrack3:amd64": "1.0.4-1",
 "libnetpbm10": "2:10.0-15ubuntu2",
 "libnettle4:amd64": "2.7.1-1ubuntu0.1",
 "libnewt0.52:amd64": "0.52.15-2ubuntu5",
@@ -723,9 +762,9 @@
 "libpcap0.8:amd64": "1.5.3-2",
 "libpci3:amd64": "1:3.2.1-1ubuntu5.1",
 "libpciaccess0:amd64": "0.13.2-1",
-"libpcre3:amd64": "1:8.31-2ubuntu2.2",
-"libpcre3-dev:amd64": "1:8.31-2ubuntu2.2",
-"libpcrecpp0:amd64": "1:8.31-2ubuntu2.2",
+    "libpcre3:amd64": "1:8.31-2ubuntu2.3",
+    "libpcre3-dev:amd64": "1:8.31-2ubuntu2.3",
+    "libpcrecpp0:amd64": "1:8.31-2ubuntu2.3",
 "libpcsclite1:amd64": "1.8.10-1ubuntu1",
 "libpipeline1:amd64": "1.3.0-1",
 "libpixman-1-0:amd64": "0.30.2-2ubuntu1.1",
@@ -737,10 +776,10 @@
 "libpolkit-agent-1-0:amd64": "0.105-4ubuntu3.14.04.1",
 "libpolkit-backend-1-0:amd64": "0.105-4ubuntu3.14.04.1",
 "libpolkit-gobject-1-0:amd64": "0.105-4ubuntu3.14.04.1",
-"libpoppler44:amd64": "0.24.5-2ubuntu4.3",
+    "libpoppler44:amd64": "0.24.5-2ubuntu4.4",
 "libpopt0:amd64": "1.16-8ubuntu1",
-"libpq-dev": "9.5.1-1.pgdg14.04+1",
-"libpq5:amd64": "9.5.1-1.pgdg14.04+1",
+    "libpq-dev": "9.5.2-1.pgdg14.04+1",
+    "libpq5:amd64": "9.5.2-1.pgdg14.04+1",
 "libprocps3:amd64": "1:3.3.9-1ubuntu2.2",
 "libproj0": "4.8.0-2ubuntu2",
 "libprotobuf-dev:amd64": "2.5.0-9ubuntu1",
@@ -784,9 +823,7 @@
 "libqt5widgets5:amd64": "5.2.1+dfsg-1ubuntu14.3",
 "libqt5xml5:amd64": "5.2.1+dfsg-1ubuntu14.3",
 "libquadmath0:amd64": "4.8.4-2ubuntu1~14.04.1",
-"librados2": "0.80.11-0ubuntu1.14.04.1",
 "libraw1394-11:amd64": "2.1.0-1ubuntu1",
-"librbd1": "0.80.11-0ubuntu1.14.04.1",
 "libreadline-dev:amd64": "6.3-4ubuntu2",
 "libreadline6:amd64": "6.3-4ubuntu2",
 "libreadline6-dev:amd64": "6.3-4ubuntu2",
@@ -804,14 +841,15 @@
 "libsasl2-modules:amd64": "2.1.25.dfsg1-17build1",
 "libsasl2-modules-db:amd64": "2.1.25.dfsg1-17build1",
 "libschroedinger-1.0-0:amd64": "1.0.11-2ubuntu1",
+    "libsctp-dev": "1.0.15+dfsg-1",
 "libsctp1:amd64": "1.0.15+dfsg-1",
 "libsdl1.2debian:amd64": "1.2.15-8ubuntu1.1",
-"libseccomp2:amd64": "2.1.0+dfsg-1",
 "libsecret-1-0:amd64": "0.16-0ubuntu1",
 "libsecret-common": "0.16-0ubuntu1",
 "libselinux1:amd64": "2.2.2-1ubuntu0.1",
 "libsemanage-common": "2.2-1",
 "libsemanage1:amd64": "2.2-1",
+    "libsensors4:amd64": "1:3.3.4-2ubuntu1",
 "libsepol1:amd64": "2.2-1ubuntu0.1",
 "libsigc++-2.0-0c2a:amd64": "2.2.10-0.2ubuntu2",
 "libsigsegv2:amd64": "2.10-2",
@@ -824,9 +862,9 @@
 "libsqlite3-0:amd64": "3.8.2-1ubuntu2.1",
 "libsqlite3-dev:amd64": "3.8.2-1ubuntu2.1",
 "libss2:amd64": "1.42.9-3ubuntu1.3",
-"libssl-dev:amd64": "1.0.1f-1ubuntu2.18",
-"libssl-doc": "1.0.1f-1ubuntu2.18",
-"libssl1.0.0:amd64": "1.0.1f-1ubuntu2.18",
+    "libssl-dev:amd64": "1.0.1f-1ubuntu2.19",
+    "libssl-doc": "1.0.1f-1ubuntu2.19",
+    "libssl1.0.0:amd64": "1.0.1f-1ubuntu2.19",
 "libstartup-notification0:amd64": "0.12-3ubuntu1",
 "libstdc++-4.8-dev:amd64": "4.8.4-2ubuntu1~14.04.1",
 "libstdc++6:amd64": "4.8.4-2ubuntu1~14.04.1",
@@ -834,12 +872,12 @@
 "libswscale2:amd64": "6:9.18-0ubuntu0.14.04.1",
 "libsys-hostname-long-perl": "1.4-3",
 "libsystemd-daemon0:amd64": "204-5ubuntu20.18",
-"libsystemd-journal0:amd64": "204-5ubuntu20.18",
+    "libsystemd-journal0:amd64": "204-5ubuntu20.19",
 "libsystemd-login0:amd64": "204-5ubuntu20.18",
-"libtasn1-6:amd64": "3.4-3ubuntu0.3",
-"libtasn1-6-dev": "3.4-3ubuntu0.3",
+    "libtasn1-6:amd64": "3.4-3ubuntu0.4",
+    "libtasn1-6-dev": "3.4-3ubuntu0.4",
 "libtcl8.6:amd64": "8.6.1-4ubuntu1",
-"libtdb1:amd64": "1.2.12-1",
+    "libtdb1:amd64": "1.3.8-0ubuntu0.14.04.1",
 "libterm-readkey-perl": "2.31-1",
 "libterm-ui-perl": "0.42-1",
 "libtext-charwidth-perl": "0.04-7build3",
@@ -936,6 +974,7 @@
 "libxdmcp6:amd64": "1:1.1.1-1",
 "libxdot4": "2.36.0-0ubuntu3.1",
 "libxerces-c3.1:amd64": "3.1.1-5.1+deb8u1build0.14.04.1",
+    "libxerces2-java": "2.11.0-7",
 "libxext-dev:amd64": "2:1.3.2-1ubuntu0.0.14.04.1",
 "libxext6:amd64": "2:1.3.2-1ubuntu0.0.14.04.1",
 "libxfce4ui-1-0": "4.11.1-2ubuntu1",
@@ -953,6 +992,8 @@
 "libxkbcommon-x11-0:amd64": "0.4.1-0ubuntu1",
 "libxkbcommon0:amd64": "0.4.1-0ubuntu1",
 "libxkbfile1:amd64": "1:1.0.8-1",
+    "libxml-commons-external-java": "1.4.01-2build1",
+    "libxml-commons-resolver1.1-java": "1.2-7build1",
 "libxml2:amd64": "2.9.1+dfsg1-3ubuntu4.7",
 "libxml2-dev:amd64": "2.9.1+dfsg1-3ubuntu4.7",
 "libxmu6:amd64": "2:1.1.1-1",
@@ -978,7 +1019,7 @@
 "libxxf86vm1:amd64": "1:1.1.3-1",
 "libyaml-0-2:amd64": "0.1.4-3ubuntu3.1",
 "libyaml-dev:amd64": "0.1.4-3ubuntu3.1",
-"linux-libc-dev:amd64": "3.13.0-83.127",
+    "linux-libc-dev:amd64": "3.13.0-86.130",
 "lksctp-tools": "1.0.15+dfsg-1",
 "llvm": "1:3.4-0ubuntu1",
 "llvm-3.4": "1:3.4-1ubuntu3",
@@ -994,8 +1035,6 @@
 "lshw": "02.16-2ubuntu1.3",
 "lsof": "4.86+dfsg-1ubuntu2",
 "ltrace": "0.7.3-4ubuntu5.1",
-"lxc": "1.0.8-0ubuntu0.3",
-"lxc-templates": "1.0.8-0ubuntu0.3",
 "lzop": "1.03-3",
 "m17n-contrib": "1.1.14-1",
 "m17n-db": "1.6.4-1",
@@ -1023,12 +1062,12 @@
 "mountall": "2.53",
 "mtr-tiny": "0.85-2",
 "multiarch-support": "2.19-0ubuntu6.7",
-"mysql-client-5.6": "5.6.28-0ubuntu0.14.04.1",
-"mysql-client-core-5.6": "5.6.28-0ubuntu0.14.04.1",
-"mysql-common": "5.5.47-0ubuntu0.14.04.1",
-"mysql-common-5.6": "5.6.28-0ubuntu0.14.04.1",
-"mysql-server-5.6": "5.6.28-0ubuntu0.14.04.1",
-"mysql-server-core-5.6": "5.6.28-0ubuntu0.14.04.1",
+    "mysql-client-5.6": "5.6.30-0ubuntu0.14.04.1",
+    "mysql-client-core-5.6": "5.6.30-0ubuntu0.14.04.1",
+    "mysql-common": "5.5.49-0ubuntu0.14.04.1",
+    "mysql-common-5.6": "5.6.30-0ubuntu0.14.04.1",
+    "mysql-server-5.6": "5.6.30-0ubuntu0.14.04.1",
+    "mysql-server-core-5.6": "5.6.30-0ubuntu0.14.04.1",
 "nano": "2.2.6-1ubuntu1",
 "ncurses-base": "5.9+20140118-1ubuntu1",
 "ncurses-bin": "5.9+20140118-1ubuntu1",
@@ -1045,12 +1084,13 @@
 "odbcinst": "2.2.14p2-5ubuntu5",
 "odbcinst1debian2:amd64": "2.2.14p2-5ubuntu5",
 "open-vm-tools": "2:9.4.0-1280544-5ubuntu6.2",
-"openjdk-7-jdk:amd64": "7u95-2.6.4-0ubuntu0.14.04.2",
-"openjdk-7-jre:amd64": "7u95-2.6.4-0ubuntu0.14.04.2",
-"openjdk-7-jre-headless:amd64": "7u95-2.6.4-0ubuntu0.14.04.2",
-"openjdk-8-jdk:amd64": "8u72-b15-1~trusty1",
-"openjdk-8-jre:amd64": "8u72-b15-1~trusty1",
-"openjdk-8-jre-headless:amd64": "8u72-b15-1~trusty1",
+    "openjdk-7-jdk:amd64": "7u101-2.6.6-0ubuntu0.14.04.1",
+    "openjdk-7-jre:amd64": "7u101-2.6.6-0ubuntu0.14.04.1",
+    "openjdk-7-jre-headless:amd64": "7u101-2.6.6-0ubuntu0.14.04.1",
+    "openjdk-8-jdk:amd64": "8u91-b14-0ubuntu4~14.04",
+    "openjdk-8-jdk-headless:amd64": "8u91-b14-0ubuntu4~14.04",
+    "openjdk-8-jre:amd64": "8u91-b14-0ubuntu4~14.04",
+    "openjdk-8-jre-headless:amd64": "8u91-b14-0ubuntu4~14.04",
 "openssh-client": "1:6.6p1-2ubuntu2.6",
 "openssh-server": "1:6.6p1-2ubuntu2.6",
 "openssh-sftp-server": "1:6.6p1-2ubuntu2.6",
@@ -1066,10 +1106,10 @@
 "perl-base": "5.18.2-2ubuntu1",
 "perl-modules": "5.18.2-2ubuntu1",
 "pgdg-keyring": "2014.1",
-"php5-cli": "5.5.9+dfsg-1ubuntu4.14",
-"php5-common": "5.5.9+dfsg-1ubuntu4.14",
+    "php5-cli": "5.5.9+dfsg-1ubuntu4.16",
+    "php5-common": "5.5.9+dfsg-1ubuntu4.16",
 "php5-json": "1.3.2-2build1",
-"php5-readline": "5.5.9+dfsg-1ubuntu4.14",
+    "php5-readline": "5.5.9+dfsg-1ubuntu4.16",
 "pkg-config": "0.26-1ubuntu4",
 "plymouth": "0.8.8-0ubuntu17.1",
 "plymouth-theme-ubuntu-text": "0.8.8-0ubuntu17.1",
@@ -1079,21 +1119,21 @@
 "pollinate": "4.7-0ubuntu1.4",
 "poppler-data": "0.4.6-4",
 "popularity-contest": "1.57ubuntu1",
-"postgis": "2.2.1+dfsg-2.pgdg14.04+1",
-"postgis-doc": "2.2.1+dfsg-2.pgdg14.04+1",
-"postgresql-9.4": "9.4.6-1.pgdg14.04+1",
+    "postgis": "2.2.2+dfsg-1.pgdg14.04+1",
+    "postgis-doc": "2.2.2+dfsg-1.pgdg14.04+1",
+    "postgresql-9.4": "9.4.7-1.pgdg14.04+1",
 "postgresql-9.4-postgis-2.1": "2.1.8+dfsg-5~97.git43a09cc.pgdg14.04+1",
-"postgresql-9.4-postgis-2.2": "2.2.1+dfsg-2.pgdg14.04+1",
-"postgresql-9.4-postgis-scripts": "2.2.1+dfsg-2.pgdg14.04+1",
-"postgresql-9.5": "9.5.1-1.pgdg14.04+1",
-"postgresql-9.5-postgis-2.2": "2.2.1+dfsg-2.pgdg14.04+1",
-"postgresql-9.5-postgis-scripts": "2.2.1+dfsg-2.pgdg14.04+1",
-"postgresql-client-9.4": "9.4.6-1.pgdg14.04+1",
-"postgresql-client-9.5": "9.5.1-1.pgdg14.04+1",
-"postgresql-client-common": "172.pgdg14.04+1",
-"postgresql-common": "172.pgdg14.04+1",
-"postgresql-contrib-9.4": "9.4.6-1.pgdg14.04+1",
-"postgresql-contrib-9.5": "9.5.1-1.pgdg14.04+1",
+    "postgresql-9.4-postgis-2.2": "2.2.2+dfsg-1.pgdg14.04+1",
+    "postgresql-9.4-postgis-scripts": "2.2.2+dfsg-1.pgdg14.04+1",
+    "postgresql-9.5": "9.5.2-1.pgdg14.04+1",
+    "postgresql-9.5-postgis-2.2": "2.2.2+dfsg-1.pgdg14.04+1",
+    "postgresql-9.5-postgis-scripts": "2.2.2+dfsg-1.pgdg14.04+1",
+    "postgresql-client-9.4": "9.4.7-1.pgdg14.04+1",
+    "postgresql-client-9.5": "9.5.2-1.pgdg14.04+1",
+    "postgresql-client-common": "173.pgdg14.04+1",
+    "postgresql-common": "173.pgdg14.04+1",
+    "postgresql-contrib-9.4": "9.4.7-1.pgdg14.04+1",
+    "postgresql-contrib-9.5": "9.5.2-1.pgdg14.04+1",
 "powermgmt-base": "1.31build1",
 "ppp": "2.4.5-5.1ubuntu2.2",
 "pppconfig": "2.3.19ubuntu1",
@@ -1107,32 +1147,43 @@
 "python-apt": "0.9.3.5ubuntu2",
 "python-apt-common": "0.9.3.5ubuntu2",
 "python-chardet": "2.0.1-2build2",
+    "python-chardet-whl": "2.2.1-2~ubuntu1",
 "python-cheetah": "2.4.4-3.fakesyncbuild1",
+    "python-colorama": "0.2.5-0.1ubuntu2",
+    "python-colorama-whl": "0.2.5-0.1ubuntu2",
 "python-configobj": "4.7.2+ds-5build1",
 "python-debian": "0.1.21+nmu2ubuntu2",
-"python-distro-info": "0.12",
+    "python-distlib": "0.1.8-1ubuntu1",
+    "python-distlib-whl": "0.1.8-1ubuntu1",
 "python-gdbm": "2.7.5-1ubuntu1",
+    "python-html5lib": "0.999-3~ubuntu1",
+    "python-html5lib-whl": "0.999-3~ubuntu1",
 "python-json-pointer": "1.0-2build1",
 "python-jsonpatch": "1.3-4",
-"python-lxml": "3.3.3-1ubuntu0.1",
 "python-minimal": "2.7.5-5ubuntu3",
 "python-oauth": "1.0.1-3build2",
 "python-openssl": "0.13-2ubuntu6",
 "python-pam": "0.4.2-13.1ubuntu3",
+    "python-pip": "1.5.4-1ubuntu3",
+    "python-pip-whl": "1.5.4-1ubuntu3",
 "python-pkg-resources": "3.3-1ubuntu2",
 "python-prettytable": "0.7.2-2ubuntu2",
 "python-pycurl": "7.19.3-0ubuntu3",
-"python-requestbuilder": "0.1.0~beta2-1build1",
 "python-requests": "2.2.1-1ubuntu0.3",
+    "python-requests-whl": "2.2.1-1ubuntu0.3",
 "python-serial": "2.6-1build1",
 "python-setuptools": "3.3-1ubuntu2",
+    "python-setuptools-whl": "3.3-1ubuntu2",
 "python-six": "1.5.2-1ubuntu1",
+    "python-six-whl": "1.5.2-1ubuntu1",
 "python-support": "1.0.15",
 "python-twisted-bin": "13.2.0-1ubuntu1",
 "python-twisted-core": "13.2.0-1ubuntu1",
 "python-twisted-names": "13.2.0-1ubuntu1",
 "python-twisted-web": "13.2.0-1ubuntu1",
 "python-urllib3": "1.7.1-1ubuntu4",
+    "python-urllib3-whl": "1.7.1-1ubuntu4",
+    "python-wheel": "0.24.0-1~ubuntu1",
 "python-xapian": "1.2.16-2ubuntu1",
 "python-yaml": "3.10-4ubuntu0.1",
 "python-zope.interface": "4.0.5-1ubuntu4",
@@ -1146,16 +1197,15 @@
 "python3-distupgrade": "1:0.220.8",
 "python3-gdbm:amd64": "3.4.3-1~14.04.2",
 "python3-gi": "3.12.0-1ubuntu1",
-"python3-lxc": "1.0.8-0ubuntu0.3",
 "python3-minimal": "3.4.0-0ubuntu2",
 "python3-newt": "0.52.15-2ubuntu5",
+    "python3-pkg-resources": "3.3-1ubuntu2",
 "python3-problem-report": "2.14.1-0ubuntu3.19",
 "python3-pycurl": "7.19.3-0ubuntu3",
 "python3-software-properties": "0.92.37.7",
 "python3-update-manager": "1:0.196.14",
 "python3.4": "3.4.3-1ubuntu1~14.04.3",
 "python3.4-minimal": "3.4.3-1ubuntu1~14.04.3",
-"qemu-utils": "2.0.0+dfsg-2ubuntu1.22",
 "qt5-default:amd64": "5.2.1+dfsg-1ubuntu14.3",
 "qt5-qmake:amd64": "5.2.1+dfsg-1ubuntu14.3",
 "qtbase5-dev:amd64": "5.2.1+dfsg-1ubuntu14.3",
@@ -1185,7 +1235,6 @@
 "sensible-utils": "0.0.9",
 "sgml-base": "1.26+nmu4ubuntu1",
 "shared-mime-info": "1.2-0ubuntu3",
-"sharutils": "1:4.14-1ubuntu1",
 "software-properties-common": "0.92.37.7",
 "sound-theme-freedesktop": "0.8-1",
 "ssh-import-id": "3.21-0ubuntu1",
@@ -1194,6 +1243,7 @@
 "sudo": "1.8.9p5-1ubuntu1.2",
 "swig": "2.0.11-1ubuntu2",
 "swig2.0": "2.0.11-1ubuntu2",
+    "sysstat": "10.2.0-1",
 "systemd-services": "204-5ubuntu20.18",
 "systemd-shim": "6-2bzr1",
 "sysv-rc": "2.88dsf-41ubuntu6.3",
@@ -1211,8 +1261,8 @@
 "tk": "8.6.0+6ubuntu3",
 "tk8.6": "8.6.1-3ubuntu2",
 "tmux": "1.8-5",
-"tzdata": "2016c-0ubuntu0.14.04",
-"tzdata-java": "2016c-0ubuntu0.14.04",
+    "tzdata": "2016d-0ubuntu0.14.04",
+    "tzdata-java": "2016d-0ubuntu0.14.04",
 "ubuntu-keyring": "2012.05.19",
 "ubuntu-minimal": "1.325",
 "ubuntu-release-upgrader-core": "1:0.220.8",
@@ -1221,7 +1271,6 @@
 "udev": "204-5ubuntu20.18",
 "udisks2": "2.1.3-1ubuntu0.1",
 "ufw": "0.34~rc-0ubuntu2",
-"uidmap": "1:4.1.5.1-1ubuntu9.2",
 "unattended-upgrades": "0.82.1ubuntu2.4",
 "unzip": "6.0-9ubuntu1.5",
 "update-manager-core": "1:0.196.14",
@@ -1230,6 +1279,7 @@
 "ureadahead": "0.100.0-16",
 "usbutils": "1:007-2ubuntu1",
 "util-linux": "2.20.1-5.1ubuntu20.7",
+    "uuid-dev": "2.20.1-5.1ubuntu20.7",
 "uuid-runtime": "2.20.1-5.1ubuntu20.7",
 "vim": "2:7.4.052-1ubuntu3",
 "vim-common": "2:7.4.052-1ubuntu3",

Pyenv: pyvenv: command not found
Ubuntu Trusty has no PECL support under PHP7
#2

How do you make this image default and switch all my projects to use it?


#3

These changes look great.

Any chance the qt5 upgrade mentioned on Mar 22 (5.2.1 -> 5.5.1) will make it into this build image?

Thanks again,

  • Mark

#4

Any chance the Postgres 9.5 is installed and default?


#5

Any chance you’ll fix AWS CodeDeploy (see this bug report) with this update?


#6

#7

Do you have a more precise ETA on when this is live? We’re currently waiting for this as we need the android sdk updates. Thanks


#8

The updated image is now live.

To double check you can SSH into a build and run

cat /opt/circleci/image_version

which should return:

trusty-545-a416bf8


#9

cat: /opt/circleci/image_version: No such file or directory

CIRCLE_BUILD_IMAGE=ubuntu-12.04 that’s the old image right?


#10

Your build is using the 12.04 image.

To switch to the 14.04 image, go to Project settings > Build environment.


#11

Ahh, I thought that was automatic :slight_smile: Thanks


#12

You’re welcome. We should definitely make it clearer that 12.04 is default and to use 14.04 requires manual intervention.


#13

I don’t understand one thing - why is it so difficult to actually use PHP (any version, WITH modules) + apache?

I couldn’t understand why phpcli worked properly but apache + php didn’t after debugging for hours.

I finally managed to create a hack which seems to work for php 5.6.17 (or any other version) of PHP, so the modules are enabled.

If you need to save hours (you’re welcome) - use this in circle.yml:

dependencies:
  pre:
    # Install php modules
    - yes | pecl install memcache;
    - echo "extension=memcache.so" > /opt/circleci/php/$(phpenv global)/etc/conf.d/memcache.ini;
    # Enable required Apache2 extensions
    - sudo a2enmod filter;
    - sudo a2enmod headers;
    - sudo a2enmod proxy;
    - sudo a2enmod proxy_http;
    - sudo a2enmod rewrite;
    # Fix the PHP version F###up in Circle CI
    - sudo sh -c "echo 'LoadModule php5_module /opt/circleci/php/$(phpenv global)/usr/lib/apache2/modules/libphp5.so' > /etc/apache2/mods-available/php5.load";

This may even possibly work with custom php versions (I didn’t test since I was so dead tired of playing around with config + committing code + force push to force a build)


#14

@kimh could Circle add support for node 6.3? The huge new feature is natively adding support for debugging via chrome devtools. https://nodejs.org/en/blog/release/v6.3.0/


#15