Ubuntu 14.04 Build Image Update 201608-01

build-image

#1

We will update our Ubuntu 14.04 (Trusty) build image between 3th and 4th Aug.

This update brings only small changes and we don’t expect any impacts on customers builds.

Fixing flaky redis start up

Our customers have experienced that redis sometimes does not start. In this update, we switched to upstart from systemv init to manage redis service to see if update mitigates the issue.

Updating Git to 2.9.2

Git is updated to 2.9.2

All changes

--- versions.json.before	2016-08-01 08:36:59.926119305 +0000
+++ /tmp/circle-artifacts.aN381Gt/versions.json	2016-08-01 08:36:58.738127434 +0000
@@ -1,12 +1,12 @@
 {
   "summary": {
-    "build-image": "trusty-621-53170ea",
+    "build-image": "trusty-645-0f3f4aa",
     "google-chrome": "50.0.2661.102",
     "chromedriver": "2.21.371461",
     "firefox": "46.0.1",
     "mongod": "3.0.7",
     "psql": "9.5.3",
-    "mysqld": "5.7.13",
+    "mysqld": "5.7.14",
     "ruby": {
       "default": "2.2.4p230",
       "all": [
@@ -108,7 +108,7 @@
     },
     "redis": "2.8.4",
     "memcached": "1.4.14",
-    "git": "2.8.3",
+    "git": "2.9.2",
     "gcc": "4.8.4",
     "g++": "4.8.4",
     "cc": "4.8.4",
@@ -129,9 +129,9 @@
     "phantomjs": "2.1.1",
     "docker": "1.9.1",
     "docker-compose": "1.5.2",
-    "heroku-toolbelt": "3.43.4",
-    "gcloud": "115.0.0",
-    "aws-cli": "1.10.42",
+    "heroku-toolbelt": "3.43.9",
+    "gcloud": "119.0.0",
+    "aws-cli": "1.10.51",
     "android": {
       "build-tool": "24.4.1",
       "build-tools": [
@@ -170,10 +170,10 @@
     "alex-3.1.7": "3.1.7-3~trusty",
     "ant": "1.9.3-2build1",
     "ant-optional": "1.9.3-2build1",
-    "apache2": "2.4.7-1ubuntu4.10",
-    "apache2-bin": "2.4.7-1ubuntu4.10",
-    "apache2-data": "2.4.7-1ubuntu4.10",
-    "apache2-dev": "2.4.7-1ubuntu4.10",
+    "apache2": "2.4.7-1ubuntu4.13",
+    "apache2-bin": "2.4.7-1ubuntu4.13",
+    "apache2-data": "2.4.7-1ubuntu4.13",
+    "apache2-dev": "2.4.7-1ubuntu4.13",
     "apparmor": "2.8.95~2430-0ubuntu5.3",
     "apport": "2.14.1-0ubuntu3.19",
     "apport-symptoms": "0.20",
@@ -201,7 +201,7 @@
     "bison": "2:2.7.1.dfsg-1",
     "bridge-utils": "1.5-6ubuntu2",
     "bsdmainutils": "9.0.5ubuntu1",
-    "bsdtar": "3.1.2-7ubuntu2.2",
+    "bsdtar": "3.1.2-7ubuntu2.3",
     "bsdutils": "1:2.20.1-5.1ubuntu20.7",
     "btrfs-tools": "3.12-1ubuntu0.1",
     "build-essential": "11.6ubuntu6",
@@ -279,7 +279,7 @@
     "cron": "3.0pl1-124ubuntu2",
     "cryptsetup": "2:1.6.1-1ubuntu1",
     "cryptsetup-bin": "2:1.6.1-1ubuntu1",
-    "curl": "7.35.0-1ubuntu2.6",
+    "curl": "7.35.0-1ubuntu2.7",
     "daemon": "0.6.4-1",
     "dash": "0.5.7-4ubuntu1",
     "dbus": "1.6.18-0ubuntu4.3",
@@ -305,7 +305,7 @@
     "docker-engine": "1.10.3-0~trusty",
     "dosfstools": "3.0.26-1",
     "dpkg": "1.17.5ubuntu5.5",
-    "dpkg-dev": "1.17.5ubuntu5.6",
+    "dpkg-dev": "1.17.5ubuntu5.7",
     "dpkg-repack": "1.37",
     "e2fslibs:amd64": "1.42.9-3ubuntu1.3",
     "e2fsprogs": "1.42.9-3ubuntu1.3",
@@ -387,8 +387,8 @@
     "gir1.2-gst-plugins-base-1.0": "1.2.4-1~ubuntu2",
     "gir1.2-gstreamer-1.0": "1.2.4-0ubuntu1",
     "gir1.2-rsvg-2.0": "2.40.2-1",
-    "git": "1:2.8.3-0ppa1~ubuntu14.04.1",
-    "git-man": "1:2.8.3-0ppa1~ubuntu14.04.1",
+    "git": "1:2.9.2-0ppa1~ubuntu14.04.1",
+    "git-man": "1:2.9.2-0ppa1~ubuntu14.04.1",
     "gnupg": "1.4.16-1ubuntu2.3",
     "google-chrome-stable": "50.0.2661.102-1",
     "gpgv": "1.4.16-1ubuntu2.3",
@@ -402,8 +402,8 @@
     "gzip": "1.6-3ubuntu1",
     "happy-1.19.5": "1.19.5-2~trusty",
     "hdparm": "9.43-1ubuntu3",
-    "heroku": "3.43.4",
-    "heroku-toolbelt": "3.43.4",
+    "heroku": "3.43.9",
+    "heroku-toolbelt": "3.43.9",
     "hicolor-icon-theme": "0.13-1",
     "hostname": "3.15ubuntu1",
     "htop": "1.0.2-3",
@@ -463,7 +463,7 @@
     "libapt-inst1.5:amd64": "1.0.1ubuntu2.11",
     "libapt-pkg4.12:amd64": "1.0.1ubuntu2.11",
     "libarchive-extract-perl": "0.70-1",
-    "libarchive13:amd64": "3.1.2-7ubuntu2.2",
+    "libarchive13:amd64": "3.1.2-7ubuntu2.3",
     "libarmadillo4": "1:4.200.0+dfsg-1",
     "libarpack2": "3.1.5-2",
     "libasan0:amd64": "4.8.4-2ubuntu1~14.04.3",
@@ -540,9 +540,9 @@
     "libcups2:amd64": "1.7.2-0ubuntu1.7",
     "libcupsfilters1:amd64": "1.0.52-0ubuntu1.7",
     "libcupsimage2:amd64": "1.7.2-0ubuntu1.7",
-    "libcurl3:amd64": "7.35.0-1ubuntu2.6",
+    "libcurl3:amd64": "7.35.0-1ubuntu2.7",
     "libcurl3-gnutls:amd64": "7.35.0-1ubuntu2.6",
-    "libcurl4-openssl-dev:amd64": "7.35.0-1ubuntu2.6",
+    "libcurl4-openssl-dev:amd64": "7.35.0-1ubuntu2.7",
     "libcurses-perl": "1.28-1build3",
     "libcurses-ui-perl": "0.9609-1",
     "libcwidget3": "0.5.16-3.5ubuntu1",
@@ -563,13 +563,13 @@
     "libdjvulibre-text": "3.5.25.4-3",
     "libdjvulibre21:amd64": "3.5.25.4-3",
     "libdns100": "1:9.9.5.dfsg-3ubuntu0.7",
-    "libdpkg-perl": "1.17.5ubuntu5.6",
-    "libdrm-amdgpu1:amd64": "2.4.64-1~ubuntu14.04.1",
-    "libdrm-dev:amd64": "2.4.64-1~ubuntu14.04.1",
-    "libdrm-intel1:amd64": "2.4.64-1~ubuntu14.04.1",
-    "libdrm-nouveau2:amd64": "2.4.64-1~ubuntu14.04.1",
-    "libdrm-radeon1:amd64": "2.4.64-1~ubuntu14.04.1",
-    "libdrm2:amd64": "2.4.64-1~ubuntu14.04.1",
+    "libdpkg-perl": "1.17.5ubuntu5.7",
+    "libdrm-amdgpu1:amd64": "2.4.67-1ubuntu0.14.04.1",
+    "libdrm-dev:amd64": "2.4.67-1ubuntu0.14.04.1",
+    "libdrm-intel1:amd64": "2.4.67-1ubuntu0.14.04.1",
+    "libdrm-nouveau2:amd64": "2.4.67-1ubuntu0.14.04.1",
+    "libdrm-radeon1:amd64": "2.4.67-1ubuntu0.14.04.1",
+    "libdrm2:amd64": "2.4.67-1ubuntu0.14.04.1",
     "libdumbnet1": "1.12-4build1",
     "libedit2:amd64": "3.1-20130712-2",
     "libegl1-mesa:amd64": "10.1.3-0ubuntu0.6",
@@ -616,7 +616,7 @@
     "libgcr-base-3-1:amd64": "3.10.1-1",
     "libgcrypt11:amd64": "1.5.3-2ubuntu4.3",
     "libgcrypt11-dev": "1.5.3-2ubuntu4.3",
-    "libgd3:amd64": "2.1.0-3ubuntu0.1",
+    "libgd3:amd64": "2.1.0-3ubuntu0.2",
     "libgdal1h": "1.10.1+dfsg-5ubuntu1",
     "libgdbm-dev": "1.8.3-12build1",
     "libgdbm3:amd64": "1.8.3-12build1",
@@ -745,8 +745,8 @@
     "liblapack3": "3.5.0-2ubuntu1",
     "liblcms2-2:amd64": "2.5-0ubuntu4.1",
     "liblcms2-dev:amd64": "2.5-0ubuntu4.1",
-    "libldap-2.4-2:amd64": "2.4.31-1+nmu2ubuntu8.2",
-    "libldap2-dev:amd64": "2.4.31-1+nmu2ubuntu8.2",
+    "libldap-2.4-2:amd64": "2.4.31-1+nmu2ubuntu8.3",
+    "libldap2-dev:amd64": "2.4.31-1+nmu2ubuntu8.3",
     "libllvm3.4:amd64": "1:3.4-1ubuntu3",
     "liblocale-gettext-perl": "1.05-7build3",
     "liblockfile-bin": "1.09-6ubuntu1",
@@ -756,7 +756,7 @@
     "liblqr-1-0-dev": "0.4.1-2ubuntu1",
     "libltdl-dev:amd64": "2.4.2-1.7ubuntu1",
     "libltdl7:amd64": "2.4.2-1.7ubuntu1",
-    "liblwgeom-2.2-5": "2.2.2+dfsg-1.pgdg14.04+1",
+    "liblwgeom-2.2-5": "2.2.2+dfsg-4.pgdg14.04+1",
     "liblwres90": "1:9.9.5.dfsg-3ubuntu0.7",
     "liblxc1": "1.0.8-0ubuntu0.3",
     "liblzma-dev:amd64": "5.1.1alpha+20120614-2ubuntu2",
@@ -789,10 +789,10 @@
     "libmpc3:amd64": "1.0.1-1ubuntu1",
     "libmpdec2:amd64": "2.4.0-6",
     "libmpfr4:amd64": "3.1.2-1",
-    "libmysqlclient-dev": "5.7.13-1ubuntu14.04",
-    "libmysqlclient18:amd64": "5.5.49-0ubuntu0.14.04.1",
-    "libmysqlclient20:amd64": "5.7.13-1ubuntu14.04",
-    "libmysqld-dev": "5.7.13-1ubuntu14.04",
+    "libmysqlclient-dev": "5.7.14-1ubuntu14.04",
+    "libmysqlclient18:amd64": "5.5.50-0ubuntu0.14.04.1",
+    "libmysqlclient20:amd64": "5.7.14-1ubuntu14.04",
+    "libmysqld-dev": "5.7.14-1ubuntu14.04",
     "libncurses5:amd64": "5.9+20140118-1ubuntu1",
     "libncurses5-dev:amd64": "5.9+20140118-1ubuntu1",
     "libncursesw5:amd64": "5.9+20140118-1ubuntu1",
@@ -804,9 +804,9 @@
     "libnfnetlink0:amd64": "1.0.1-2",
     "libnih-dbus1:amd64": "1.0.3-4ubuntu25",
     "libnih1:amd64": "1.0.3-4ubuntu25",
-    "libnspr4:amd64": "2:4.10.10-0ubuntu0.14.04.1",
-    "libnss3:amd64": "2:3.21-0ubuntu0.14.04.2",
-    "libnss3-nssdb": "2:3.21-0ubuntu0.14.04.2",
+    "libnspr4:amd64": "2:4.12-0ubuntu0.14.04.1",
+    "libnss3:amd64": "2:3.23-0ubuntu0.14.04.1",
+    "libnss3-nssdb": "2:3.23-0ubuntu0.14.04.1",
     "libnuma1:amd64": "2.0.9~rc5-1ubuntu3.14.04.1",
     "libodbc1:amd64": "2.2.14p2-5ubuntu5",
     "libogdi3.2": "3.2.0~beta2-7ubuntu1",
@@ -1057,7 +1057,7 @@
     "libxdmcp-dev:amd64": "1:1.1.1-1",
     "libxdmcp6:amd64": "1:1.1.1-1",
     "libxdot4": "2.36.0-0ubuntu3.1",
-    "libxerces-c3.1:amd64": "3.1.1-5.1+deb8u2build0.14.04.1",
+    "libxerces-c3.1:amd64": "3.1.1-5.1+deb8u3build0.14.04.1",
     "libxerces2-java": "2.11.0-7",
     "libxext-dev:amd64": "2:1.3.2-1ubuntu0.0.14.04.1",
     "libxext6:amd64": "2:1.3.2-1ubuntu0.0.14.04.1",
@@ -1083,7 +1083,7 @@
     "libxmu6:amd64": "2:1.1.1-1",
     "libxmuu1:amd64": "2:1.1.1-1",
     "libxpm4:amd64": "1:3.5.10-1",
-    "libxrandr2:amd64": "2:1.4.2-1",
+    "libxrandr2:amd64": "2:1.5.0-1~trusty1",
     "libxrender-dev:amd64": "1:0.9.8-1build0.14.04.1",
     "libxrender1:amd64": "1:0.9.8-1build0.14.04.1",
     "libxres1:amd64": "2:1.0.7-1",
@@ -1103,7 +1103,7 @@
     "libxxf86vm1:amd64": "1:1.1.3-1",
     "libyaml-0-2:amd64": "0.1.4-3ubuntu3.1",
     "libyaml-dev:amd64": "0.1.4-3ubuntu3.1",
-    "linux-libc-dev:amd64": "3.13.0-87.133",
+    "linux-libc-dev:amd64": "3.13.0-92.139",
     "lksctp-tools": "1.0.15+dfsg-1",
     "llvm": "1:3.4-0ubuntu1",
     "llvm-3.4": "1:3.4-1ubuntu3",
@@ -1149,10 +1149,11 @@
     "mtr-tiny": "0.85-2",
     "multiarch-support": "2.19-0ubuntu6.7",
     "mysql-apt-config": "0.6.0-1",
-    "mysql-client": "5.7.13-1ubuntu14.04",
-    "mysql-common": "5.7.13-1ubuntu14.04",
-    "mysql-community-client": "5.7.13-1ubuntu14.04",
-    "mysql-community-server": "5.7.13-1ubuntu14.04",
+    "mysql-client": "5.7.14-1ubuntu14.04",
+    "mysql-common": "5.7.14-1ubuntu14.04",
+    "mysql-community-client": "5.7.14-1ubuntu14.04",
+    "mysql-community-server": "5.7.14-1ubuntu14.04",
+    "mysql-server": "5.7.14-1ubuntu14.04",
     "nano": "2.2.6-1ubuntu1",
     "ncurses-base": "5.9+20140118-1ubuntu1",
     "ncurses-bin": "5.9+20140118-1ubuntu1",
@@ -1204,11 +1205,11 @@
     "pollinate": "4.7-0ubuntu1.4",
     "poppler-data": "0.4.6-4",
     "popularity-contest": "1.57ubuntu1",
-    "postgis": "2.2.2+dfsg-1.pgdg14.04+1",
-    "postgis-doc": "2.2.2+dfsg-1.pgdg14.04+1",
+    "postgis": "2.2.2+dfsg-4.pgdg14.04+1",
+    "postgis-doc": "2.2.2+dfsg-4.pgdg14.04+1",
     "postgresql-9.5": "9.5.3-1.pgdg14.04+1",
-    "postgresql-9.5-postgis-2.2": "2.2.2+dfsg-1.pgdg14.04+1",
-    "postgresql-9.5-postgis-scripts": "2.2.2+dfsg-1.pgdg14.04+1",
+    "postgresql-9.5-postgis-2.2": "2.2.2+dfsg-4.pgdg14.04+1",
+    "postgresql-9.5-postgis-2.2-scripts": "2.2.2+dfsg-4.pgdg14.04+1",
     "postgresql-client-9.5": "9.5.3-1.pgdg14.04+1",
     "postgresql-client-common": "175.pgdg14.04+1",
     "postgresql-common": "175.pgdg14.04+1",
@@ -1245,8 +1246,8 @@
     "python-oauth": "1.0.1-3build2",
     "python-openssl": "0.13-2ubuntu6",
     "python-pam": "0.4.2-13.1ubuntu3",
-    "python-pip": "1.5.4-1ubuntu3",
-    "python-pip-whl": "1.5.4-1ubuntu3",
+    "python-pip": "1.5.4-1ubuntu4",
+    "python-pip-whl": "1.5.4-1ubuntu4",
     "python-pkg-resources": "3.3-1ubuntu2",
     "python-prettytable": "0.7.2-2ubuntu2",
     "python-pycurl": "7.19.3-0ubuntu3",
@@ -1289,7 +1290,7 @@
     "python3-update-manager": "1:0.196.14",
     "python3.4": "3.4.3-1ubuntu1~14.04.3",
     "python3.4-minimal": "3.4.3-1ubuntu1~14.04.3",
-    "qemu-utils": "2.0.0+dfsg-2ubuntu1.24",
+    "qemu-utils": "2.0.0+dfsg-2ubuntu1.25",
     "qt5-default:amd64": "5.2.1+dfsg-1ubuntu14.3",
     "qt5-qmake:amd64": "5.2.1+dfsg-1ubuntu14.3",
     "qtbase5-dev:amd64": "5.2.1+dfsg-1ubuntu14.3",
@@ -1346,8 +1347,8 @@
     "tk": "8.6.0+6ubuntu3",
     "tk8.6": "8.6.1-3ubuntu2",
     "tmux": "1.8-5",
-    "tzdata": "2016d-0ubuntu0.14.04",
-    "tzdata-java": "2016d-0ubuntu0.14.04",
+    "tzdata": "2016f-0ubuntu0.14.04",
+    "tzdata-java": "2016f-0ubuntu0.14.04",
     "ubuntu-keyring": "2012.05.19",
     "ubuntu-minimal": "1.325",
     "ubuntu-release-upgrader-core": "1:0.220.8",

#2

#3

Any news here? When can we expect this update to be up and running?


#4

This post described the image update that was release at the beginning of August.

Is there something specific you’re looking for?


#5