Ubuntu 14.04 Build Image Update 201606-02

build-image
php
mysql

#1

We will update our Ubuntu 14.04 (Trusty) build image between 25th and 26h June.

MySQL

Upgrading to 5.7

Many of our customers want to use MySQL 5.7. MySQL 5.7.13 will be installed in this update.

Haskell

Haskell is very unfortunate on Ubuntu 14.04 build image. It’s build environment has been completely missing on the build image. In this update, we will install Haskell build environment that’s similar to the one on Ubuntu 12.04 but with newer versions.

GHC

GHC 8.0.1 will be pre-installed.

Happy

Happy 1.19.5 will be pre-installed.

Alex

Alex 3.1.7 will be pre-installed.

Cabal

Cabal 1.24 will be pre-installed.

Couchdb

Couchdb has been also missing on Ubuntu 14.04 build image. Couchdb 1.6.1 will be installed in this update.

PHP

Adding new version of PHP was canceled in the last image update. We’ll install these versions this time.

Adding PHP 5.5.36

Now PHP 5.5.36 is pre-installed.

Adding PHP 5.6.36

Now PHP 5.5.36 is pre-installed.

Adding PHP 5.6.22

Now PHP 5.6.22 is pre-installed.

Adding PHP 7.0.7

Now PHP 7.0.7 is pre-installed.

All changes

--- versions.json.before	2016-06-23 04:43:49.808602935 +0000
+++ /tmp/circle-artifacts.uCpQioF/versions.json	2016-06-23 04:43:48.788613138 +0000
@@ -1,12 +1,12 @@
 {
   "summary": {
-    "build-image": "trusty-596-97c2e34",
+    "build-image": "trusty-618-2236eb5",
     "google-chrome": "50.0.2661.102",
     "chromedriver": "2.21.371461",
     "firefox": "46.0.1",
     "mongod": "3.0.7",
     "psql": "9.5.3",
-    "mysqld": "5.6.30",
+    "mysqld": "5.7.13",
     "ruby": {
       "default": "2.2.4p230",
       "all": [
@@ -69,10 +69,13 @@
       "all": [
         "5.5.31",
         "5.5.32",
+        "5.5.36",
         "5.6.17",
         "5.6.18",
+        "5.6.22",
         "7.0.3",
-        "7.0.4"
+        "7.0.4",
+        "7.0.7"
       ]
     },
     "java": {
@@ -83,6 +86,26 @@
         "jdk1.8.0"
       ]
     },
+    "clojure": {
+      "lein": "2.5.3"
+    },
+    "haskell": {
+      "all": [
+        "8.0.1"
+      ],
+      "cabal": "1.24.0.0",
+      "alex": "3.1.7",
+      "happy": "1.19.5"
+    },
+    "scala": {
+      "all": [
+        "0.13.5",
+        "0.13.6",
+        "0.13.7",
+        "0.13.8",
+        "0.13.9"
+      ]
+    },
     "redis": "2.8.4",
     "memcached": "1.4.14",
     "git": "2.8.3",
@@ -91,7 +114,6 @@
     "cc": "4.8.4",
     "c++": "4.8.4",
     "make": "3.81",
-    "lein": "2.5.3",
     "maven": "3.2.5",
     "ant": "1.9.3",
     "apache2": "2.4.7",
@@ -100,6 +122,7 @@
     "elasticsearch": "1.7.2",
     "neo4j": "2.3.3,4623254",
     "riak": "2.1.3",
+    "couchdb": "1.6.1",
     "geos": "3.5.0",
     "go": "1.6.2",
     "gradle": "1.10",
@@ -107,8 +130,8 @@
     "docker": "1.9.1",
     "docker-compose": "1.5.2",
     "heroku-toolbelt": "3.43.3",
-    "gcloud": "112.0.0",
-    "aws-cli": "1.10.35",
+    "gcloud": "115.0.0",
+    "aws-cli": "1.10.40",
     "android": {
       "build-tool": "24.4.1",
       "build-tools": [
@@ -144,6 +167,7 @@
     "acl": "2.2.52-1",
     "acpid": "1:2.0.21-1ubuntu2",
     "adduser": "3.113+nmu3ubuntu3",
+    "alex-3.1.7": "3.1.7-3~trusty",
     "ant": "1.9.3-2build1",
     "ant-optional": "1.9.3-2build1",
     "apache2": "2.4.7-1ubuntu4.9",
@@ -187,6 +211,7 @@
     "bzip2": "1.0.6-5",
     "ca-certificates": "20160104ubuntu0.14.04.1",
     "ca-certificates-java": "20130815ubuntu1",
+    "cabal-install-1.24": "1.24+git20160621.1.30549fe~trusty",
     "cassandra": "3.4",
     "cgmanager": "0.24-0ubuntu7.5",
     "cgroup-lite": "1.9",
@@ -206,10 +231,13 @@
     "circleci-nodejs-6.1.0": "1",
     "circleci-php-5.5.31": "5",
     "circleci-php-5.5.32": "5",
+    "circleci-php-5.5.36": "5",
     "circleci-php-5.6.17": "5",
     "circleci-php-5.6.18": "5",
+    "circleci-php-5.6.22": "5",
     "circleci-php-7.0.3": "5",
     "circleci-php-7.0.4": "5",
+    "circleci-php-7.0.7": "5",
     "circleci-python-2.7.10": "1",
     "circleci-python-2.7.11": "1",
     "circleci-python-3.1.4": "1",
@@ -242,6 +270,9 @@
     "command-not-found-data": "0.3ubuntu12",
     "console-setup": "1.70ubuntu8",
     "coreutils": "8.21-1ubuntu5.3",
+    "couchdb": "1.6.1-0ubuntu5",
+    "couchdb-bin": "1.6.1-0ubuntu5",
+    "couchdb-common": "1.6.1-0ubuntu5",
     "cpio": "2.11+dfsg-1ubuntu1.2",
     "cpp": "4:4.8.2-1ubuntu6",
     "cpp-4.8": "4.8.4-2ubuntu1~14.04.3",
@@ -348,6 +379,7 @@
     "gettext-base": "0.18.3.1-1ubuntu3",
     "gfortran": "4:4.8.2-1ubuntu6",
     "gfortran-4.8": "4.8.4-2ubuntu1~14.04.3",
+    "ghc-8.0.1": "8.0.1-10~trusty",
     "ghostscript": "9.10~dfsg-0ubuntu10.4",
     "gir1.2-freedesktop": "1.40.0-1ubuntu0.2",
     "gir1.2-gdkpixbuf-2.0": "2.30.7-0ubuntu1.2",
@@ -368,6 +400,7 @@
     "gvfs-daemons": "1.20.3-0ubuntu1.2",
     "gvfs-libs:amd64": "1.20.3-0ubuntu1.2",
     "gzip": "1.6-3ubuntu1",
+    "happy-1.19.5": "1.19.5-2~trusty",
     "hdparm": "9.43-1ubuntu3",
     "heroku": "3.43.3",
     "heroku-toolbelt": "3.43.3",
@@ -517,8 +550,6 @@
     "libdapclient3:amd64": "3.12.0-1",
     "libdatrie1:amd64": "0.2.8-1",
     "libdb5.3:amd64": "5.3.28-3ubuntu3",
-    "libdbd-mysql-perl": "4.025-1",
-    "libdbi-perl": "1.630-1",
     "libdbus-1-3:amd64": "1.6.18-0ubuntu4.3",
     "libdbus-glib-1-2:amd64": "0.100.2-1",
     "libdbusmenu-glib4:amd64": "12.10.3+14.04.20140612-0ubuntu1",
@@ -553,8 +584,8 @@
     "libevent-2.0-5:amd64": "2.0.21-stable-1ubuntu1.14.04.1",
     "libexif-dev": "0.6.21-1ubuntu1",
     "libexif12:amd64": "0.6.21-1ubuntu1",
-    "libexpat1:amd64": "2.1.0-4ubuntu1.2",
-    "libexpat1-dev:amd64": "2.1.0-4ubuntu1.2",
+    "libexpat1:amd64": "2.1.0-4ubuntu1.3",
+    "libexpat1-dev:amd64": "2.1.0-4ubuntu1.3",
     "libfakeroot:amd64": "1.20-3ubuntu2",
     "libffi-dev:amd64": "3.1~rc1+r3.0.13-12ubuntu0.1",
     "libffi6:amd64": "3.1~rc1+r3.0.13-12ubuntu0.1",
@@ -662,7 +693,6 @@
     "libhdf5-7:amd64": "1.8.11-5ubuntu7",
     "libheimbase1-heimdal:amd64": "1.6~git20131207+dfsg-1ubuntu1.1",
     "libheimntlm0-heimdal:amd64": "1.6~git20131207+dfsg-1ubuntu1.1",
-    "libhtml-template-perl": "2.95-1",
     "libhx509-5-heimdal:amd64": "1.6~git20131207+dfsg-1ubuntu1.1",
     "libice-dev:amd64": "2:1.0.8-2",
     "libice6:amd64": "2:1.0.8-2",
@@ -743,6 +773,7 @@
     "libmail-sendmail-perl": "0.79.16-1",
     "libmcrypt-dev": "2.5.8-3.1ubuntu1",
     "libmcrypt4": "2.5.8-3.1ubuntu1",
+    "libmecab2": "0.996-1.1",
     "libmemcache-dev": "1.4.0.rc2-1ubuntu1",
     "libmemcache0": "1.4.0.rc2-1ubuntu1",
     "libmirclient-dev:amd64": "0.1.8+14.04.20140411-0ubuntu1",
@@ -753,13 +784,15 @@
     "libmnl0:amd64": "1.0.3-3ubuntu1",
     "libmodule-pluggable-perl": "5.1-1",
     "libmount1:amd64": "2.20.1-5.1ubuntu20.7",
+    "libmozjs185-1.0": "1.8.5-1.0.0+dfsg-4ubuntu1",
     "libmp3lame0:amd64": "3.99.5+repack1-3ubuntu1",
     "libmpc3:amd64": "1.0.1-1ubuntu1",
     "libmpdec2:amd64": "2.4.0-6",
     "libmpfr4:amd64": "3.1.2-1",
-    "libmysqlclient-dev": "5.5.49-0ubuntu0.14.04.1",
+    "libmysqlclient-dev": "5.7.13-1ubuntu14.04",
     "libmysqlclient18:amd64": "5.5.49-0ubuntu0.14.04.1",
-    "libmysqld-dev": "5.5.49-0ubuntu0.14.04.1",
+    "libmysqlclient20:amd64": "5.7.13-1ubuntu14.04",
+    "libmysqld-dev": "5.7.13-1ubuntu14.04",
     "libncurses5:amd64": "5.9+20140118-1ubuntu1",
     "libncurses5-dev:amd64": "5.9+20140118-1ubuntu1",
     "libncursesw5:amd64": "5.9+20140118-1ubuntu1",
@@ -1045,8 +1078,8 @@
     "libxkbfile1:amd64": "1:1.0.8-1",
     "libxml-commons-external-java": "1.4.01-2build1",
     "libxml-commons-resolver1.1-java": "1.2-7build1",
-    "libxml2:amd64": "2.9.1+dfsg1-3ubuntu4.7",
-    "libxml2-dev:amd64": "2.9.1+dfsg1-3ubuntu4.7",
+    "libxml2:amd64": "2.9.1+dfsg1-3ubuntu4.8",
+    "libxml2-dev:amd64": "2.9.1+dfsg1-3ubuntu4.8",
     "libxmu6:amd64": "2:1.1.1-1",
     "libxmuu1:amd64": "2:1.1.1-1",
     "libxpm4:amd64": "1:3.5.10-1",
@@ -1115,12 +1148,11 @@
     "mountall": "2.53",
     "mtr-tiny": "0.85-2",
     "multiarch-support": "2.19-0ubuntu6.7",
-    "mysql-client-5.6": "5.6.30-0ubuntu0.14.04.1",
-    "mysql-client-core-5.6": "5.6.30-0ubuntu0.14.04.1",
-    "mysql-common": "5.5.49-0ubuntu0.14.04.1",
-    "mysql-common-5.6": "5.6.30-0ubuntu0.14.04.1",
-    "mysql-server-5.6": "5.6.30-0ubuntu0.14.04.1",
-    "mysql-server-core-5.6": "5.6.30-0ubuntu0.14.04.1",
+    "mysql-apt-config": "0.6.0-1",
+    "mysql-client": "5.7.13-1ubuntu14.04",
+    "mysql-common": "5.7.13-1ubuntu14.04",
+    "mysql-community-client": "5.7.13-1ubuntu14.04",
+    "mysql-community-server": "5.7.13-1ubuntu14.04",
     "nano": "2.2.6-1ubuntu1",
     "ncurses-base": "5.9+20140118-1ubuntu1",
     "ncurses-bin": "5.9+20140118-1ubuntu1",
@@ -1341,7 +1373,7 @@
     "vim-tiny": "2:7.4.052-1ubuntu3",
     "vnc4server": "4.1.1+xorg4.3.0-37ubuntu5.0.2",
     "w3m": "0.5.3-15",
-    "wget": "1.15-1ubuntu1.14.04.1",
+    "wget": "1.15-1ubuntu1.14.04.2",
     "whiptail": "0.52.15-2ubuntu5",
     "x11-apps": "7.7+2",
     "x11-common": "1:7.7+1ubuntu8.1",
@@ -1376,7 +1408,6 @@
     "xserver-common": "2:1.15.1-0ubuntu2.7",
     "xterm": "297-1ubuntu1",
     "xtrans-dev": "1.3.5-1~ubuntu14.04.1",
-    "xul-ext-ubufox": "3.2-0ubuntu0.14.04.1",
     "xvfb": "2:1.15.1-0ubuntu2.7",
     "xz-utils": "5.1.1alpha+20120614-2ubuntu2",
     "zerofree": "1.0.2-1ubuntu1",

#2

I am concerned that this appears to update firefox to 47. This version currently does not work with selenium and would therefore break our tests. See https://github.com/SeleniumHQ/selenium/issues/2110. Anyone else have this concern? I don’t think selenium/firefox have this worked out yet and would propose dropping this upgrade.


#3

@micheletest sorry, updating firefox wasn’t my intention and I was just working to pin the firefox version to 46, so it should be fine.


#4

Nice catch! Thanks so much :slight_smile:


#5

Thanks for the updates.

Any insight into when Qt5 will be upgraded, as discussed previously?


#6

We’re rolling this back for now because of an issue with the MySQL setup, causing errors like “Access denied for user ‘root’@‘localhost’”. We’ll follow up once we fix it and redeploy the new image.


#7

#8

An update that fixes the MySQL issues has now been rolled out.

MySQL 5.7 is the preinstalled version on 14.04 and builds should now run without modification unless you are using database features affected by breaking changes in the MySQL 5.7 release.


#9

@tom What is the solution for using MySQL 5.6? What do we need to add to our circle.yml to make this work again???


#11

To use MySQL 5.6 on the 14.04 image, please follow the steps here:


#12

@tom
thanks for the steps. A couple of things:
1)
I got an issue when running those:

+ sudo apt-add-repository -y 'deb http://ppa.launchpad.net/ondrej/mysql/experimental/ubuntu precise main'
+ sudo apt-get update


Hit http://repo.mysql.com trusty InRelease

Get:1 http://security.ubuntu.com trusty-security InRelease [65.9 kB]

(...)

Get:22 http://archive.ubuntu.com trusty-updates/main amd64 Packages [991 kB]

Hit http://ppa.launchpad.net trusty/main amd64 Packages

Err http://ppa.launchpad.net precise/main amd64 Packages
  

Hit https://packagecloud.io trusty InRelease

Err http://ppa.launchpad.net precise/main amd64 Packages
  

Get:23 http://archive.ubuntu.com trusty-updates/restricted amd64 Packages [23.5 kB]

Err http://ppa.launchpad.net precise/main amd64 Packages
  

Hit https://packagecloud.io trusty/main Sources

Get:24 http://archive.ubuntu.com trusty-updates/universe amd64 Packages [469 kB]

Err http://ppa.launchpad.net precise/main amd64 Packages
  404  Not Found

(...)

Fetched 13.0 MB in 5s (2,483 kB/s)
W: Failed to fetch http://ppa.launchpad.net/ondrej/mysql/experimental/ubuntu/dists/precise/main/binary-amd64/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
+ sudo DEBIAN_FRONTEND=noninteractive apt-get install -y mysql-server-5.6
(...)

It took 37 seconds to get to that point only

Compare with:

dependencies:
  pre:
    - sudo service mysql stop  # takes 4 seconds
    - docker run -d --name mysql -p 3306:3306 -e MYSQL_ROOT_PASSWORD=root mysql:5.6  # takes 20 seconds
    - until nc -z 127.0.0.1 3306; do sleep 1; echo "Waiting for test DB to come up..."; done  # about 10 seconds

Note: you should then access the database via 127.0.0.1:3306, not localhost:3306


#13

Hi lizzie.

It’s been a while since the last update on… Ubuntu image update. Any news? When can we expect the build image update?


#14

Yup, it would be so cool to finally get this update up an running :confused:


#15

The update described in this post was released in June.

Is there something specific that you’re looking for?


#16

When it comes to me: yeah.

I checked the history and the interesting part for me is a modern version of Qt5. The upgrade was mentioned here, in March: Another Ubuntu 14.04 (Trusty) Update

And the current topic is most recent topic concerning Ubuntu image updates, so I decided to ask about “news” here :slight_smile:


#17

We have an open ticket to get Qt5 rolled out. There are still a few issues that we need to address to make sure the update doesn’t introduce regressions for customers testing with older versions.

It should be available in the next image update which is coming soon. Please subscribe to our Announcements to be notified when it’s available.


#18