Ubuntu 14.04 Build Image Update 201606-01

build-image

#1

We will update our Ubuntu 14.04 (Trusty) build image between 13th and 14th June.

This update is mainly for upgrading PostgreSQL to 9.5.

PostgreSQL

Upgrading to 9.5

We have been running both 9.4 and 9.5 of PostgreSQL on the Trusty build image, but running two versions are not our intention and 9.5 has been installed by mistake as a part of postgis dependency.

We like to fix this issue but it seems many of our customers want 9.5 rather than 9.4, so we’ll be only installing 9.5 and remove 9.4 from the build image.

Please be noted that if you are manually activating 9.5 then this update will break your builds because 9.4 won’t be available anymore. In case this happens, you just need to remove the code from circle.yml.

Upgrade PostGIS to 2.2

We will be updating PostGIS to 2.2 from 2.1.

Editted on 14th

We have some issues to ship the PHP versions in this update. We’ll do another release as soon as we sort out the issue.

PHP

We are pre-installing the following versions to the build image.

Adding PHP 5.5.36

Now PHP 5.5.36 is pre-installed.

Adding PHP 5.6.36

Now PHP 5.5.36 is pre-installed.

Adding PHP 5.6.22

Now PHP 5.6.22 is pre-installed.

Adding PHP 7.0.7

Now PHP 7.0.7 is pre-installed.

All changes

--- versions.json.before	2016-06-06 02:39:02.546699594 +0000
+++ /tmp/circle-artifacts.xwhSOcy/versions.json	2016-06-06 02:39:01.246688761 +0000
@@ -1,11 +1,11 @@
 {
   "summary": {
-    "build-image": "trusty-575-884bd0f",
+    "build-image": "trusty-596-97c2e34",
     "google-chrome": "50.0.2661.102",
     "chromedriver": "2.21.371461",
     "firefox": "46.0.1",
     "mongod": "3.0.7",
-    "psql": "9.4.8",
+    "psql": "9.5.3",
     "mysqld": "5.6.30",
     "ruby": {
       "default": "2.2.4p230",
@@ -19,7 +19,7 @@
       ],
       "gem": "2.4.5.1",
       "rvm": "1.27.0 (master)",
-      "bundler": "1.12.4"
+      "bundler": "1.12.5"
     },
     "python": {
       "default": "2.7.11",
@@ -106,9 +106,9 @@
     "phantomjs": "2.1.1",
     "docker": "1.9.1",
     "docker-compose": "1.5.2",
-    "heroku-toolbelt": "3.43.2",
-    "gcloud": "110.0.0",
-    "aws-cli": "1.10.32",
+    "heroku-toolbelt": "3.43.3",
+    "gcloud": "112.0.0",
+    "aws-cli": "1.10.35",
     "android": {
       "build-tool": "24.4.1",
       "build-tools": [
@@ -154,7 +154,7 @@
     "apport": "2.14.1-0ubuntu3.19",
     "apport-symptoms": "0.20",
     "apt": "1.0.1ubuntu2.11",
-    "apt-transport-https": "1.0.1ubuntu2.13",
+    "apt-transport-https": "1.0.1ubuntu2.14",
     "apt-utils": "1.0.1ubuntu2.11",
     "apt-xapian-index": "0.45ubuntu4",
     "aptitude": "0.6.8.2-1ubuntu4",
@@ -275,6 +275,7 @@
     "dosfstools": "3.0.26-1",
     "dpkg": "1.17.5ubuntu5.5",
     "dpkg-dev": "1.17.5ubuntu5.6",
+    "dpkg-repack": "1.37",
     "e2fslibs:amd64": "1.42.9-3ubuntu1.3",
     "e2fsprogs": "1.42.9-3ubuntu1.3",
     "eatmydata": "26-2",
@@ -368,15 +369,15 @@
     "gvfs-libs:amd64": "1.20.3-0ubuntu1.2",
     "gzip": "1.6-3ubuntu1",
     "hdparm": "9.43-1ubuntu3",
-    "heroku": "3.43.2",
-    "heroku-toolbelt": "3.43.2",
+    "heroku": "3.43.3",
+    "heroku-toolbelt": "3.43.3",
     "hicolor-icon-theme": "0.13-1",
     "hostname": "3.15ubuntu1",
     "htop": "1.0.2-3",
     "icu-devtools": "52.1-3ubuntu0.4",
     "ifupdown": "0.7.47.2ubuntu4.3",
-    "imagemagick": "8:6.7.7.10-6ubuntu3",
-    "imagemagick-common": "8:6.7.7.10-6ubuntu3",
+    "imagemagick": "8:6.7.7.10-6ubuntu3.1",
+    "imagemagick-common": "8:6.7.7.10-6ubuntu3.1",
     "indicator-application": "12.10.1+14.04.20140407-0ubuntu1",
     "info": "5.2.0.dfsg.1-2",
     "init-system-helpers": "1.14",
@@ -415,7 +416,7 @@
     "libalgorithm-diff-perl": "1.19.02-3",
     "libalgorithm-diff-xs-perl": "0.04-2build4",
     "libalgorithm-merge-perl": "0.08-2",
-    "libapache2-mod-php5": "5.5.9+dfsg-1ubuntu4.16",
+    "libapache2-mod-php5": "5.5.9+dfsg-1ubuntu4.17",
     "libapparmor-perl": "2.8.95~2430-0ubuntu5.3",
     "libapparmor1:amd64": "2.8.95~2430-0ubuntu5.3",
     "libappindicator1": "12.10.1+13.10.20130920-0ubuntu4.1",
@@ -475,11 +476,11 @@
     "libbz2-1.0:amd64": "1.0.6-5",
     "libbz2-dev:amd64": "1.0.6-5",
     "libc-bin": "2.19-0ubuntu6.7",
-    "libc-dev-bin": "2.19-0ubuntu6.7",
-    "libc6:amd64": "2.19-0ubuntu6.7",
-    "libc6-dbg:amd64": "2.19-0ubuntu6.7",
-    "libc6-dev:amd64": "2.19-0ubuntu6.7",
-    "libc6-i386": "2.19-0ubuntu6.7",
+    "libc-dev-bin": "2.19-0ubuntu6.9",
+    "libc6:amd64": "2.19-0ubuntu6.9",
+    "libc6-dbg:amd64": "2.19-0ubuntu6.9",
+    "libc6-dev:amd64": "2.19-0ubuntu6.9",
+    "libc6-i386": "2.19-0ubuntu6.9",
     "libcaca0:amd64": "0.99.beta18-1ubuntu5",
     "libcairo-gobject2:amd64": "1.13.0~20140204-0ubuntu1.1",
     "libcairo-script-interpreter2:amd64": "1.13.0~20140204-0ubuntu1.1",
@@ -584,7 +585,7 @@
     "libgcr-base-3-1:amd64": "3.10.1-1",
     "libgcrypt11:amd64": "1.5.3-2ubuntu4.3",
     "libgcrypt11-dev": "1.5.3-2ubuntu4.3",
-    "libgd3:amd64": "2.1.0-3",
+    "libgd3:amd64": "2.1.0-3ubuntu0.1",
     "libgdal1h": "1.10.1+dfsg-5ubuntu1",
     "libgdbm-dev": "1.8.3-12build1",
     "libgdbm3:amd64": "1.8.3-12build1",
@@ -725,7 +726,6 @@
     "liblqr-1-0-dev": "0.4.1-2ubuntu1",
     "libltdl-dev:amd64": "2.4.2-1.7ubuntu1",
     "libltdl7:amd64": "2.4.2-1.7ubuntu1",
-    "liblwgeom-2.1.8": "2.1.8+dfsg-5~97.git43a09cc.pgdg14.04+1",
     "liblwgeom-2.2-5": "2.2.2+dfsg-1.pgdg14.04+1",
     "liblwres90": "1:9.9.5.dfsg-3ubuntu0.7",
     "liblxc1": "1.0.8-0ubuntu0.3",
@@ -735,11 +735,11 @@
     "libm17n-0": "1.6.4-2ubuntu1",
     "libmagic-dev:amd64": "1:5.14-2ubuntu3.3",
     "libmagic1:amd64": "1:5.14-2ubuntu3.3",
-    "libmagickcore-dev": "8:6.7.7.10-6ubuntu3",
-    "libmagickcore5:amd64": "8:6.7.7.10-6ubuntu3",
-    "libmagickcore5-extra:amd64": "8:6.7.7.10-6ubuntu3",
-    "libmagickwand-dev": "8:6.7.7.10-6ubuntu3",
-    "libmagickwand5:amd64": "8:6.7.7.10-6ubuntu3",
+    "libmagickcore-dev": "8:6.7.7.10-6ubuntu3.1",
+    "libmagickcore5:amd64": "8:6.7.7.10-6ubuntu3.1",
+    "libmagickcore5-extra:amd64": "8:6.7.7.10-6ubuntu3.1",
+    "libmagickwand-dev": "8:6.7.7.10-6ubuntu3.1",
+    "libmagickwand5:amd64": "8:6.7.7.10-6ubuntu3.1",
     "libmail-sendmail-perl": "0.79.16-1",
     "libmcrypt-dev": "2.5.8-3.1ubuntu1",
     "libmcrypt4": "2.5.8-3.1ubuntu1",
@@ -1070,7 +1070,7 @@
     "libxxf86vm1:amd64": "1:1.1.3-1",
     "libyaml-0-2:amd64": "0.1.4-3ubuntu3.1",
     "libyaml-dev:amd64": "0.1.4-3ubuntu3.1",
-    "linux-libc-dev:amd64": "3.13.0-86.131",
+    "linux-libc-dev:amd64": "3.13.0-87.133",
     "lksctp-tools": "1.0.15+dfsg-1",
     "llvm": "1:3.4-0ubuntu1",
     "llvm-3.4": "1:3.4-1ubuntu3",
@@ -1159,10 +1159,10 @@
     "perl-base": "5.18.2-2ubuntu1",
     "perl-modules": "5.18.2-2ubuntu1",
     "pgdg-keyring": "2014.1",
-    "php5-cli": "5.5.9+dfsg-1ubuntu4.16",
-    "php5-common": "5.5.9+dfsg-1ubuntu4.16",
+    "php5-cli": "5.5.9+dfsg-1ubuntu4.17",
+    "php5-common": "5.5.9+dfsg-1ubuntu4.17",
     "php5-json": "1.3.2-2build1",
-    "php5-readline": "5.5.9+dfsg-1ubuntu4.16",
+    "php5-readline": "5.5.9+dfsg-1ubuntu4.17",
     "pkg-config": "0.26-1ubuntu4",
     "plymouth": "0.8.8-0ubuntu17.1",
     "plymouth-theme-ubuntu-text": "0.8.8-0ubuntu17.1",
@@ -1174,18 +1174,12 @@
     "popularity-contest": "1.57ubuntu1",
     "postgis": "2.2.2+dfsg-1.pgdg14.04+1",
     "postgis-doc": "2.2.2+dfsg-1.pgdg14.04+1",
-    "postgresql-9.4": "9.4.8-1.pgdg14.04+1",
-    "postgresql-9.4-postgis-2.1": "2.1.8+dfsg-5~97.git43a09cc.pgdg14.04+1",
-    "postgresql-9.4-postgis-2.2": "2.2.2+dfsg-1.pgdg14.04+1",
-    "postgresql-9.4-postgis-scripts": "2.2.2+dfsg-1.pgdg14.04+1",
     "postgresql-9.5": "9.5.3-1.pgdg14.04+1",
     "postgresql-9.5-postgis-2.2": "2.2.2+dfsg-1.pgdg14.04+1",
     "postgresql-9.5-postgis-scripts": "2.2.2+dfsg-1.pgdg14.04+1",
-    "postgresql-client-9.4": "9.4.8-1.pgdg14.04+1",
     "postgresql-client-9.5": "9.5.3-1.pgdg14.04+1",
     "postgresql-client-common": "174.pgdg14.04+1",
     "postgresql-common": "174.pgdg14.04+1",
-    "postgresql-contrib-9.4": "9.4.8-1.pgdg14.04+1",
     "postgresql-contrib-9.5": "9.5.3-1.pgdg14.04+1",
     "powermgmt-base": "1.31build1",
     "ppp": "2.4.5-5.1ubuntu2.2",

#2

Is there any hope that in the future, you will start versioning your containers, and allow users to choose which version of the container each project uses?


Ubuntu 14.04 Build Image Update 201610-01 Released
#3

@jelder no immediate plans but you should make this into a feature request.


#4

I have made the feature request, please see Feature: Container Versioning. Future readers, if you want this feature, please visit the feature request and up vote (or is that ‘heart’) it.


#5

Would be great to get some automated notifications to people using things that might break as a result of this type of change so we’re at least aware of why our builds just start failing. After some looking around I found that Postgres 9.4 was removed. To get to that conclusion I searched around for an article, I messaged you on twitter and after finding it out via SSH debug I received this link via twitter. Would be awesome to not have to go through so many steps.

Edit: I now see I can “Follow” the Announcements discussion board. So that’s cool, I’ll be using that to avoid this issue in the future.

Anyways, its fixed now and very happy to have Postgres 9.5 as the default! We (as you imply here) had to rejigger our config to make that work: https://gist.github.com/jphenow/4c8f02a502e464a87a59164d14cc87c8


#6

#7