Status, Jobs, Workflow for public repository not visible

I have a public repository at with builds at

Unlike my other projects, I am not able to view my build status, jobs, or workflows for this repository when I am not logged in (e.g., in a private browsing window).

I believe the repository configuration got into a bad state because I followed the repository to trigger the first build instead of going to Add Projects -> Setup Project -> Start Building.

It would be great if I could get my repository made visible to I can link to my builds.

If you go into the advanced project settings, do you have “Free and Open Source” turned on?

I do not see this setting anywhere. THe only advanced settings I see are under Build Settings. In those settings there are:

  • GitHub Status updates
  • Buid forked pull requests
  • Pass secrets to build from forked pull requests
  • Only build pull requests
  • Auto-cancel redundant builds
  • Enable build processing (preview)

For the record, this setting is available on for my other projects.

1 Like

That is very strange. Thank for the additional info, this definitely feels like bug.

Could you try to unfollow/refollow this project?

Unfollowing and re-following had no effect.

Thanks for giving it a try. Let me see if I can do some more debugging.

I tried modifying the payload that the page sends (through Firefox’s devtools request editor) to send {"feature_flags": {"oss": true}} (which is what my other projects send what that button gets toggled) but I get an HTTP 504.

This works for other settings on the page, just not the oss flag.

Is there some way I can open a support ticket to get this addressed?

Hi Brennie,

It looks like is available to me when I look in a private browsing window. I believe @levlaz fixed this and forgot to respond.

If you are still seeing issues, please open a ticket here and we can dig deeper into why this is not working for you.

I’m having a very similar issue :frowning:

For my forked project, when not logged in I can see individual jobs (e.g. but when trying to access the workflow (e.g. I get: ‘Login required’.

Is there any way to make workflow results publicly visible for F/OSS projects?

@pjoe You have a separate issue in the sense that you can see all pages by Workflows.

This is related to how we do permissions checks differently We aren’t treating this as a bug (since this page always worked this way) but we have created a Feature Request to gauge prioritization of the work needed to allow non-signed in user to access that page.

I’m going to close this thread since the original bug was resolved.

Edit: The request isn’t public right now but we will link your ticket to it.