Ruby 2.3.6 no longer supported in ruby:2.3-node-browsers Image


#1

The circleci/ruby:2.3-node-browsers image had by default ruby 2.3.6 installed. However, a recent update to this image, upgraded the ruby version to 2.3.7. Our deployment scheme requires the version to be strictly tied into 2.3.6 at the moment, however, this recent update to this image poses a problem to us.

An attempt to update this directly from the config.yml by installing rbenv and ruby2.3.6 fails. Errors with ruby 2.3.6 is specified in Gemfile, but current version of ruby is 2.3.7

Any help is appreciated. Thanks!


#2

There is a 2.3.6 specific image: circleci/ruby:2.3.6-node-browsers


#3

There isn’t. Same is true for 2.5.0 now that 2.5.1 got released. It would be great if older tags would be kept around, instead of removing them as soon as a new patch is released…


#4

As far as I know, all image development is done on GitHub. So as a workaround @jdno, you could fork the relevant repo, wind back to the point where the version tag is exposed, build this image, and then pull it in from your own registry.


#5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.