Can't see my repositories `An error occurred while fetching your repositories. Please refresh to try again.`

I notice a 401 error in the networks tab

I refreshed permissions but still nothing is working any ideas?

Request URL: https://circleci.com/api/v1.1/user/repos/bitbucket
Request Method: GET
Status Code: 401 Unauthorized

2 Likes

Same here. Does anyone have any idea how to fix it?

1 Like

Hi @karim, and @cb-ankit-gupta

Welcome to the CircleCI community!

I suspect the OAuth token we use to connect to the VCS on your behalf is outdated.

You might want to perform a full re-authentication, so a new token is generated.

Note that if you have both a Bitbucket identity and GitHub one linked under the same CircleCI account. you’ll need to perform the full re-authentication for both. Once you’re able to log back in with one of your VCS identity (and confirm you have access to the appropriate repositories, you can re-link the second identity.

Let me know if the above helps.

Hi Yann,

I did perform a full re-authentication. However, It does not seem to work and the problem still exists.

2 Likes

Hi @yannCI,

I have the same problem. Repeating steps to do full re-authentication didn’t help. I’m not able to setup build for a new project because of that.

1 Like

Hi @cb-ankit-gupta and @vsapronov,

Do you have both a GitHub and a Bitbucket identity associated with your CircleCI account?

On your User Settings page, do you see a Connect blue button, in either the GitHub or Bitbucket section?

Experiencing the same issue.
Has anybody resolved it? And how?

Hi CircleCI team and @yannCI

I have the same problem and can’t add a new project.

I’ve associated it with Bitbucket some time ago, but now it’s already revoke.
I tried the following steps, but I couldn’t solve it.

  1. Revoke CircleCI access on GitHub
  2. Log in again using your GitHub account

It may not be possible to completely revoke the association with Bitbucket.

Thank you.

Best

Hi CircleCI team and @yannCI

The older CircleCI dashboard still had Bitbucket authentication settings.
↓
https://circleci.com/dashboard

My username on GitHub also seems to be in the past.

If I could revoke this completely, maybe I could solve the problem.

However, I don’t know how to revoke this.

Does anyone know how to do it?

@yannCI

Supplement:

I also referred to the discussion below.
I have already confirmed that authentication is revoke in Bitbucket.

Hi @hiroki-hasegawa,

I have manually removed the connection between your Bitbucket account and CircleCI identity.
Could you try logging in again and re-linking them? In general:

  1. Clear browser cache
  2. Log in to Github account
  3. Log in to Bitbucket account
  4. Authenticate CircleCI via Github account
  5. Link Bitbucket account on user settings page

If the issue is persisting, I think it would be better to handle this via a support ticket:
https://support.circleci.com/hc/en-us/requests/new

Please let us know if you have any additional questions as well.

Hi @aaronclark ,

I have manually removed the connection between your Bitbucket account and CircleCI identity.

Thank you very much!

When I logged in again, 401 error caused by Bitbucket was resolved.

I can now set up a new circleci project.

Thanks to you, I can enjoy CircleCI again!

2 Likes

Hi - I am evaluating circle-ci at the moment, and seem to have the same error when i removed access to my bitbucket repos. I now cannot see any of my github repos, and i just see an error message…

I tried the full re-authentication as per above, nuked the browser cache and was able to re-connect my github account, but no joy… Please can someone assist.

I can also see this in the console, which is incorrect as the integration was removed…?
GET https://circleci.com/api/v1.1/user/repos/bitbucket net::ERR_FAILED 500

Hi any ideas on this ? I think the bitbucket connection needs manually removing as per @hiroki-hasegawa. My evaluation time is running out so would appreciate if someone could have a look for me. thx

Hi, @javajenks

I am so sorry I did not notice the mentions from you. :cold_sweat:

It seems you are having the same problem as me.

I mentions to CircleCI’s engineering team and they solved this for me.
↓

There may be no way for CircleCI’s users to solve this.

The only way may be to ask the engineering team.