Cannot reconnect BitBucket account

I followed the instructions at CircleCI security alert: Rotate any secrets stored in CircleCI to disconnect Bitbucket. Now I wish I hadn’t.

I was able to reauthenticate with GitHub, but cannot see my Bitbucket projects. That’s because, after revoking app permissions in Bitbucket, CircleCI still shows Bitbucket under account integrations.

There is no way to remove it from this page. I’ve searched the forums and it looks like this cannot be solved by the user (which is sort of not really a good user experience).

When I open CircleCI, it asks me to select an organization:


My Bitbucket organization does not appear.

Selecting GitHub takes me to Projects, which displays the following:

Refreshing and clearing cache does nothing.

Ironically, if I do a hard refresh, I see my projects for just a second before the above error appears. Dev Tools shows the following:

Any recommendations? We are now dead in the water because we cannot build our application!

We are suffering with the same issue. Some of our devs appears to be able to get in, and some can’t.
My personal experience was multi browsers and multi times of revoking and some how, some way, I got a recaptcha form to appear and suddenly my Bitbucket organisations reappeared.

Thank you. I tried clearing cache and a different browser. No luck. Support told me to clear cache and cookies. Did that again, no luck and advised them. Waiting to hear back.

Based on what you and Support said, sounds like a lot of people have this issue. In my searching, it’s been a bug for awhile. Hopefully this prompts CircleCI to finally fix it.

Support are currently helping our team out by deleting the tokens on their side, and that appears to have worked.

What specifically did you do? I deleted mine in Bitbucket but still have the ghost connection in CircleCI.

With the lack of documentation and no answer from Support, we used this as the kick in the pants to finally move our legacy repo from Bitbucket to GitHub. Good riddance to Bitbucket!

Unfortunately, we still have this error for GitHub, even though we reauthenticated:

1 Like

CircleCI had to remove the ghost token for us.

I have the same problem, tried multiple browser and sessions, but that did not fix anything.

Unfortunately, CircleCI Support has not been responsive. Hopefully someone else will post here with a solution, if one exists on the user side.

@DrTorte with CircleCI Support had to take care of it on his end. We’re back up and running. Thank you!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.