Bitbucket organization not showing on my circle ci

I just revoked my circle-ci access on bitbucket and access was given back. But when I login to circle-ci, Organizations are no more displayed and i cannot found projects as well.

Please kindly help

Same thing has happened to me, which is really not useful given I am now locked out of my org and can’t rotate any of my secrets that circleci has leaked

wow. but was this now resolved for you or no resolution yet

Nope no resolution for me yet

This happened to me as well, I revoked access on Bitbucket because for some reason my project got suspended and when I try to reconnect it no Organizations are displayed. It creates a new entry in Bitbucket App Authorizations but it still doesn’t work.

I had my support ticket answered and they removed my API token and then got me to log out and back in again. This has worked for me. It seems something corrupted the API token

Is there another way to solve this without opening a ticket? Seems im not the only one in the organization having this issue so is not feasible to open a ticket for everyone.

Seeing the same issue for our service account, and now we have builds failing as this is blocking creating new SSH keys. Now I am hesitant to tell all our users to do the same. Is there an easy way to resolve this?

I eventually got access back after gotten my support ticket answered by circleci

We resolved doing the following:

  • log out from circleci
  • clear cache/cookie/storage from circleci site.
  • got an invitation link from owner/admin account

Any other approach ends in having no organizations on our end.

Hi everyone,

If you’re encountering an issue with this and haven’t yet opened a support ticket, please do so. Please include the following:

Subject Line: Bitbucket Reconnection Issue

Your Bitbucket Username
Your Bitbucket Organization Name
Your GitHub Username, if applicable.

Thanks and much appreciated,


While it has already been noted that you need to

 - log out from circleci
 - clear cache/cookie/storage from circleci site.

You may find that you also have to log out from Bitbucket and maybe delete any local Bitbucket cookies.

The reason for this is that when you first try and reconnect from within the CircleCI web interface it uses a Bitbucket-provided authentication interface that uses data from the Bitbucket cookie/data store. With the link between CircleCI and Bitbucket having been recreated the locally stored data does not work correctly.

This may be why some staff at an organization are able to correctly access the CircleCI web interface and some may not - it will depend on how the reconnection took place when they accessed the CircleCI app after the reconnection.