Xcode 11.2.1 GM Seed 1 Released

We have release Xcode 11.2.1 GM Seed 1 (version 11B53).

You can select this with the following in your config.yml:

      xcode: 11.2.1

The manifest of installed software is here. Apart from Xcode, everything should be the same as the 11.2.0 image.


Hi @marc, tried it and got an error saying

git-lfs filter-process: git-lfs: command not found

Have there been any breaking changes?


I’m seeing the same error, even on xcode: 11.2.0

Curiously enough it seems like git-lfs is installed. I attempted to get around the command not found error by trying to install it myself as an extra step.

      - run:
          name: Install git-lfs via homebrew
          command: |
            HOMEBREW_NO_INSTALL_CLEANUP=1 HOMEBREW_NO_AUTO_UPDATE=1 brew install git-lfs

The output:

#!/bin/bash --login -o pipefail

Warning: git-lfs 2.8.0 is already installed and up-to-date
To reinstall 2.8.0, run `brew reinstall git-lfs`

And when trying to run checkout, I got the same error:

git-lfs filter-process: git-lfs: command not found

This is fairly high urgency because we have an issue to push a fix to for which Xcode 11.2+ is a solution but we can’t use 11.2.0 for obvious reasons so we were hoping to build with 11.2.1 ASAP.

1 Like

Thanks @marc!
FYI: the official Xcode 11.2.1 release is available. It’s the same version 11.2.1 (11B53) as the GM Seed 1 so there shouldn’t be any issues using that instead on the same VM image you already have. TIA!

I’m showing the general release 11.2.1 as 11B500

You are correct. Thanks. Realized I downloaded the final version yesterday but that took so long that I forgot to install it! :man_facepalming:

I’ve been looking into the git lfs issue yesterday and today. The problem is that when we run the code to do the checkout, we execute it with /bin/sh -c '...'. When we invoke the shell in this way, git lfs is not on the PATH when building on Catalina. It was on the PATH on Mojave (specifically /usr/local/bin is not on the path).

So git lfs is installed, it’s not on the path. We’re working on fixing this presently, we’ll keep you updated.


Appreciate the update!

As a cheap workaround I attempted adding an export PATH=/usr/local/bin:$PATH step before the checkout, to no avail. I assume that’s due to the difference between /bin/sh and /bin/bash though.

Looking forward to a (relatively) quick fix to we can start building/shipping with Xcode 11.2.1

I’m getting ruby errors with the latest xcode builds from the fastlane plugin_update_manager

initialize': [!] Malformed version number string undefined (ArgumentError)

It looks as though something has changed in ruby and I can’t use additional plugins

[16:55:52]: Installing Ruby gem 'fastlane-plugin-update_project_codesigning'...
Fetching fastlane-plugin-update_project_codesigning-0.2.0.gem
[16:56:02]: Error loading plugin 'fastlane-plugin-update_project_codesigning': You don't have write permissions for the /Library/Ruby/Gems/2.6.0 directory.
[16:56:02]: Installing Ruby gem 'fastlane-plugin-trainer'...
Fetching fastlane-plugin-trainer-0.4.1.gem
Fetching trainer-0.9.1.gem
[16:56:09]: Error loading plugin 'fastlane-plugin-trainer': You don't have write permissions for the /Library/Ruby/Gems/2.6.0 directory.
[16:56:09]: It seems like you wanted to load some plugins, however they couldn't be loaded
[16:56:09]: Please follow the troubleshooting guide: https://docs.fastlane.tools/plugins/plugins-troubleshooting/

I’ve updated out build agent so now the checkout steps runs in a login bash shell on macOS. This fixes the git lfs issue.

Please do let me know if you see any other issues with the Catalina-based images.


1 Like

Hi Michal,

This is fixed now. Let me know if you have any another issue please.

1 Like

Thank you @marc, the issue with git-lfs now seems to be resolved.

I’m getting errors when trying to update to any Xcode build image > 11.0. The error is something to the effect chruby: unknown Ruby: X.X.X

This is because the master branch on our repository is using an Xcode 10 build image along with its comparable ruby version in the .ruby-version file.

When I make the change on a branch and circle ci checks that branch out, I guess it first checks out master then switches branch. When it checks out master I get the error mentioned above.

In order to resolve it myself it seems like I would need to make a commit to our master branch which breaks its build, is it possible to always have a comparable ruby version between images to allow for graceful updates? Or perhaps there is some other issue here or better approach that I am missing/