When can we expect the final Xcode 10.2 Image to be released?

xcode
#1

Apple has released the final Xcode 10.2 on 3/25/19, when can we expect the macOS images to be updated to this version?

12 Likes
#2

Standalone download is up.

https://download.developer.apple.com/Developer_Tools/Xcode_10.2/Xcode_10.2.xip

Please add a release build environment as soon as possible. Thanks!

#3

Hello. We have our release schedule listed here https://circleci.com/blog/build-image-update-schedule/

We will update the image when testing is complete.

#4

FYI, the current (“10.2.0”) version produces the error below when you upload the build:

ERROR ITMS-90534: "Invalid Toolchain. Your app was built with an unsupported version of Xcode or SDK. If you plan to submit this build to the App Store, make sure you are using the GM version of Xcode 9 and the SDK for iOS 11, tvOS 11, watchOS 4, or macOS 10.13 or later. If you are using an Xcode beta version to test your app, make sure you are using the latest supported version. For more information about supported beta versions, view the TestFlight Release Notes (https://developer.apple.com/testflight/release-notes/).

4 Likes
#5

Got the same “invalid Toolchain” error. Thought the version I was running was 10.2.0 since that’s what the docs say. My colleague Googled the build version and found that it was indeed 10.2.0-beta3… not sure why the docs wouldn’t mention that explicitly? Anyways once bitten, twice shy and all that.

#6

Indeed the version currently installed is the 10.2.0-beta3 (build 10P99q).

The official release is: 10.2.0 (build 10E125).

(For details: https://xcodereleases.com)

I hope the image will be updated soon as there is a bug in 10.2.0-beta3 which prevents our app to build.

#7

It’s been almost 7 days since 10.2 has been released, any update on the images?

10 Likes
#8

It doesn’t make sense to release betas named the same way as a GM release. And unless you dig into build numbers on Apple’s website, there is nothing on the CircleCI supported versions page that says it’s a beta. Just seems incredibly error prone to do it this way.

https://circleci.com/docs/2.0/testing-ios/#supported-xcode-versions

cc @alexey

5 Likes
#9

Any updates on this?

3 Likes
#10

It somehow amazes me how it’s not a bigger priority to support new Xcode releases when you consider how many business rely on it. I understand its a manual process to update but its been 10 days and they already it setup with the beta so I would assume it would be possible to do faster.

5 Likes
#11

Hopefully this issue will be solved as soon as possible.
First of all this prevents the dev ops operation to run smoothly and secondly being this a paid service it’s expected to run as expected.
If it doesn’t run well I think everyone who is running Xcode 10.2.0 is entitled to a compensation for the broken service.

2 Likes
#12

Any news?
I hope to been released the image running non-beta Xcode10.2 as soon as possible.

#13

Sorry for the delay in this. A couple of higher priority issues bumped this so we were not able to get the 10.2 GA out as fast as we normally do. We are actively working on this and expect it to be out soon. Please watch https://discuss.circleci.com/c/announcements

In addition, I have relayed the information to clarify if we have a Beta or GA version released.

#14

Any updates? This is a critical blocker for us.

6 Likes
#15

Same for us - tests are failing since we targeted 10.2, we assumed it was ready when it was released.

1 Like
#16

Its now been 15 days since the release of Xcode and 4 days since you said that it would be out “soon”. I hope you are planning to post a postmortem for how this update of Xcode was handled from your side and what you will do better in the future.

Please understand that the development pipeline of your customers depend on images for the latest releases of Xcode being available as fast as possible and if any delays are to be expected they should be communicated as soon as possible so everyone get a chance to plan accordingly.

4 Likes
#17

@drazisil apologies if you already are aware of this and I’m stating the obvious here, but I thought I’d mention the following, in case it wasn’t clear or known to everyone involved (@nh7a hinted at it 12 days ago) :

Apple explicitly rejects apps built by beta versions of Xcode once the GM version is released. In other words: the Xcode 10.2 available in CircleCI isn’t just inconvenient because it isn’t the latest & greatest, but it is invalid. As I said, this is a blocker for us.

#18

We are very aware this is a blocker. The latest update I have from the team working on this is sometime this week.

I’m also aware that this is outside the promised timeline, and and I have asked the team lead to speak to this when the update is out.

One of our support engineers, @stella, has put together a gist that at least one customer says works as a workaround. https://gist.github.com/lokst/3985c1d7610afde9f8a75b79a36496ed

While not ideal, It may help ease some of the burden. My current update stays the same, we are working to get this out as soon as we can.

1 Like
Xcode 10.2 still not supported?
Update Xcode 10.2 version
#19

Using the gist, I’m getting this error:

# Requires setting the XCODE_INSTALL_USER and XCODE_INSTALL_PASSWORD
# environment variables
# See: https://github.com/xcpretty/xcode-install#usage
xcodebuild -version
sudo gem install xcode-install
xcversion uninstall 10.2
xcversion update
xcversion install 10.2
xcodebuild -version
^D��^D��Xcode 10.2
Build version 10P99q
Successfully installed xcode-install-2.5.0
1 gem installed
-------------------------------------------------------------------------------------
Please provide your Apple Developer Program account credentials
The login information you enter will be stored in your macOS Keychain
You can also pass the password using the `FASTLANE_PASSWORD` environment variable
See more information about it on GitHub: https://github.com/fastlane/fastlane/tree/master/credentials_manager
-------------------------------------------------------------------------------------
Username: /Library/Ruby/Gems/2.3.0/gems/highline-1.7.10/lib/highline.rb:868:in `get_line': The input stream is exhausted. (EOFError)
	from /Library/Ruby/Gems/2.3.0/gems/highline-1.7.10/lib/highline.rb:891:in `get_response'
	from /Library/Ruby/Gems/2.3.0/gems/highline-1.7.10/lib/highline.rb:264:in `ask'
	from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/forwardable.rb:202:in `ask'
	from /Library/Ruby/Gems/2.3.0/gems/fastlane-2.116.0/credentials_manager/lib/credentials_manager/account_manager.rb:129:in `ask_for_login'
	from /Library/Ruby/Gems/2.3.0/gems/fastlane-2.116.0/credentials_manager/lib/credentials_manager/account_manager.rb:37:in `user'
	from /Library/Ruby/Gems/2.3.0/gems/fastlane-2.116.0/spaceship/lib/spaceship/client.rb:373:in `login'
	from /Library/Ruby/Gems/2.3.0/gems/fastlane-2.116.0/spaceship/lib/spaceship/client.rb:346:in `login'
	from /Library/Ruby/Gems/2.3.0/gems/fastlane-2.116.0/spaceship/lib/spaceship/portal/spaceship.rb:25:in `login'
	from /Library/Ruby/Gems/2.3.0/gems/fastlane-2.116.0/spaceship/lib/spaceship/portal/spaceship.rb:103:in `login'
	from /Library/Ruby/Gems/2.3.0/gems/xcode-install-2.5.0/lib/xcode/install.rb:335:in `spaceship'
	from /Library/Ruby/Gems/2.3.0/gems/xcode-install-2.5.0/lib/xcode/install.rb:375:in `fetch_seedlist'
	from /Library/Ruby/Gems/2.3.0/gems/xcode-install-2.5.0/lib/xcode/install.rb:199:in `seedlist'
	from /Library/Ruby/Gems/2.3.0/gems/xcode-install-2.5.0/lib/xcode/install.rb:413:in `list_versions'
	from /Library/Ruby/Gems/2.3.0/gems/xcode-install-2.5.0/lib/xcode/install.rb:305:in `list'
	from /Library/Ruby/Gems/2.3.0/gems/xcode-install-2.5.0/lib/xcode/install/update.rb:10:in `run'
	from /Library/Ruby/Gems/2.3.0/gems/claide-1.0.2/lib/claide/command.rb:334:in `run'
	from /Library/Ruby/Gems/2.3.0/gems/xcode-install-2.5.0/bin/xcversion:12:in `<top (required)>'
	from /usr/local/bin/xcversion:22:in `load'
	from /usr/local/bin/xcversion:22:in `<main>'
Exited with code 1

Is this something I have to do (I have them saved locally), or something CircleCi needs to fix?

#20

Hi @dai-cb,

Have you tried setting the FASTLANE_PASSWORD environment variable as well?