Xcode 10.0 GM Image Released

build-image
ios
xcode
macos

#1

We are delighted to have released Xcode 10.0 GM on CircleCI 2.0 on Friday, September 14th. To select the new image, add the following to your jobs in .circleci/config.yml :

macos:
  xcode: "10.0.0"

The software manifest for the image is here .


#2

Thanks for releasing the GM.

However, and I believe others share the same opinion, the iterations on these images should be faster. Even though the announcement mentions 14th of September, it seems like we only had access to it today, 17th of September, when iOS 12 and, as a matter of fact, official Xcode 10.0 came out (different build number than the GM).

It would have probably saved several people using CircleCI from having to create manual builds if those were shared sooner rather than later. The same thing happened for beta 6, and it now seems that this work was - too little, too late - since we must wait for the official image to be released by CircleCI.


#3

Hi,
It is nice to have a Xcode GM image, but some features requires newer version of macOS.

https://circle-macos-docs.s3.amazonaws.com/image-manifest/build-449/index.html

System Version macOS 10.13.3 (17D102)

https://help.apple.com/xcode/mac/current/#/dev88332a81e

Important: You must be running Xcode v10.0 and later on macOS v10.13.6 and later to upload your app to be notarized.

Please update macOS version if you please.


#4

I agree with Hiroshi above.

In the XCode 10 release notes, I can see that the minimum version of MacOS required is 10.13.6

Xcode 10 requires a Mac running macOS 10.13.6 or later.

While in the build image manifest, the version of MacOS listed is 10.13.3

System Version macOS 10.13.3 (17D102)

Could we have an updated MacOS? I think this was the cause of our failing build trying to validate the provisioning profiles.


#5

Does the this release include simulators for iOS 10 and iOS 11? During the betas, simulators for only iOS 12 were available.


#6

You can find the exact list of simulators (and other tools) in the build manifest https://circle-macos-docs.s3.amazonaws.com/image-manifest/build-449/index.html


#7

We are having issues with builds and provisioning profiles too and I think it’s because Circle CI is using an older unsupported version of Mac OS with Xcode 10.

Everything works fine with Circle CI and Xcode 9 but with the Xcode 10 images it can no longer sign the build and upload it to TestFlight due to the following error on every single provisioning profile (which all work fine with Xcode 9 and 10 on other machines):

DVTProvisioningProfileManager: Failed to load profile “/Users/distiller/Library/MobileDevice/Provisioning Profiles/e5abd7c3-86e7-44d4-9dab-9cdd02982b03.mobileprovision” (Error Domain=DVTProvisioningProfileProviderErrorDomain Code=2 “Failed to load profile data.” UserInfo={NSLocalizedDescription=Failed to load profile data., NSLocalizedRecoverySuggestion=Profile “(null)” ((null)) has unsupported platforms (null). Profiles with the “mobileprovision” file extension should have one of “tvOS”, “watchOS”, or “iOS”.})

Running the following command:

/Applications/Xcode.app/Contents/MacOS/Xcode

also produces this warning:

application requires at least OS X version 10.13.6 (10.13.6), but is being run on 10.13.3 ( 10.13.3/17D102), and so is exiting.Abort trap: 6

So it’d be great if Circle CI could respond to this thread with a status update of getting a version of Xcode 10 on a supported version of Mac OS!


#8

@Sara could we please get an updated macOS image with at least 10.13.6 ? As XCode 10 doesnt fully work with CircleCI due to the macOS version, it blocks us from upgrading our software


#9

Hi all! We’re aware of the issue and plan on replacing the image soon or update it to the next patch version of Xcode (if it becomes available first). Thank you for your patience while we work on this and please watch Announcements for an update.


#10

Thanks for pushing the update.

Is the XCode 10 version 10A255 or 10A254a?
From what I’ve gathered, one is the final release, and the other is the GM seed.
Can you verify that the machines are running the final 10A255 version?

Thanks!


#11

@Sara When can we expect Xcode 10 version 10A255 on MacOSX 10.14?


#12

@Sara any news on an updated Xcode 10 image? It’s been 17 days since Circle CI released an invalid Xcode 10 image that isn’t capable of signing builds or uploading them to TestFlight due to using an out of date Mac OS that’s not compatible with Xcode 10.

It’s costing our team members a lot of time in manual release engineering and it’s what we’re paying Circle CI for. While I appreciate that you’ve acknowledged the issue it’d also be great to now have a fix delivered.


#13

@Sara could we get an ETA for latest xcode (10.0 final)/macos (10.13.6) . we’re getting some “Path to CoreSymbolication is invalid, aborting” errors when uploading DSYMs to Fabric. this essentially means that uploads of DSYMs to Fabric are broken on these images, and have to manually upload builds.


#14

My team is experiencing the same issue with being forced to do things manually which is increasing the complexity of our release cycle. :persevere: I’ve been in contact with people at Circle and the most recent response I’ve gotten (from 10/6) is:

We do not yet have an image available with 10.13.6. Our engineering team is working on providing this as soon as possible. We will provide you with an update as soon as we have more information. Thank you for your patience.

I sent a followup email requesting an ETA, so if I hear anything I’ll be sure to update here as well.


#15

:pray: thank you. this seems very problematic as xcode 10 is installed on an unsupported OS.


#16

I second what everyone else is saying. Additionally, the XCode command-line tools need to be upgraded to v10+. If I run brew config on the image I get:

CLT: 9.4.0.0.1.1526532315
Xcode: 10.0 => /Applications/Xcode-10.app/Contents/Developer

Due to this we are currently unable to install applesimutils, see https://github.com/wix/AppleSimulatorUtils/issues/29


#17

Hi Everyone! The Xcode 10.0.0 image now has macOS 10.13.6. Thank you again for your patience while we worked on updating this image!


#18

Thanks, the updated image is working for us. Circle CI is now successfully able to sign our builds and upload them to TestFlight!


#19

Hi all. I decide to upgrade xcode version to 10.0.0 after succesful release it 2 days ago. And now VM for me not assigment, because i stuck on this letter:
“Creating a dedicated VM with xcode:10.0.0 image
Waiting for a VM assignment:”
Please, solve this problem, we can’t upgrade our app, while this issue is there(


#20

Hi! What’s the ETA on Xcode 10.1? It’ll really help us as we need to build with it.