Trying to use macos.x86.metal.gen1 but getting an error

Hi all, I’m trying to use the macos.x86.metal.gen1 in my yml but am getting an error:

My yml snippet looks like:

resource_class: macos.x86.metal.gen1
macos:
xcode: 13.2.1

I am able to use this without any issues though:

resource_class: medium
macos:
xcode: 13.2.1

I know the metal one says that it requires a 24 hour lease… is there some setting in my org or projects that I need to enable to use it?