The extension won't recognize the config files in my project: The focused file is not a CircleCI config file


The config.yml file is in focus and runs fine as a pipeline but when pressing “Validate current configuration file”, I get an error that "The focused file is not a CircleCI config file. Make sure you’re focusing on a config file ". Is this a know issue and is there a fix for this?

1 Like

Hello Olivier,

Thanks for the report! We’re going to look into it, just a question, is your yaml file inside a .circleci folder?

Hello Olivier,

Thanks for you feedback!
Indeed, it is a known issue about how VSCode handles focused window.
If you have a terminal/debug console/debug/problems tab open, please click on it, then click again on the CircleCI config file you’d like to verify.
By the way, you can click on the CircleCI icon on the top right corner of your editor to verify the config file too.

Let me know if you have any other questions!


Yes, the file is in the .circleci folder. Its also running like it supposed to.

Thank you for the quick answer. And I tried the workaround, but I get the same result. Have also closed all additional windows, but still nothing. This is some more information if you want to try and reproduce it.

Version: 1.75.1 (user setup)
Date: 2023-02-08T21:32:34.589Z
Electron: 19.1.9
Chromium: 102.0.5005.194
Node.js: 16.14.2
OS: Windows_NT x64 10.0.19045
Sandboxed: Yes

I have 3 config files in one repo: a main file and 2 continuation files and the stepup is like this:

Main → root/.circleci/config.yml
Continuation → root/projectOne/.circleci/config.yml
Continuation → root/projectTwo/.circleci/config.yml

Thank you for the answer.

How do you trigger the config validate feature ? Via the command palette, the icon on the top right corner of your editor or via a right click inside the file ?

I’ve tried both ways and it gives the same result

1 Like

Thank you for your feedback, we will investigate into this.
We will let you know once a fix has been deployed.

Hi @OlivierDeNeef .
Sorry for getting back to you so late. This issue was (hopefully!) fixed a few weeks ago.
Could you confirm you are not still experiencing problems?

Sorry for the late reply, everything works perfectly now. And the new features are awsome for navigating yaml, great job