SSH Handshake error on new project

I’m getting the following error on a newly setup project:

error cloning repository: ssh: handshake failed: ssh: unable to authenticate, attempted methods [none publickey], no supported methods remain

I can see that the access key was created on the bitbucket repository and it’s also there in circle ci. All our other projects are working just fine. The access key status on bitbucket also says “never” in the “last used” column, which appears suspicious to me.

I’m kind of lost here. I also tried setting up another project and I’m getting the same error. Older pipelines on other projects are working fine.

I don’t know if you’re still running into this issue, but I was able to resolve it by modifying my SSH config on my local dev machine.

In your $HOME/.ssh/config file:

Host *
  PubkeyAcceptedKeyTypes +ssh-rsa

Thanks for the answer.

The problem was the connection between circleci and bitbucket, so I don’t think it was fixable on my local machine ssh settings.

It appears as though it was fixed, either by the circle ci team or bitbucket. Wherever the issue was.

Oh, sorry. I totally misunderstood the problem at hand. Glad it’s working again, though!