Setup-project broken

bitbucket

#1

When adding a new project from bitbucket and clicking ‘Set up Project’, a blank screen appears, nothing happens.


#2

Same here. I’ve tried everything (logout and login, re-auth circleci), nothing seems to work. (Github project in my case)


#3

Ditto. On github, tried personal account, tried org account, nada.

Also tried turning off Privacy Badger and uBlock Origin. On that note, I’m surprised at the third-party tracking and advertising scripts being pulled into the app, e.g., connect.facebook.net, www.google-analytics.com, bat.bing.com.

Looks like I picked the wrong week to demo CCI for the execs.


#4

Ditto, tried everything that came to my head, made public a repo and other stuff.


#5

This happens on my private circle account. When I tried it on my enterprise work account, it all works fine. Annoying coz that’s the account with live support.


#6

Same here, happens for enterprise account. I am blocked!


#7

Hmm, the URL in the image supplied by the OP does not match what I have (and mine works).

The format of mine (on GH) is https://circleci.com/setup-project/gh/(username)/(project). For BitBucket, which also works, I have https://circleci.com/setup-project/bb/(username)/(project).

What browsers are people using? I’m on Firefox/Mint. Does anyone get JS crashes in their browser console?

Are folks here having problems with a paid account or a free one? I’m on the free tier only.


#8

Ah, I wonder if a link is rendering incorrectly for people. I have just tried https://circleci.com/setup-project/projectname and it fails in the same way as the OP’s report. I suggest people try typing in the URLs as per my format above, and that might get them working again.


#9

This solution worked for me. I’m using Chrome v71, no JS crash.
I have a free account.

Thanks @halfer


#10

“Set Up Project” button now resolves to the correct URL, and the page is no longer blank.


#11

Just to close the loop here, this was a UI bug that was shipped and reverted. Everything should be back to normal now. If you are running into this issue it is likely a separate problem, please open a new thread :slight_smile:


#12

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.