Renaming GitHub Org Breaks Circle


#1

I posted this as a comment in the Build Environment category but I believe i’s more appropriate in Bug Reports here so reposting.


I ran into a problem with renaming a GitHub org, now whenever I try to view my projects in CircleCI I’m redirected to a 404 page and it acts like I’ve logged out, or when I try to set up a project and I click “Start Building” and the button is in an infinite loading state. None of my builds run and I’m given the message “Your build was not run - reason code (:no-followers).” If I try to click “Follow Project” it gets stuck in an infinite loading state.

I contacted support and received a response that I couldn’t get help since I’m not on a paid plan. Is it impossible to get this problem fixed on a free plan?


#2

Well now, as most likely the last person to touch this code, that is interesting/troubling…

@lunafi-evan does this happen in CircleCI under the name of your new org (ie, you’re not trying to go to a link which has your old org name in it) AND under the name of a new project (ie, you’re not trying to access one of your old projects).

For example:

  • I have have a GH org Foo (original name, I know)
  • I go into CircleCI, and start building a project Raekwon
  • I go to GH and rename my org Foo to Bar
  • I go into CircleCI, wait for it to recognize my GH org rename (refresh all the things)
  • I go into/create a project called Bar/Raekwon

NOT:

  • I got into CircleCI and try to go to Foo/Raekwon or Foo in general

#3

So here’s an overview:

  • I started with org Foo and one project being built, ProjectA
  • I renamed the org from Foo to Bar
  • If I try to visit urls using the old Foo org ProjectA project, everything is broken and nothing loads
  • If I try to visit urls using the newly renamed Bar org, I can view my projects and builds
  • Two days ago ProjectA under the newly named Bar org was not even building because it said nobody was following it and when I tried to follow it the button would just keep showing the loading animation infinitely. Today it suddenly started working when I push to my pull request, even though I haven’t changed anything
  • If I try to follow another project under the new Bar org, the button is stuck in a loading state infinitely
  • If I try to set up a new project under the new Bar org, the “Start Building” button is stuck in a loading state infinitely

#4

Joy, this sounds like a fun case GH timing issues, internal timing issues, and I’m guessing the space time continuum just hates me personally to boot.

@lunafi-evan we’ll get you sorted yet!

First: thanks for taking the time to write all that up. As a fellow developer I’m sure you can understand just how valuable understandable, and well written bug reports are. Go you!

Second: to start on all this, @lunafi-evan please log out, clear you CircleCI related cookies and caches etc., then log back in. There’s a very outside chance that this will give the refresh logic enough time to do everything it’s wingeing about doing presently. (this is not a good UX at all obviously, but if it gets you immediately unblocked, I’ll take it)

Third: @drazisil any chance you can help me/us transfer this over to a proper ticket in our system? I’m not sure I know what usually happens from here on out.

@lunafi-evan I very rarely am let out to talk to customers, they usually keep me locked in the SQL mines. whereas @drazisil is legit. So, I’m going to hand off to him monitoring this while I focus on the underlying issues.


#5

@lunafi-evan Can you send a request to support@circleci.com with the old and new names so I can do a manual transfer? You can mention me in the ticket so my fellow agents know to get the ticket to me.


#6

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.