Build not triggered after Github repo was renamed

github

#1

We renamed a repo. Many settings in Circle CI seem to have picked up the new name, but not everywhere. And builds are not being triggered.


#2

Could you please email support@circleci.com with the org and project name and we will fix that for you?

Thanks!


#3

For future readers, what I did in my case to resolve this issue (with my private repo) is:

  1. Go to the dashboard/history to find your old project’s link, e.g.
    https://circleci.com/gh/:org/:old_repo/
  2. Change the address and go to:
    https://circleci.com/gh/:org/:new_repo/
    This will trigger some repair in circleci server
  3. Go to your GitHub repo’s setting -> webhooks -> https://circleci.com/hooks/github
    Here you should find some failed hook deliveries. Click to expand Response and look for ones with the header for X-GitHub-Event of either push or pull_request (with “action”: “opened” in the payload) and redeliver it.
    If this is too complicated/troublesome you can always just push a new commit.

Hope this helps you.


#4

This worked flawlessly.


#5

worked for me thx


#6

Worked but I had to resend the payload with “X-GitHub-Event: push”, the PR with action opened didn’t trigger a new build. Thanks!


#7

#8

For future readers, resetting the webhooks should also fix this problem right away: https://support.circleci.com/hc/en-us/articles/115015447187-Commits-not-building-after-username-project-or-repo-renamed