Is there any way to disable git-lfs in Ubuntu 14.04 (Trusty) image?

git-lfs

#1

My project timeouts during checking out repository because of taking too much time(>30min) to download a lot of files under control of git-lfs.

I tried to find out how to tell CircleCI stop using git-lfs but no luck.
Since checkout can’t be succeeded, even circle.yml seems not be loaded.

(And when I looked into the failing console output, git-lfs was stuck during downloads.
Maybe this topic is relevant? Build times out at Checkout)

Any help will be appreciated.


Build times out at Checkout
#2

Hello Shimada-san,

I found your ticket in zendesk and will respond there.

Best,
Zak


#3

I’m having this problem too. How do I get help with it? It would be helpful if this discussion included details about the outcome so others can benefit.


#4

We are also having this problem. We opened a support request, but haven’t heard back yet. We’ve temporarily switched back to the Ubuntu 12 container as a workaround, but would love to get back on 14.


#5

Discussion with support is still ongoing. I’ve claimed that there’s something wrong with git-lfs but looks like they think different way(like repository is too big, etc…)


#6

In our case, we think this is caused by having many files in LFS (https://github.com/git-lfs/git-lfs/issues/931).


#7

Yes, I also have many files in git-lfs and I know it’s very slow. However, when I looked into the build log, git-lfs in the container behaved like “stuck” instead of “slow”. I guess some constant networking issue is there between CircleCI and Git LFS.

I know that this kind of issue takes a lot of efforts to investigate, so my possible workaround is just to remove git-lfs from my build image(even when circle.yml cannot be loaded) as fortunately my test suites don’t depend on git-lfs’ed files.

Problem is, I still haven’t succeeded to make them understand my exact situation (and maybe what the heck git-lfs is).


#8

I was able to figure out what my issue was and now git lfs is working for me in CircleCI. This may not apply to you, but it’s something you can check. When I checked out the repo separate from CircleCI I noticed some of the files I was tracking with LFS gave an error message “Pointer file error: Unable to parse pointer at:”. When cloning in CircleCI it just hung on these files indefinitely instead of giving an error for some reason. I think I got into this situation by using git mv to move files from a path that was not tracked by git-lfs to a path that was. I think as a result the git-lfs files were in a weird state in git. To fix this I tried deleting the files and readding them. The error message went away and CircleCI became unstuck while cloning.

What was helpful in discovering this was SSHing into the CircleCI VM and setting these flags, then running the various git commands CircleCI uses to clone to the commit. I saw that it got stuck after one file.

export GIT_CURL_VERBOSE=1
export GIT_TRACE=1
export GIT_TRACE_PACKET=1

#9

I tried to check out my repo in my local machine with setting env vars you suggested but unfortunately no any signs of error were shown.

So it looks I still need to find out how to escape from git-lfs in circleci build env.

Anyway thanks for valuable information.


#10

It seems like the slow clone problem could be worked around if Circle CI incorporated the following into their clone command:

GIT_LFS_SKIP_SMUDGE=1 git clone https://github.com/username/my_lfs_repo.git destination_dir
git lfs pull

@circle, can someone please respond to my support inquiry about this issue? (#14890)


#11

Thanks everyone for your feedback here.

Git LFS was added in our most recent image update. Ubuntu 14.04 Build Image Update 201701-01

@kimh since this effecting so many users, is there a way to make this either an optional service or remove it altogether in the next image update?


#12

Any updates on this issue? I still am waiting for git-lfs to be optional…


#13

@shimarin, @nic:

Could you try setting GIT_LFS_SKIP_SMUDGE=1 as an environment variable?


#14

Thanks for reply.

Actually I’ve already tried it but didn’t change anything.


#16

This problem exists, and it’s a show-stopper.

Cross-referencing https://stackoverflow.com/questions/44986734

I’m happy to help.


#17