Build times out at Checkout


#1

Hello,

I have a project linked to a private GitHub repository, for which I added a Deploy key to build on Linux.
Builds were running fine until I committed a minor change (definitely not impacting the build). The build “timed out” and hung at the “Checkout using deploy key” step.

The message I get is:

Warning: Permanently added 'github.com,192.30.253.112' (RSA) to the list of known hosts.

command if [[ -e /home/ubuntu/reponame/.git ]]; then git fetch --force;else
rm -rf /home/ubuntu/reponame
mkdir /home/ubuntu/reponame
cd /home/ubuntu/reponame
git clone --quiet git@github.com:username/reponame.git . --config core.compression=9 --depth 10 --no-single-branch
fi && true && git reset -q --hard commitsha && git checkout -q -B 'master' commitsha && git reset -q --hard commit_sha took more than 30 minutes to run

git checkout cancelled

What I’ve tried so far:

  • Removing the deploy key and creating a new one (repo side / circle side)
  • Checking out at the working build commit and triggering a new build
  • Clearing source / dependency cache

Any help would be appreciated.
Thanks.


Is there any way to disable git-lfs in Ubuntu 14.04 (Trusty) image?
#2

I have this exact same issue. Haven’t found a workaround


#3

I ended up creating a new repository (different name) and copying the original repository content (without the git) and the build succeeded. I had to do a backup of the original repository with the git since I didn’t want to lose the history.
I guess there is a better way but it’s the only one that worked.

By the way, I also tried debugging via SSH and I got the message ‘Clone succeeded, but checkout failed’.


#4

@minjungkh That is really weird, please let us know if this issue comes up again.


#5

I can replicate it super consistently. Unfortunately, I don’t have any other info than what was already posted above.

What info would be helpful?


#6

@coristig Could you send a link to a build?


#7

Here it is: https://circleci.com/gh/yhat/yhat-website-boot-theme/95

The project is private, is there a way for me to invite you / give access?


#8

@zzak I did have git lfs configured.
https://discuss.circleci.com/t/is-there-any-way-to-disable-git-lfs-in-ubuntu-14-04-trusty-image/10208


#9

It’s ok, as an employee I can see your build just fine.

Thank you for the link!


#10

@minjungkh Thank you for letting us know.

Best, Zak


#11

I’m having the same timeout problem. How do I get help with this?


#12

Any updates on this? Appreciate the help


#13

I am experiencing this, and I thought it might be git-lfs related.

It turns out (upon ssh’ing in to test) the git reset --hard SHA was hanging, which is consistent with the git-lfs problem noted here: https://stackoverflow.com/q/44986734/19212


#14

Hi guys, any update on this? we are having the same issue.


#15