IP ranges Open Preview

We’re excited to announce that our IP ranges feature is now in an open preview! IP ranges allows customers to meet their security and compliance requirements by enabling jobs to go through a set of well-defined IP address ranges that are verifiably associated with the CircleCI service.

Open Preview Availability

The IP ranges preview is available to all cloud customers on a paid pricing plan. Pricing will be calculated based on network data usage of jobs that have opted in to using the IP ranges feature. There is no charge while the feature is in preview. Pricing details will be shared soon and will take effect when the feature is generally available. The feature is currently exclusively available for Docker jobs, not including remote_docker.

Enabling IP ranges

The IP ranges feature is enabled on a per-job basis using a specific config flag. For more information on getting started, see the IP ranges documentation page.

Feedback

We’re very interested in hearing your feedback! Feel free to send feedback for specific requests during the preview in the new “IP Ranges (open preview)” category on our cloud Canny board or ask questions in this Discuss topic.

3 Likes

Hi there, it’s very useful feature and I’m already using it.
But today I faced the issue when trying to use circleci_ip_ranges: with parameter.
Here is the part of my config

...

deploy:
    parameters:
      only-prod:
        type: boolean
        default: false
    circleci_ip_ranges: <<parameters.only-prod>>
    docker:
      - image: circleci/python:3.8
    steps:
      - checkout
...
workflows:
  feature:
    jobs:
      ...
      - deploy:
        only-prod: false
        context: dev
  ...
  production:
    jobs:
      - deploy:
          context: production
          only-prod: true
          filters:
            branches:
              only:
                - production
....

And I’m getting this error:

[#/jobs/deploy] 0 subschemas matched instead of one
1. [#/jobs/deploy] only 1 subschema matches out of 2
|   1. [#/jobs/deploy/circleci_ip_ranges] expected type: Boolean, found: String
|   |   SCHEMA:
|   |     type: boolean
|   |   INPUT:
|   |     <<parameters.only-prod>>
2. [#/jobs/deploy] expected type: String, found: Mapping
|   Job may be a string reference to another job

Can you help me with this?
Thanks

Same issue here. Trying to use a parameter in an orb to set it should use it or not but the param is recognized as a string instead of boolean

@VahagnBleyan apologies for the delayed response.

For the first, we need a bit more information on our side to understand what’s going on. Is it possible to share the rest of the config?

For the second issue, the indentation appears to be off. The only-prod and context need to be indented below the deploy

@via-justa Similar to the above, we think that parameters aren’t supported where you’re trying to use them, but we’d need to see more of the config in order to verify. Are you able to share more of the config? You can share via direct message if you do not want to post here.

@via-justa and @VahagnBleyan

We’ve found the root cause and want to let you know that this is currently a known limitation that we’re working on fixing. I’ll provide an update when I have more.