Indefinitely queued build


#1

One of my builds appears to be stuck in queue, but the UI doesn’t reveal why:
https://circleci.com/gh/palantir/gradle-java-distribution/21

It’s been in “Scheduled” state for a few minutes “waiting on previous builds”, but I can’t find any other builds that are running.


Queue waiting for projects that are already finished?
Build queued - never running
#2

Seeing this too on some of our repos.


#3

Same here.


#4

Thanks for bringing this to our attention. We’re currently looking into it.


#5

Yup, all of my builds are waiting for a phantom build to finish.


#6

This issue has been resolved. If you continue to experience similar issues, please check to make sure you are triggering your build via GitHub push, instead of using the “rebuild” button to retry a previously stuck build. If that still doesn’t work, please let us know here.

Thanks!


#7

‘resolved’? … as in… are we supposed to kill all the existing perma-stalled builds and presume this won’t happen again? Because I still have a bunch.

And does your reply mean that the ‘rebuild’ button is broke, no matter what, or just for these affected builds?

Frankly, none of this seems “resolved”.


#8

Hi @dahoste,

Using the rebuild button to rebuild a previously stuck build may create a new build that is also stuck. Using it for any other build should work as expected.

Yes, that will work. We apologize for any inconvenience experienced with this approach.

Given that the fix was implemented several hours ago and the issue has not resurfaced, it is safe to presume that this won’t happen again.

Let us know if you have any other questions!

Cheers,
Frank


#9

Still seeing this issue.

Steps I took to create it:

  1. ) Build Failed
    2.) Clicked rebuild
    3.) Phantom is back… :slightly_smiling:

#10

Hi, I got this problem too.

All my builds are Scheduled but there is not any build is running.


#11

Hi, I’m getting same issue here.
CircleCI status says it’s all green, but my queue is all purple :sweat:


#12

@takayukioda @tsing @larron We ran a job to fix this a few hours ago, please let us know if you still see the issue. Sorry about all this!


#13

FYI – I’ve still been seeing this myself on occasion and just experienced it now.

I had a build waiting in the queue and after the builds in front of it completed, it stayed in the queue until I clicked “Rebuild”, at which point the stalled build started and so did the new one I just created by clicking “Rebuild”.

The message it still displays is “Circle spent 00:00 acquiring containers for this build. This build was queued behind the following builds for 26:58” with all three builds completed.


#14

I now have a build, too, which is queued now for just over an hour, waiting for a job that is already long finished. The previous job was also spuriously queued for almost an hour.


#15

I just re-checked the build status, and it is still queued behind the same finished build, but now the queue wait time is reduced to 45 minutes. Maybe the support staff is currently working on the problem?


#16

The build has now run, after being queued for 2:04:11. Some data is still not up-to-date, e.g. it is shown as having finished “0 sec” ago, but it finished 7 minutes ago.
A new build has been queued after a GitHub push, and is marked as queued since 0 secs - which is nonsense.


#17

I’m seeing the queued build issue now here:

https://circleci.com/gh/wellbridgehealth/monolith/25

That build has been blocked on the successfully completed predecessor build for 20 minutes.

What should I do?


#18

I have one queued build and another dozen piled up behind that one. Dead in the water.


#19

The issue is not resolved. I have a single queued build from yesterday and 15 builds behind it.


#20

Very sorry about that, David. We got your build running, currently looking into the root cause. Sorry again.