Builds stuck in "not running" or "scheduled"


#1

several of our organizations builds seem to be stuck in “not running” or “scheduled”. We have plenty of parallel space for these builds to execute.


#2

it appears to now be working.


#3

spoke too soon…it retried several times and then put it into a “scheduled” state.


#4

I am seeing this warning on CIrcleCI UI on the “Retried” builds. “Some errors occurred while attempting to infer information about your code.” Not more information. I am not sure why, it was building fine earlier in the day.


#5

Hi @bka9

We fixed few bugs recently that should have taken care of this issue.

Can you please send me a build link if this issue still repros and we can investigate.


#6

@anon30319619 https://circleci.com/gh/octanner/platform-auth-api/62


#7

Thanks @bka9.

Your builds are running on 1.0. Did you intend to run them on 1.0 ? (I see a 2.0 tag on this discussions thread)

I did not see your builds queuing for the project link that you shared. You can see the queue times on the top of the page and I see 0:00 for most builds I checked on.

Please let me know if this issue still exists.


#8

@anon30319619 Sorry I wasn’t sure what version we were using. Though I am still have issues with this build. It is not that there is an indefinite queue time, it starts the build and then gets to the “Configure the Build” stage, it says it is sucessful on that step but the status of the build changes to RETRIED. It attempts two more times and then gets into a SCHEDULED state for a while and the status changes from SCHEDULED build to a CIRCLE BUG state.

https://circleci.com/gh/octanner/platform-auth-api/tree/master


#9

We experience the same issue, so apparently it is not fixed. Opened a ticket six days ago and still no response (except for the robot…). We have paralellism of 6x ; only one build is running with parallelism of 2x, and a lot of other builds are queued behind it (usually in ‘not running’, sometimes ‘scheduled’.)

Any help would be appreciated!


#10

We are experiencing the same issues on 2.0 for 2 hours now.
https://circleci.com/gh/SumatoSoft


#12

We are experiencing this issue as well. Using workflows and had about 10 containers stuck in “Not Running”.


#13

Similar issue here.

A build crashed

and is now marked as Retried.

An identical build was triggered, but this one sat at “Scheduled” for over 20 minutes. There was nothing ahead of it in the queue. It did eventually run, and under Queued it reads “22:27 waiting + 00:00 in queue”. The 22:27 wait is unexplained


#14

Hi,

I’m currently trying to run my project on CircleCI but it is in a “Scheduled” state for 2 hours. I cancelled and tried “Rebuild”. Now it is in “Not running” state since 1 hour. Can someone please help me here?


#15