GitHub organization private repos missing from "Add Projects" page


#1

I’ve just started with CircleCI today, but unfortunately I can’t integrate it with my github repos.

I am an admin of a GitHub organization and I have already authorized CircleCI as suggested in the docs.
I can see my organization under the “Getting Started” section of the “BUILDS” tab. However when I go to add a new project, all I see is my personal public repos, not any of the private repos associated with the Organization.
I have also tried logging in with “all repos” (why does that option even exist?) but there is no difference.

Is there something that I am missing? I’ve scoured the docs and done everything they suggest, but still no luck.

Thanks,
Ian


#2

The behavior you see (Only public repos) suggests that you authorized your account using the GitHub Public option. The way to fix that is generally changing the permissions which should be done by logging in the way you did. I’m unsure why that fix would not work - my suggestion would be to try removing the permissions and trying it over again. Best of luck!


#3

Thanks for the fast response!
by “removing the permissions” you mean the github “Organization settings” -> “Third-party application access policy” right? I denied and then granted again, but so far no difference.

One thing I noticed is that some other services we use have 2 permission categories. For example:

  • Gitter Private Repo Access
  • Gitter Public Repo Access

Which are both approved, Should CircleCI have 2 permission categories as well?

Also, is there some other permissions I need to set somewhere in GitHub? Do I need to enable circleCI access for each repo or something?


#4

I am running into a similar problem where I only see public repos and no private repos. Did you get any resolution to this issue?


#5

Hi @switchspan, I was able to figure it our purely out of luck.

In the very top left corner of the web UI you can change what “organization” you are currently working with. I had to change from my personal github to the github org. Then if you go back to add projects you should be able to see all repos under the github org.

Really dumb UI design in my opinion. They should add a notice right on the add projects page that says something like “Can’t find your repo?” that links to docs explaining this.
I also can’t find any docs that mention the top left org switcher tool which is so critical to the UI.


#6

Thanks for pointing this out. I submitted a PR to our docs, adding a note about this.

I also added a ticket to our system to add some copy on the projects page.


#7

Thanks Eric!

I pushed this to the Hello World document and the FAQ. https://circleci.com/docs/2.0/hello-world/ https://circleci.com/docs/2.0/faq/#why-cant-i-find-my-project-on-the-add-project-page

-Michelle


#8

Wow! Impressed by the fast response of the employees here :+1:
Thanks for getting this into the docs, will make life easier for the next person.


#9