Github Integration - setup no longer working

github

#1

I’ve tried this on several projects now; personal projects, public projects, and projects with our org, private projects.

Process:

  • Go to a GitHub project, settings, Integration & Services
  • Select CircleCI
  • Save the integration
  • Follow the project on CircleCI (will build manually without issue)
  • Go back to the GitHub project, settings
    • deploy key exists and was used
    • service still grey
    • no webhoook setup
  • Open service and send a test payload -> “Okay, the test payload is on its way.”
  • Wait for it… wait for it…
    • Crickets
  • Delete, unfollow, refollow, retry
    • Crickets

I’ve setup dozens of projects in the past. Seems 100% broken.

Example public personal project: https://github.com/ninowalker/ymlgraph


Troubleshooting when Circle doesn't build after pushes to GitHub
#2

Note that another user has reported the apparent identical issue here (and in the same timeframe): Troubleshooting when Circle doesn't build after pushes to GitHub


#3

I’m seeing this on CircleCI version 2. Webhook seems to fire fine and is aknowledged. But nothing happens on the CircleCI end.


#4

I am seeing the same condition with one of my projects. I have two other projects which seem to be working fine. I’ve removed the checkout key, unfollowed then refollowed the project per another answer on this board and no luck.


#5

I’m having what seems to be the same problem as @ryancastle , where I can see that the webhook is firing and acknowledged, but my CircleCI project status is not updating. Builds aren’t firing, and I’m not seeing any new commits or branches after the state that the GitHub repo was in when I first followed it.

I’ve tried removing hooks/unfollowing/refollowing as suggested but it hasn’t changed a thing.


#6

Might be worth adding some repo information so employees have something to investigate. Post it here if you’re on the free tier, or raise a support ticket if you’re on a paid contract.


#7

Found my issue – bad syntax in a workflow (I’m using v2 with workflows.) For anybody as confused as I was: if you have a validation error in your workflow, nothing will update on the builds tab (and retrying the last failed build will not look for a new commit.)

Also there’s no notification that I could find that the workflow’s broken – as far as I can tell, you just have to go look at the workflow tab and then try to unravel (from the VERY opaque error message there) what your syntax issue is. Unlike a failed build, which sends me an email, I didn’t get any kind of notice that my changes were being noticed and were just failing. This seems like a UX issue CircleCI might want to fix.


#8

Also, for the curious, my syntax error was exactly this one: Workflows "Config does not conform to schema" error


#9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.