Error with circleci orb init command - author field is required

I’m trying to author an orb for the first time. I’m following one of the tutorials given on the circleci site.

Before I ran the command, I (1) created a namespace “revenova” (2) created a github repo Revenova/sfOrgBuilder-orb (Revenova is our org name).

Below is the command with inputs, outputs and errors. Can anyone give me a hint on what is missing:

$ circleci orb init sfOrgBuilder-orb --private

Note: This command is in preview. Please report any bugs!

? Would you like to perform an automated setup of this orb? Yes, walk me through the process.

Downloading Orb Project Template into sfOrgBuilder-orb

A few questions to get you up and running.

? Are you using GitHub or Bitbucket? GitHub

? Enter your github username or organization Revenova

? Enter the namespace to use for this orb revenova

Saving namespace revenova as default

? Orb name sfOrgBuilder-orb

? What categories will this orb belong to?

? Automatically set up a publishing context for your orb? Yes, set up a publishing context with my API key.

orb-publishing context already exists, continuing on

? Would you like to set up your git project? Yes

? Enter your primary git branch. main

? Enter the remote git repository

Thank you! Setting up your orb…

Error: author field is required


Can you please confirm that you have your set globally in git? You can check this in your ~/.gitconfig file. If your email is not set globally could you please try setting that with:

git config --global

Please give that a try and let me know how you get on!

Kind Regards
Owen Oliver

My is set and visible in the [user] section of /.gitconfig and I still have the error.

After looking the git settings, the error is to set

git config --global <name>

It would probably be better to have a Git repository template rather than a UI - it would not block users.