Error while trying to install libpango1.0-dev


#1

Hello community!

I’m getting an error while trying to install an important dependency for our application. Basically, this is what I get:

ubuntu@box363:~$ sudo apt-get install libpango1.0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpango1.0-dev : Depends: libpango-1.0-0 (= 1.36.3-1ubuntu1.1) but it is not going to be installed
                   Depends: libpangocairo-1.0-0 (= 1.36.3-1ubuntu1.1) but it is not going to be installed
                   Depends: libpangoft2-1.0-0 (= 1.36.3-1ubuntu1.1) but it is not going to be installed
                   Depends: libpangoxft-1.0-0 (= 1.36.3-1ubuntu1.1) but it is not going to be installed
                   Depends: gir1.2-pango-1.0 (= 1.36.3-1ubuntu1.1) but 1.30.0-0ubuntu3.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Any clue on what’s going on?

Thanks!


#2

I met the same issue today. Did you resolved it?


#3

Try a sudo apt-get update first. If that doesn’t help, show us what you are doing, and the config you are using.


#4

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.