Sudo apt-get install 404 failure


#1

Today “sudo apt-get install python-dev” started failing with
"Err http://archive.ubuntu.com/ubuntu/ trusty-updates/main libpython2.7-dev amd64 2.7.6-8ubuntu0.2
404 Not Found [IP: 91.189.88.161 80]"
See: https://circleci.com/gh/sorenlassen-csumb/cst438fa16hello/30
The same is happening for my students in their projects and after multiple retries.

UPDATE: was solved by tom’s fix to call sudo apt-get update before calling sudo apt-get install python-dev.


#2

My team started having this exact same problem today, with the same library. Oddly enough, out of the ~10 repos we have that install that library in order to deploy, only one of them has gotten this error so far.

It’s very consistent, too-- every time we push to that one repo, it fails. Every time we push to the others we’re actively developing on, it succeeds. The build and deploy scripts are exactly the same for all these repos. They’re all microservices that get pushed into the exact same Amazon ECS cluster.

It’s worth noting that last week, this same repo started failing builds because python2.7-dev didn’t exist, when our other repos (again, using the same deploy scripts) didn’t have this problem. That’s why we added a line to install that package in the first place.


#3

Thanks for reporting this.

As a first check - can you make sure you have a sudo apt-get update before calling sudo apt-get install python-dev.


#4

Thanks.
It worked!


#5

Thanks, that solved it for me, too.


#7

This worked! Thanks @tom


#8

Worked for me as well. Thanks


#9

Ever figure out why only one project was running to this issue?


#10