Docker pull is not pulling the image from public repository

docker

#1

1. The stack you’re using
I am using dotnet core and webpack

2. The exact error message you are getting
Tag latest not found in repository docker.io/promact/aspnetcore-node. It started yesterday(Friday 23rd June, 2017) after the docker outage in CircleCI 1.0.

promact/aspnetcore-node is a public repository on docker hub.

3. Which troubleshooting steps you’ve already taken

  1. tried changing tags to dev
  2. Tried a different repository chintans/asp-node
  3. tried hosting in a private repository on AWS

All of the above solution gave the same error

Any recent changes either in the codebase or the stack
No changes

What happens when you run the tests locally
I have tried docker pull for the above mentioned image on few other remote servers and they all seems to work.

What is supposed to happen when your build runs
It should fetch the docker image and build my custom image which is then deployed to Amazon ECS


#2

Can you give me a link to your build?


#3

https://circleci.com/gh/Visualogyx/api_dotnetcore_main/461


#4

Is there any updates to this issue? This is affecting our deployment systems


#5

CircleCI 1.0 hasn’t had a recent version of Docker in a while (and it won’t). I tried running docker pull promact/aspnetcore-node in a 1.0 build and it failed for me. I think something about that image or how it was made is disagreeing with the version of Docker that CircleCI 1.0 is using. It works on my local machine but then again I’m running a recent Docker binary.

I also tried running docker pull promact/aspnetcore-node in a CircleCI 2.0 build and it worked perfectly. Would migrating to CircleCI 2.0 be possible for you? Not only would this problem be avoided, your build may actually complete faster as well.


#6

Thanks, moving to CircleCI 2.0 worked for me. Builds are much faster too. Thanks for helping out


#7