Docker pull can't find tag even if exists

docker

#1

When we are trying to pull a docker image with a specific tag, we are getting the following error:
Pulling repository docker.io/xxx/xxxx
Tag yyy not found in repository docker.io/xxx/xxxx
docker pull xxx/xxxx:yyy returned exit code 1
Action failed: docker pull xxx/xxxx:yyy

But the tag yyy is exists. when I’m running: docker pull xxx/xxxx:yyy from my computer it works correctly.
If i’m ssh’ing to the build machine, and runs docker pull xxx/xxxx:yyy, I’m getting the same error.
Is there any known issue? How could we fix it?

Best regards,
Adam


#2

Is it a public image? If it is private, maybe you’re getting this because you’ve not logged into the registry?


#3

It’s a private image.
I’m logging in first and then pulling the image.
It worked before. all of a sudden it stopped working.


#4

I had the same issue on some builds this morning :

Pulling repository docker.io/library/ubuntu
Tag 14.04 not found in repository docker.io/library/ubuntu

When I retried them a few hours late, the docker pull worked fine. Must have been a transient issue at the docker repository, or some issue in circle connection to it.


#5

You both seem to be using Docker Hub, so perhaps that’s it. By default, pulls are encrypted, so CircleCI would have very little way to interfere with it.


#6

@halfer do you know if there is a circle specific equivalent that would be more reliable?


#7

@earlrob: there isn’t a CircleCI specific registry, as it’s an open-source standard. I use GitLab, which works fine for me.


#8

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.