Deployement by SSH connection to remote server fails : Timeout

ssh
keys

#1

Hello,

In order to deploy our solution on our remote server (debian), i had to setup the ssh connection between circleCI and our server, i followed the tutorials on this website and read the forum a lot but i can’t manage to get a connection, it get blocked at the ssh connection (i assume it waits for the password input) circleCI

I tried the same process with my personnal linux machine and i can connect with DSA (or RSA) keys to our server.
Just so you know, I created the keys on the server or my personnal machine: in both cases it doesn’t work (tried RSA or DSA, didn’t change a thing). I register the private key on CircleCI SSH Permissions of my project, paste manually the public key in the authorized_keys in the folder .ssh of the root of my server (i need to connect as root) and here is the code i use to deploy to our server (the fingerprint i register is the one referring to the private key registered in SSH permissions).

- add_ssh_keys:
         fingerprints:
            - "fd:c6:87:a4:8a:b1:3b:d7:6c:b7:bb:13:b7:95:23:62"

 - deploy:
         command: ssh -vv -o "StrictHostKeyChecking=no" root@"ADDRESS OF MY SERVER"

(Sorry for not using a snippet for the code, I don’t know how to use it with this editor and since i’m a new user i can’t add more pictures).

To be honest i’m quite lost in this situation, any idea why it get stuck and how i can fix it ?
Thanks you in advance.


#3

I have the exact same problem trying to ssh or scp into the server I need to deploy the build. I’ve connected through SSH to the build machine …and the only thing I get is timeouts when trying to reach the domain “photoworkflow.studio”, I’ve also tried with the actual IP of the server, and I get the same result.


#4

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.