Container Image Update 201511-01

container-image

#1

We will update our build container image between 30th Nov and 6th Dec.

Please be aware that this update contains some breaking changes for Go builds, so please be sure to checkout the following details if your project uses Go.

Breaking changes

  • Go: 1.4 => 1.5.1

If you still need to use Go 1.4, please put the following to your circle.yml.

machine:
  post:
    - sudo rm -rf /usr/local/go
    - if [ ! -e go1.4.linux-amd64.tar.gz ]; then curl -o go1.4.linux-amd64.tar.gz https://storage.googleapis.com/golang/go1.4.linux-amd64.tar.gz; fi
    - sudo tar -C /usr/local -xzf go1.4.linux-amd64.tar.gz

dependencies:
  cache_directories:
    - ~/go1.4.linux-amd64.tar.gz

New packages

  • Ruby 2.1.7
  • JRuby 9.0.3.0 9.0.4.0
  • PHP 7.0.0RC7
  • Node v4.2.2 v5.0.0 v5.1.0
  • Docker Compose 1.5.1

[Update 30th Nov]
We’ve discovered that Cassandra was upgraded from 2.2.2 to 3.0.0 in the new container. This upgrade makes it not possible to start Cassandra unless you are using Java8. This upgrade was not intentional, so we are now working on downgrading.

In the meantime, please put the following line in your circle.yml if Cassandra doesn’t start in your build.

machine:
  pre:
    - sudo apt-get install cassandra=2.2.2

  services:
    - cassandra

Supporting Golang 1.5.x
Add docker-compose to build environments
#2

#3

Hi. I think it would be much more easy to install and support Go via https://github.com/travis-ci/gimme as it would allow people to select different versions of Go easily.


#4

When will PHP 5.6.16 be coming?


#5

please update npm version when node.js version increased.
we got build error on new container.

npm ERR! Linux 3.14.28-031428-generic
npm ERR! argv "/home/ubuntu/nvm/versions/node/v5.1.0/bin/node" "/home/ubuntu/nvm/versions/node/v5.1.0/bin/npm" "install"
npm ERR! node v5.1.0
npm ERR! npm  v2.13.5
npm ERR! code EBADPLATFORM

my local (node.js default) environment

$ node -v
v5.1.0
$ npm -v
3.3.12

#6

@GrahamCampbell Sorry, looks we missed the version. We’ll install in the next image release.


#7

@vvakame Do you get the error only when using node v5.1.0? What version of node do you specify in your circle.yml?


#8

We have the npm problem on node v5 too:

node:
    version: v5

#9

PHP releases are very frequent, so always good to check when doing an environment update. They’re normally every 6 weeks.


#10

Having the same issue. Using either Node v: 5.0.0 or 5.1.0 in circle.yml file. Is there a work-around for this?


Wrong NPM version with Node 5.0/5.1
#11

@craineum @tsing @vvakame We have a workaround for this issue. Please take a look at Wrong NPM version with Node 5.0/5.1


#12

#13

Just an FYI for other golang users. I added - go get github.com/tools/godep at the end of the machine/post section. It failed with permission denied. If you need to do something similar, add a sudo chown -R ubuntu:ubuntu /usr/local/go.


#14

I ran in to some trouble with Go version, checked https://circleci.com/changelog but didn’t find this change. Do you have some rule which changes are changelog-worthy and which aren’t?


#15

We don’t put image updates in the changelog, we are going to be announcing image changes here on Discuss. The changelog is mostly for updates to the application itself not base images.


#16