CircleCI Badge not displaying on private repository

I can’t seem to make CircleCI Status badge display on my private GitHub repository.
Here’s how I constructed the string in

[![Build Status](<my-private-network>/<my-private-project>.svg?style=svg&circle_token=<my-api-token>)](<link-to-circleci-pipeline>)

I’ve also made sure to create API token labeled as ‘Status’.

camo.githubusercontent returns 404 and I’m unable to display it properly in my readme. Am I missing something, or is this bug report indeed?

:wave: If you go to the raw link<my-private-network>/<my-private-project>.svg?style=svg&circle_token=<my-api-token> in your browser, does it show the badge correctly?

I’m curious as to whether this is a problem with the badge generation or if the problem only happens when it is embedded in the readme.

I’m having the same issue. The raw link works in my browser (with and without the Circle token) but camo.githubusercontent won’t display it.

I had the same issue and adding the circle_token=<my-api-token> parameter to the URL fixed it.