Github badges broken


#1

When I include the Circle badge on the readme in our github account, it shows up broken. The original link loads but Github’s CDN returns 404. I believe it’s related to the headers being set by your server per this thread https://github.com/github/markup/issues/224

Do you have any plans to fix this?

I emailed support and was not helped.


#2

Is this a public or private project? I am not having any issues on my public repos, so its unclear what his is happening. For example https://github.com/levlaz/braindump works just fine.


#3

It’s a private project. I had style=svg, I also tried the styles on your braindump repo which also doesn’t work.

Here is the code I’m embedding on the README.

[![Circle CI](https://circleci.com/gh/hiringthing/HiringThing/tree/master.svg?style=shield&circle-token=:circle-token)](https://circleci.com/gh/hiringthing/HiringThing/tree/master)

Here is what is showing on our README along with the source. Looks like a github caching issue.


#4

Thanks for the additional info, let me play around with it on a private project and see if I can get to the bottom of this. I will get back to you soon here!


#5

A GitHub member recommends headers to set no cache, expiration time, etc. All that seems to be set for bade request so I’m not sure what would be causing the issue.


#6

I’m having the same issue with this. Has anyone figured out the issue?


#7

I am having this problem with my private repo too. Same result as @joshuasiler


#8

In order to fix this issue you need to set the new API key in Circle Ci, and name it e.g. GitHub badge, and then add that token at the very end of the link, like noted in the documentation: https://circleci.com/docs/status-badges/ (look at :circle-token)


#9

Your documentation doesn’t show anything about a Token, @Aleksandaar … can you advise?


#10