Cannot make public Bitbucket repo Open-Source


I apologise if it is a duplicate, but I was not able to find anybody having a similar issue.

I am currently trying to set up CircleCI for my open source project available under the following public repository. [Currently all CircleCI work is done in branch ‘test_update’]:

However, in the ‘Advanced Settings’ of my project in CircleCI interface I get the message Your repository must be public to enable this feature and consequently I am unable to mark my project as “Free and Open Source”. I have logged in to CircleCI with my Bitbucket account.

I imagine that I must have missed something trivial, but I am having trouble to figure out what was it. I would really appreciate help!

You do have the ‘This is a private repository’ setting set to off (no tick in the tick box)?

I just tested by making a fork of your repo and then pointing CircleCI at it - when I then checked the CircleCI setting it had automatically set the Free and Open Source option within the project.

Thanks for the help!
‘This is a private repository’ setting in Bitbucket is set to off in the ‘Repository Settings’. I double checked it right now. I tried to ‘unfollow’ and ‘follow’ the project in CircleCI as well but sadly it had no effect.

What may be relevant is that the project was initially started as a private repository. It was changed to public only after some time.

You may want to send a message to their support team as such an issue may need them to look at low-level logs.

Indeed the issue was fixed after contacting CircleCI support.